Mike Russo's ParserComp 2021 Reviews

I was going back and forth on doing reviews this time out, since I’m rather behind on my IFComp entry and should really be working on that! But one always needs an outlet for one’s vices, and procrastination via overly-wordy reviews are my drug of choice.

As per usual, I’m playing in a random order, with games I tested last in the queue. I’ll fill this post out with links to the reviews as I write 'em.

Acid Rain, by Garry Francis
The Arkham Abomination, by catventure
Black Knife Dungeon, by Arthur DiBianca
Daddy’s Birthday, by Jonathan8 (and Ruth)
Danny Dipstick, by Garry Francis
The Faeries of Haelstowne, by Christopher Merriner
Fivebyfivia Delenda Est, by Andrew Schultz
Foreign Soil, by Olaf Nowacki
Grandpa’s Ranch by Kenneth Pedersen
Grooverland, by Brian Rushton
Gruesome, by Robin Johnson
Loud House ‘game on’, by Caleb Wilson
Return to the Stars, by Adrian Welcker
Somewhere, Somewhen, by Jim MacBrayne
Snowhaven, by Tristin Grizel Dean
The Time Machine, by Bill Maya
Waiting for the Day Train, by Dee Cooke
Yesternight, by Robert Szacki

13 Likes

Snowhaven, by Tristin Grizel Dean

The central business of this evocative Adventuron game is cooking, and appropriately enough, on starting up you’re given a choice of seasonings: the story can be served up pleasant, “emotive” (said emotion being melancholy), or sinister. Of course, sometimes chefs who vary a dish too many different ways find their reach exceeds their grasp, and Snowhaven unfortunately runs into same coding issues that add a sour note to proceedings. But like the old family recipe the protagonist cooks for their visiting sibling – a hearty mushroom stew – its warm, earthy flavor overcomes such minor mistakes.

I haven’t played many Adventuron games, but almost uniformly, I find they set a very strong mood – and that’s the case here, too. The austere, near-ascii graphics are certainly a draw, but the prose isn’t far behind: it’s typically unobtrusive, but every once in while I’d come across a line like the one describing freshly-dug parsnips as “white and wrinkly as a witch’s finger” and smile. The two variations I played – pleasant and emotive – share the same map, plot, and most of their puzzles, as well as a similar wintry, lonely vibe. But they each put their own spin on things through a few well-recast details. Praying at the grave of your grandfather in the pleasant version leads to a wistful reflection on how one generation cares for the next before passing on, for example, whereas in the emotive one the grave is your wife’s, and prayer leads to a moment of sadness and regret.

There’s not so much a plot here as a situation: we’re in a primeval, near-abstract wilderness – a person, their dog, a stream, some books – with Snowhaven suggesting a few reasons why they might be out there and how they might feel about it. Then the business is all about gathering some ingredients so you can welcome a long-unseen relative with a gift of food. The puzzles are similarly low-key, as most of them just involve finding bulbs of garlic or hardy herbs in the places you’d expect them, then chopping and throwing them in the pot.

There are a couple harder puzzles that skew more traditional – guessing a locker code from careful examination of the protagonist’s home, building a snare to catch rabbits. And contrarily, there are also a few places where the game requires the player to be assumptive about what they want to do in a way that doesn’t comport with text-adventure conventions (I’m thinking of the puzzles where you need to find the lost soap, or get bait for the fishing rod – the solutions are completely logical, even obvious once you know the trick (FIND SOAP and DIG WORM) but they’re nonetheless tricky since you need to interact with objects that aren’t “really” there). Both these approaches mix things up, but I still preferred the more quotidian tasks that make up the bulk of the game, as they better fit the gentle, lonely mood that’s the major strength.

I have a second expectation I bring to an Adventuron game, which is that I’ll struggle with the parser – I understand action construction isn’t as robust as in TADS or Inform, and it has some distinctive foibles, like the way it sometimes bluffs you about the existence of objects that aren’t actually there. Snowhaven suffers from these issues, but unfortunately adds some significant bugs on top. Some of these are just silly, like being told I couldn’t leave the cabin without the soap in the same response that then told me I’d successfully left the cabin without the soap. But my first emotive playthrough dead-ended when TIE ROPE led to an attempt to tie it to itself, and then the thing simply vanished. And I didn’t win my second time either, since I couldn’t get carrots out of the storage locker – TAKE CARROTS led to “You take a few carrots out of your store of frozen vegetables”, which seemed promising, but after a line break I saw “You can’t do that,” and in fact no carrots were ever taken.

There’s definitely been some care taken with the implementation – there’s a lot of scenery, I only found one typo (“No sooner than you sitting down to rest”), there’s an achievement list, and unnecessary actions like the aforementioned PRAY are rewarded (speaking of rewards, there’s also a potentially-remunerative easter egg that I felt clever for finding). But the coding of the actual game logic doesn’t have the same attention to detail, which is an awful shame. A similar misstep is the requirement of pinging the author to get a password to access the third, “sinister” take on the story – I’m already fairly sure I’d get less enjoyment from a less-gentle version, and it’s probably not wise to add an additional barrier to entry when there are 17 other Comp games waiting to be played.

But in the end I didn’t find these drawbacks all that meaningful. Snowhaven isn’t a game you play to be a completionist, or for bragging rights for working out all the puzzles – it succeeds at creating a place and a mood, with everything you do in that place rather incidental. I’ll look forward to an update or smoother post-Comp release, and maybe one day check out the version where I can be eaten by a bear, but I don’t need anything more from Snowhaven beyond what I’ve already gotten.

8 Likes

Loud House ‘game on’, by Caleb Wilson

A quick disclosure to start out this review: while I don’t know him personally, Caleb Wilson was an early and perceptive tester on the game I wrote for last year’s IFComp. I don’t think that dramatically undercuts my ability to assess a game with a reasonable degree of impartiality – one strives for professionalism, after all – but I definitely went into this one with some goodwill.

That goodwill was quickly tested, though, as Loud House ‘game on’ doesn’t make the best first impression, with doodly cover art, no ABOUT text, and a default X ME response. The basic setup – you’re a kid who wants to buy a new video game, and needs to collect some stuff from your siblings to make that happen – is fine enough, the writing is enthusiastic in a way that’s occasionally catching, and while the jokes are juvenile a good number land, but there are still tons of typos, objects with default descriptions, takeable scenery, and guess-the-verb challenges. Trying to figure out what Caleb was getting at with this was bewildering, and I wondered if it was aiming at parody, or if there was a meta layer I was missing? Eventually I got to a point where I couldn’t figure out how to progress, and in frustration I checked these forums in search of hints or a clue as to what was going on, and I came across this post.

If you have the common sense God gave gravel, you’ll see where this is going: Loud House ‘game on’ was written by a different Caleb Wilson, who is ten and entered a fan-fiction game about a cartoon he likes into the Comp (as one of approximately ten million Mike Russos, including at least one other who posts about IF stuff occasionally, you’d think I’d be more attuned to such things). Upon finding this out, I blinked, looked over the transcript I’d been annotating with increasingly-snippy complaints about spelling and grammar issues, and felt like the worst human being in the world – and then went back to the game and, expectations appropriately reset, had a much better time with it.

So yes, there’s nothing pomo here, it’s just a first game from a young author with a good amount of first-game-itis, but actually some real promise too. What starts out looking like a simple collectathon of running around hoovering up every quarter you find actually goes through two game-changing shifts, with a second act that riffs on a bunch of additional cartoons in a bunch of higher-action mini-scenarios, and a riddle-y finale. This change of pacing enlivens the mid-game, and I found the humor in this section landed better for me (I especially liked the joke that sees a lion suddenly pop up in your inventory), though maybe that’s because I was more familiar with its references and tropes than the Nickelodeon cartoon that’s the basis for the first bit.

While a couple additional passes for polish wouldn’t go amiss to iron out grammar, tweak some puzzles (I was stymied by the football puzzle since it didn’t seem to make sense given the rules of football), and add some synonyms (a hint for anyone else having trouble using weapons – try throwing them rather than hitting or stabbing with them) Loud House ‘game on’ is actually quite a good time. So now the next time I see a game from Caleb Wilson, I’ll still be looking forward to playing, regardless of which of them wrote it!

13 Likes

Thanks for the review :slight_smile: My Caleb will be pleased I’m sure. For the record: I warned the other Caleb Wilson this might happen, maybe I should have warned the rest of the world…

7 Likes

I thought this was really funny. I could see it happening. I think the other Caleb Wilson is going to have to start using his middle name again, like he used to sometimes do in the early days.

4 Likes

I am laughing so hard right now! Congrats to the other Caleb.

7 Likes

Danny Dipstick, by Garry Francis

If you are a gamer of a certain age, you will look at Danny Dipstick’s title and blurb (“You need to find a girlfriend, but all the girls think you’re a dork. Try to overcome your dorkiness to pick up a girl”) and feel a cold pit of dread form in your stomach, suffused by a terror far beyond what your quotidian Amnesia-clones could ever hope to induce: yes, in space-year 2021, we’re looking at a Leisure Suit Larry parody (though apparently this is a reimplementation of a 1999 original, which is still late in the day for such a thing but is a bit more understandable).

I never really played any of the LSL games (one friend had a copy of the third one but we couldn’t get very far, so my only memories were of answering dry trivia questions to defeat the copy protection, and then making a beeline for a set of binoculars that allowed you to see an at-the-time-exciting pair of pixelated boobs), but my understanding is that to the extent they worked, it was because most of the jokes were at the protagonist’s expense and the games weren’t nearly as lecherous as they seemed to be. This is a delicate balance to strike at the best of times, and given the way parody heightens and deforms its inspirations, my hopes were not high.

The good news is that Danny Dipstick isn’t going for parody or exaggerated laughs, so it mostly avoids the kinds of gratuitous offensiveness I’d feared. The bad news is that I can’t tell what it actually is going for. Neither the puzzles, the plot, nor the writing seem to be trying to stand out in any way – the game is perfectly functional and moves the player from point A to point B, but I’m couldn’t tell you why the author wrote this game in this way at this time. There’s perhaps a clue in the ABOUT text, which reveals that this was originally an assignment in a computer science class, and while Danny Dipstick is polished far above the level that implies, I couldn’t shake the feeling that the game was written to build and demonstrate familiarity with programming, with the player experience coming second, not because it’s actively bad, but because it’s frustratingly flat.

The gameplay provides a good example of what I mean. You’re told from the jump that there are three things you need to do to get a girlfriend: fix your bad breath, get some better clothes, and develop social skills (one of these seems harder than the others…) These objectives are available at any time via the STATUS command, and each can be met in a single, clearly-signposted step. The game plays out over a small map of maybe a dozen locations, most of which offer up two or three possibilities for interaction. There are a number of characters, all of whom are looking for one and exactly one item, and who as far as I can tell respond only to TALK TO, with ASKing about other topics not leading to anything interesting. The author provides frequent prompting, if not hand-holding, to make sure you’re able to progress (my transcript is littered with a lot of “You should…”s), which keeps things on track but drains the sense of agency.

The puzzles are of a piece with this general approach. There are two main puzzle chains, both of which require a little bit of poking around to start, but which run quite similarly: once you find the initial object, it’s very clear who you should give it to, which then leads to you acquiring a second object with a likewise obvious use, and then there’s an even more obvious final step to take to wrap up the game. Everything works fine, but there’s nothing distinctive or interesting about any of it.

As for the writing and plot, they’re certainly there? Again, this is largely a positive, because when I went onto the dance floor and saw two women described primarily via the colors of their dresses and hair, I cringed. But it turns out once you solve the relevant puzzles and talk to them they’re reasonable people, partnered up but happy to chat with Danny and help him out after he does them a good turn – and while his opening lines are awfully smarmy, they’re not too bad in grand scheme of things, and once it’s clear they’re not interested in a date, he’s basically respectful. This is much much better than gratuitous offensiveness, of course, but it’s also kind of boring! There aren’t many real jokes, or at least few that landed for me (there’s a bit about a guy taking up collections for the Society for Retired Adventurers…), but it feels like the game isn’t even trying for laughs.

(I should point out that the exception to this overall inoffensiveness is the character of the convenience store clerk. He’s described as ethnically Indian, with a thick, hard to understand accent, and his main personality trait is extreme indolence. And after you complete a transaction, he says “thank you, come again.” So this is Apu from the Simpsons, again presented not so much as a parody or the opportunity for a joke, but just as Apu from the Simpsons, plus calling him lazy. Not great!)

Danny Dipstick at least doesn’t wear out its welcome – it takes maybe ten minute to go from utter loser to having a beautiful girlfriend – and it’s cleanly implemented in Inform 6, with no parser awkwardness to speak of. But I found it a quintessentially inessential game, and there’s not much I’m taking away from it beyond the mild relief that it wasn’t as bad as I’d feared.

(Transcript attached)

dipstick mr.txt (33.6 KB)

7 Likes

Acid Rain, by Garry Francis

The gods of randomization decided I should play both of Garry Francis’s games back-to-back, so here we are with another older-school Inform game – but instead of the tepid parody of Danny Dipstick, with Acid Rain we’ve got a puzzle-y adventure that I quite enjoyed. Sure, it’s got some player-unfriendly archaisms, like an inventory limit that adds nothing to the gameplay and a too-tight time limit that required a restart, but there’s definitely pleasure to be had in scratching a familiar itch in a well-designed, well-implemented playground.

Per the ABOUT text, this is actually a reverse-engineered reconstruction of a game from the late 80s, which helps explain the title – I grew up in the northeast U.S. in a similar time period, and remember hearing lots of worrisome news stories about acid rain, so using it as an ominous near-future setting element makes sense in world before a regional cap-and-trade system (the endearingly-named RGGI) got the problem under control. Acid Rain isn’t about getting recalcitrant Reagan Administration officials to take Canadian concerns about trans-national pollution seriously, however – instead you’re some flavor of scientist driving home from a conference when your car dies due to a drained battery. Good thing your car fetched up right outside the mansion of a mad scientist, who’s surely got a replacement battery stowed somewhere amidst all the junk from their electrical engineering hobby!

It doesn’t take long for the structure of the game to emerge – you’re quickly trapped in the house, and in addition to finding a new battery, you also need to gather a bunch of components to create a door-opening gadget so you can escape. There are also a host of strangely-behaving animals scattered throughout the mansion, serving as both barriers and occasional sources of assistance. Some of this is explained (the animal stuff), but some of it you just have to chalk up to text adventure conventions (why the mad scientist made the front door automatically trap visitors inside, but then also provided a sign clearly laying out the situation and a note with a list of the parts needed to build the opener).

This isn’t the only way Acid Rain is a bit of an archaism: as mentioned above, there are some retro design touches that maybe provide some aesthetic pleasure to grognards, but serve mostly to annoy in the here and now. The refusal to allow X NOTE or X SIGN to reveal what’s actually written on them is just a niggle, and the inventory limit isn’t too harsh, though I ultimately found it rather pointless since it doesn’t force any decision-making or interesting gameplay, just a bit of backtracking tedium. The time limit is the worst offender here – you start out with a flashlight with limited battery power that will die if you take too long exploring the dark house, which I don’t believe you can recover from. There are new D-cells available within the house, and they appear to function indefinitely, but they’re not in a place you’d reasonably expect to find them meaning it’s pretty much blind chance whether you come across them in time to avoid a restart.

On the flip side, the game is well implemented, with a surprising amount of scenery implemented and some nice conveniences too. It’s definitely possible to die, but a quick UNDO sorted any trouble out, and there’s a character who provides in-game hints. I didn’t need to use this feature much, though, since the puzzles are typically well clued and fit the world reasonably enough once you grant the premise. There’s nothing you haven’t seen before, but they’re satisfying to work through, with a bunch of keys to juggle and animals to feed on the easier end, and a secret passage to find and a code to decipher on the harder side. The code was probably my favorite puzzle, as it’s possible to solve via brute force but also has a good number of clues for those who don’t like grinding through such things.

Is Acid Rain anything other than a scavenger hunt through a medium-sized map of rooms that primarily hold one gettable object and one bit of scenery? No, and if that kind of thing isn’t your jam, or you’re easily turned off by clunky gameplay elements that haven’t stood the test of time, nothing here is going to change your mind. But if you’re the sort of person who sometimes looks at a long list of ice cream flavors and picks a vanilla – occasionally, one just wants the simple thing – Acid Rain fits the bill.

(Transcript attached)

acid rain mr.txt (122.6 KB)

7 Likes

Just to say… Thanks for taking the time to review and share the reviews!

Adam :slightly_smiling_face::pray:

1 Like

Somewhere, Somewhen, by Jim MacBrayne

Reader, a confession: I have played a large amount of IF over the last few decades, but have never been able to dip more than the tiniest toe into Zork before I get bored and wander off. I’ve faffed around in the white house, reconnoitering the mailbox and display case and thinking “this will be fun!” as I lift the trap door and enter the Great Underground Empire – but despite making that descent at least half a dozen times, I have no clear memories of actually accomplishing anything down there, my impressions a uniform smear of over-large maps and exploration-punishing mechanics like time and carrying limits and the murderthief, which always lead me to abandon the attempt.

I’ve read a bunch of appreciations so I certainly understand why this works for others, and some of this is definitely down to expectations – I got into IF in the early days of this century, when a wholly different set of design aesthetics was in the ascendant, so while I’m as subject to nostalgia as the next person, I’m not nostalgic for Zork. And some of it’s down to the ridiculous plenty of the modern age – when Zork was the only thing going, beavering away at its devilish puzzlery was I’m sure the glorious work of many a late night and weekend. Here and now, though? It’s hard to justify the time investment to myself when I’ve also barely scratched the surface of Counterfeit Monkey, to pick one example from literally hundreds.

I bring all this up to lay the groundwork for my two central takeaways for Somewhere, Somewhen: 1) it’s pretty Zorky; and 2) I really didn’t get on with it, partially though not exclusively for the reasons I’ve never got on with Zork. If Acid Rain, the game I played right before it in the Comp, was an example of an old-school game whose archaisms don’t stand in the way of contemporary enjoyment, Somewhere, Somewhen serves as a caution for how easy it is for this approach to go awry. A custom-parser fantasy adventure with a wacky mix of magic and anachronistic technology is certainly appealing to a specific audience, but I think even their patience would be tested by SS’s sprawling, red-herring-choked map (including one literal red herring – no, this doesn’t make it better), arbitrary puzzle design, and too-dense prose. There are some individual puzzles that aren’t bad, and the custom parser is pretty well implemented, but ultimately I didn’t find much to enjoy.

The game doesn’t put its best foot forward, which is part of the issue. After a quote from The Raven that doesn’t connect to anything in the game so far as I could see, you get a vague but wordy introduction where you’re plucked from your ordinary life (in the regular, real world? It’s unclear) and told by a mysterious voice from beyond that you’ve been chose to retrieve an unpronounceable MacGuffin that the mysterious voice and pals have somehow lost (adding insult to injury, when you finally find the MacGuffin at the end of the game, it has only a default description, underlining the arbitrariness of proceedings). Then you show up in a deserted labyrinth, and well, this is the description of the initial location:

Yes yes, lamp and sword, but it’s too wordy, and the parser doesn’t allow you to abbreviate the inscriptions to FIRST, SECOND, etc., so you’re in for a lot of typing to fully explore things. And before you’ve gotten a chance to get to grips with your surroundings, the mysterious voice comes back and tells you how to solve the first puzzle, which by that point I’d only started to dig into.

After this rocky beginning, it does improve for a bit – that initial puzzle gives you some magic words that open portals to various other locations, which each have a couple of puzzles to resolve, mostly hinging on unlocking doors and collecting kit. And the writing starts to get a bit more fleet, though it’s never a real draw. By the time I was about a third of the way in, though, I started having additional complaints. First, the various locations you explore are fairly monotonous – there’s a castle, a cellar, and a hall that all felt pretty much interchangeable, though a deserted village at least somewhat changes things up – but have large, sparse maps. There’s an EXITS command to help with mapping, but it has some issues, like closed doors not being listed and a few exits opened by puzzle-solving not being included even once they were available. There are also one-way connections that require a lot of step-retracing, and non-cardinal directions (northeast, southwest, etc.) are used without much rhyme or reason, which complicated getting around to no real benefit.

The other issue that reared its head at that point was the inventory limit. Its existence was predictable enough, but what was less predictable was that worn items still count against it, and the conveniently-provided carryall you get towards the end of the first act also has its own limit. And as mentioned above, there are rather a lot of useless items and red herrings scattered throughout the game – in addition to a number of critical ones only findable via SWEEPING DUST and LOOKING UNDER and LOOKING BEHIND – so you will run into this limit, and it will require a whole lot of inventory-juggling and backtracking, which combined with issue number one (remember those sprawling maps?) makes much of the mid-game an unfun exercise in logistics.

The puzzles themselves are a mixed bag. Most are pretty traditional and straightforward – collecting ingredients for a witch’s brew, navigating a maze, solving riddles, getting an iron key with a magnet – but there are a few that rely on authorial mid-reading. One late-game puzzle requires realizing that a safe has a key lock rather than a traditional dial one, but there’s no indication of that in any of the descriptions I found. And then there’s the riddle that had me tearing out my hair – I’m going to spoil it, because if you try to play Somewhere, Somewhen you’ll need it spoiled to. Getting into the witch’s cottage requires entering a code on a keypad (remember what I said about the wacky mix of magic and technology?), clued with the following message:

Winifred accepts digits
spider’s legs and octopus 
arms on weekdays.

Right, so that’s 885, easy enough. But no! “Digits” is meant to indicate that you should type a 10, and “weekdays” translates as 7. Maybe this is a Downton Abbey joke (you know, “what’s a week-end?”) but it sure requires some trial and error. And some of the puzzles like this are item-based, so playing the game straight would require a whole lot of item-hauling to enable you to run through the red herrings and figure out which are actually useful. Others might have the patience for this, but I very much don’t, especially when the rewards of advancing the story and exploring more of the setting are pretty lackluster – I started having regular recourse to the hints about halfway through, and didn’t regret it one bit.

I’ll close by repeating that the custom parser is actually pretty good for such things. It doesn’t like abbreviation of objects, and you can’t interact with objects in containers or on supporters, even to examine them, without first taking them (I haven’t mentioned the inventory limit yet this paragraph, have I? Yes, this makes the inventory limit even more annoying. And it applies to the caryall too). But other than that, it affords most of the conveniences of a modern system, including being able to recall recent commands. It’s clear a lot of time, energy and enthusiasm went into coding it, and I’m sure that’s true of this big game as a whole – and for someone looking for another Zork to pour hours and hours into, I could see Somewhere, Somewhen being the most fun they’d have in this Comp. But for someone like me, who’s barely ever been eaten by a grue and sees a flood control dam and just wishes the whole thing were over, it sadly misses the mark, especially with a bunch of other games I’m excited to get to.

3 Likes

Thanx for the good review! I can understand the confusion between the Caleb Wilsons, and see how it would be a bad game for someone with lots of coding experience to create between the guess the verbs, In-acurate challenges, and stuff like that. It’s just that I couldn’t figure out how to make verbs at the time (except when I created squirting as a verb at the end of my project) or how to hint them. But for my next game (Which I’ve almost finished), I’ll try to do better, and make more verbs. (P.S. Now that I think about it, I actully don’t know how you figured out that you needed to throw the weapons.)

5 Likes

Oh, wow, I totally didn’t pick up on the verb thing! I just learned Inform last year, and when I started I actually had more trouble with modifying the built-in verbs, so I created new ones willy-nilly and shied away from using the regular ones. But making a game is a great way to figure this stuff out, so it’s awesome that you’re already close to done with your next game!

For figuring out throwing, I think it was pretty much just trial and error – you’d provided strong clues that I needed to hit the guard in the head, so eventually I hit on the right answer, after trying variations of HIT, STAB, THWACK, etc.

Mind if I ask for a smalll spoiler on all the locked safes? I wasn’t able to figure out how to do anything with them and it’s kind of bothering me :slight_smile:

Congrats again on the game!

Thank you so much for the time and effort you spent playing my game and writing this review. I appreciate it so much. :smiling_face_with_three_hearts:

4 Likes

Secon pair of D-cell batteries also can be dried up.

I tested this game, and I couldn’t put my finger on one thing that worked particularly well for me. The short answer, without horning in on your thread: yes, acid rain was a concern, and a different fear from the “duck and cover” drills we had. It was based more on science than fearmongering, and because of that, the fear of acid rain didn’t paralyze me, but I still cared about it. Acid Rain brought back those memories but did more.

Also, since I’m here, thanks for making this thread. I think the authors appreciate the transcripts.

Not in the release version. The replacement batteries last forever. I think I mentioned this in the instructions. (Yes, I know. No one ever reads instructions.)

I really liked imagining you writing a meta game with lots of typos and verb issues for fun :grinning_face_with_smiling_eyes:

3 Likes

I am not playing parsercomp games as I am working in an alfatest.
More sooner than later I will start playing this comp games.

Waiting for the Day Train, by Dee Cooke

Aesthetics predominate in Waiting for the Day Train, a game of two parts: this Adventuron amuse-bouche presents a non-interactive pixel-art opening, and then segues over to photographs to accompany the puzzle-solving gameplay. Living up to my expectations for Adventuron, both parts are absolutely gorgeous, and while I’m not sure they ultimately cohere into a united whole, they’re individually well worth experiencing.

It feels a bit odd to lead off a review of a parser game emphasizing what you look at rather than what you read, but I suspect even the most prose-focused of players will have the same response I did. The prologue section is well-written, with an intriguing opening line (“The night is a different world”) leading into some efficiently-conveyed backstory about the main character’s efforts to escape a world of tormenting spirits about to be thrust into everlasting night. But it’s the pictures that accompany the writing that really make an impression: they’re moody, all black and beige and gray, with fat pixels of raindrops streaking the screen; your character, a robed, faceless figure a la Bobbin Threadbare, seems authentically beleaguered just from their posture and way of holding themself.

Once day breaks and you head to the station to catch your train, the visuals completely transform, with the night-time pixel art replaced by photographs. You’ve fallen asleep in the forest near the station, and the environment here is absurdly lush, with the green landscape half-concealing sturdy old wooden bridges and lovely, weathered stonework. These photos create a day-world that’s absurdly pleasant and welcoming, bucolic and nostalgic all at once.

Getting to the train before the time limit is a matter of solving three or four simple puzzles, none of which are very challenging on their own but do put you up against a time limit. While this did mean I had to restart my first playthrough due to overmuch faffing about, the short playtime made the replay painless, and without the deadline the puzzles might feel a bit thin. They’re standard sorts of thing – districting a flock of birds, feeding a hungry animal – enlivened by a bit of unexplained magic, but primarily serve to give you something to do as you explore the lovely setting. The implementation is largely solid, too, with the only niggle I ran into some confusion about how to retrieve a gem from the stream after I’d spied it trapped by some stepping-stones: since it was described as being right near the stones, I’d thought a simple TAKE GEM should work, on one bank or the other – CLIMB ON STONES is what eventually worked to put me in the middle of the crossing, where I could pick the jewel up, but that seemed a bit unintuitive to me.

My only real critique is that it was hard for me to tonally reconcile the peaceful, welcoming daylit world with the foreboding and terrible nighttime (oh, and that reminds me, there’s a typo with “forboding” subbed in for “foreboding” – only error I noticed). The contrast certainly made me want to make sure I stayed in the daytime and didn’t get trapped in the world of eternal night. But while I intellectually understood my character as desperate, rain-soaked and rushing to reach their last chance for escape, the lovely photos made the daytime section so peaceful, homey, and pleasant that the urgency drained away, and I enjoyed it more as a hang-out game, with the challenges feeling less like barriers and more like a prompt to slow down and spend time in a beautiful place. Still, I can’t find much to complain about getting two different aesthetically engaging experiences in one short game, and I found Waiting for the Day Train very much worth a play.

5 Likes

Thank you for the lovely review! The game was inspired by a beautiful place I visited recently :slight_smile:

5 Likes