Writable files not working after switch to Vorple

I have a notetaking system in my game which is basically copy-pasted from the Inform 7 example ‘The Fourth Body’. It was all working fine and dandy until I decided to add in Vorple features for the game to add images and notifications. Now those are working, but I’m getting this error whenever I try to read notes the player has written in the notebook:

*** Error on file ‘playernotes’: tried to open a file owned by another project ***

*** Run-time problem P48: Error handling external file

I’ve tried changing the line where I declare the file from

The file of notetaking is called “playernotes”.


The file of notetaking (owned by project “D9E467E6-D36F-4C72-A55F-8E8FBDD618B3”) is called “playernotes”.

I’ve also tried moving the playernotes.glkdata file into the Release folder to be zipped up, but no avail.

I feel like there must be something simple here that I need to do to make this work. Any tips?

Did you figure this one out on your own, or it is still a problem?

If you’ve figured it out, what was the solution?

If it’s still a problem, can you post some sample code that replicates the issue?

I ended up just declaring a new file and that worked instead for some reason. Then I had a whole swathe of different problems, addressed here: Removing headers from text files in Vorple interpreter - #2 by otistdog