What is wrong with iplayif.com?

Trying to play games through iplayif.com but it’s permanently “Loading…” after uploading file either from a link or from a disk. Launched in Chrome and Firefox. Games from Spring Thing Festival of Interactive Fiction load fine. Does anyone else have this problem? Are there any mirrors?

I’m not aware of any bugs, but there’s always the possibility of newly triggered bugs, especially if they’re somehow caused by higher traffic today. If you do see an issue, please do check the browser console for any errors. Most errors should be caught and reported to the user visibly, but some might not be, and might only be shown in the browser console.

1 Like

I checked. There are no any errors or warnings.

It works only after cleaning cache (ctrl-F5).

It’s been like that since the latest update, I mentioned it in another thread but promptly forgot about it and didn’t come back to it afterwards, sorry. It works the first time you load a game but refreshing the page makes it spin the compass icon without starting the game. I suspect it’s a race condition somewhere in the loading sequence, maybe if the story file loads from cache before the interpreter’s own files it doesn’t start properly.

1 Like

Hmm. Weird.

Someone else on Reddit complained that iplayif.com wasn’t working for them, so there probably is an issue, but I can’t see what it would be.

Thanks, I can reproduce this now. Seems like doing a soft refresh (ie, the refresh button) makes it stall maybe half the time? But never if the console is active…

When it does stall, GiLoad prints this message, so whatever is the issue is after the Parchment launcher code:

GiLoad: trying pre-loaded load (array)...

It also stalls with ZCode, and doesn’t log anything. So probably not anything to do with GiLoad then. I’m suspecting one of these load handlers in AsyncGlk?

Possibly when refreshing it’s too fast, and the load event has already fired? I should also check document.readyState.

Okay I’ve pushed a fix for that issue, and I’m no longer getting refresh stalls. Let me know if you continue to have any trouble with it.

Honestly I’m quite surprised I never experienced this issue before, it was far from obscure. Pretty embarrassing bug haha.


Working on my end! :+1:

1 Like

Confirm. All is good now :gear: :gear:


Hi, I’ve just uploaded a game to textadventures.co.uk, but if you refresh the page, you can only type one command and then the whole game freezes. I’ve never experienced this before playing IF and I don’t know how to fix it, and I need to have this game working ASAP. Any help is appreciated. Thanks!

Nevermind, I figured it out. I just needed to release the game as zblorb rather than Glulx.

Good to hear you worked it out, but for the record, textadventures.co.uk is a completely different and unrelated site to iplayif.com.

1 Like

Having some trouble with Parchment, not sure if I am doing something incorrect or if something is broken. There are some story files stored online.

If I enter the URL to those files, I can download them.

If I use Parchment’s “play a story file on your device” and point to the just-downloaded file, it will load fine.

However, if I enter the URL to the story file on the Parchment page (the same URL I just used to download the file) then it gives a “TypeError: Failed to fetch”.

Does anyone know why I might be able to download the story file, but not be able to use the URL to it in Parchment’s entry box OR by adding that URL after “?story=” at the end of the Parchment URL? Has that feature of “passing a URL” been removed?

Many thanks in advance,


1 Like

What’s the URL? There could be something on the server that stops it being loaded by Parchment.

Anything from the “Obsessively Complete Infocom Catalog” on the E Blong site.

For example:
Zork I:
Passed to Parchment as:

. . generates the error. Entering the URL to the same story file on the main Parchment page also generates the error.

However, if I download the file, then ask Parchment to load the file I have stored locally, it works fine.

It’s working for me…

Maybe you could try a hard refresh (Ctrl + F5)?

Or could your internet be blocking the proxy.iplayif.com domain? That issue has come up once, but it doesn’t seem very common.

Thank you for the quick response. Hard refresh, incognito mode, alternate browser, do not fix the problem.

The domain could be the problem, just not sure where to check for that. I also tried using Firefox. Still a fail, but the error message is a little different: “TypeError: NetworkError when attempting to fetch resource.” Not sure if that’s any more revealing…

I’m at home now. I’m looking to use this as part of a demonstration of IF for a class in school, so I can try it at an alternate site tomorrow and let you know. I’m pretty sure this was working up until this afternoon, but maybe I just never tried it at home until tonight?

Will report back - thank you for the assistance!

Do you know how to use the browser’s developer tools? In the Network tab, what happens when you try to load proxy.iplayif.com?

I’m not very familiar at all, unfortunately, but I was able to open the tools, and when I tried loading that URL, it failed with an “ERR_SSL_PROTOCOL_ERROR”.

what version of what browser are you using on what OS?