Vorple doesn't work with Firefox? [Resolved]

So I was trying to play The Little Match Girl 3: The Escalus Manifold (RPGs are cool yo), but nothing loaded for me when I opened the page. Happened with both the version hosted on Itch and the version on Ryan Veeder’s site. It just gave me a blank screen with links to the instruction manual and the other games in the series at the bottom. Checking the console got me this error message:

Uncaught (in promise)
Object { syscall: “”, errno: 13, code: “EACCES”, path: undefined, stack: “n@https://v6p9d9t4.ssl.hwcdn.net/html/7452266/interpreter/vorple.min.js:2:2849\n3229/t/</</Zt/<@https://v6p9d9t4.ssl.hwcdn.net/html/7452266/interpreter/vorple.min.js:2:83882\n”, message: “Error: EACCES: Permission denied.” }

So I figure it’s a Vorple thing. I tried some other random Vorple games, and none of those loaded with Firefox either. I downloaded Brave browser and tried with that, which worked, but I have to turn off “Brave Shields”, their anti-tracking/fingerprinting/etc thing. Unfortunately turning off tracking protection in Firefox doesn’t solve the problem, even though I disabled everything I could.

Now, I don’t know if I’m missing something or if the magical tech fairies have a vendetta against Firefox in particular, but has this has happened to anyone else? Any way to fix it? (I know I could just use Brave, but I like Firefox. And having to download a separate browser just to play a game is a bit of a hassle, for anyone else who might be dealing with this.)

(Edit: Also, I skimmed Vorple’s Github issues for a minute and didn’t see anything obviously related to this, so either it’s something wrong with my browser or the issues list just isn’t updated all that much? Or I need to pay more attention.)

(Edit 2: Actually it might be this issue, which also gets mentioned in this thread from 2020? Seems to be a Safari thing though, not Firefox. Who knows.)


I’m on Firefox (117.0 (64-bit)) and had no issue opening the game on itch or Ryan’s website or the IFDB. Works just fine here.
What’s your Firefox version?


I’m on 111.0.1 (64-bit), apparently. An upgrade is probably in order…

Edit: Yep, that did the trick. Thank you!