Technical problems with the Worlds Apart hints in Parchment

I’m trying to play Worlds Apart in Parchment on Chrome in Windows 10. The first time I tried to get a hint, the hints displayed fine as long as I kept pressing numbers, but when I pressed q, I got the message “TypeError: Cannot read properties of undefined (reading ‘length’)” in a pink box at the top of the screen. The game wouldn’t respond to anything else I did, so I had to restart. The second time, I couldn’t even past “Continue? (Y/N)” because no matter what letter I press, the same error occurs. Is there any way I can either fix this error, or read the hints elsewhere?


I think that Parchment’s support for the TADS format (which Worlds Apart is in) is fairly new, so there may still be issues. The simplest thing would be to install the official TADS player and use that. You can get it from (get htads_playkit_2517.exe) or

You can also check the Parchment issues page on GitHub to see if anything similar has been reported, and if not, add your own bug report:

I can reproduce the error and will investigate further!

Okay, I think I’ve fixed the error.

Nothing to do with TADS btw, just an edge case in the GlkOte protocol that I wasn’t handling in my new AsyncGlk library. One big improvement I’m finding with Typescript is that when I realise that my specification of the protocol has an mistake, such as saying a property is required when it’s actually optional, I can fix the specification and then the Typescript compiler will check that the rest of the code accounts for it being optional.

1 Like

It works now, thanks!