TADS 3 mkchrtab not working?


I’m trying to write a TADS 3 game in Chinese, and it seems like I need to create the CP936 character map. I am using windows, I downloaded the windows code page from ftp://ftp.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/ and I tried running “mkchrtab.exe CP936.TXT cp936.tcs”, the command ends without error, but nothing is generated. Does anyone know what I might be doing wrong?


I’ve never tried this before, but it looks like you need to alter the table source file you downloaded as described in “Creating a Mapping Table File.” TADS seems to want an ID and a LDESC for the source file, a NATIVE_DEFAULT and INTERNAL_DEFAULT for characters that can’t be mapped, and then a symbol like <-> in-between the character values.

Thanks, though I was following http://www.tads.org/t3doc/doc/sysman/cmap.htm and did add “default_display” line as instructed; the page you linked to is under t2doc, so I’m not sure if anything about these character mapping files have changed between TADS2 and TADS3.

Never mind my bad; for some reason TADS installed with limited default permissions for its directories, I had to fix that before I could write tcm files.