SQL Errors

Running into a few of these today, though a reload or 2 usually clears it up.

I got those yesterday. (Before that, it had been quite a while with everything working great. No SQL errors, and no logging out.)

A day or two ago, I switched to the PHP MySQL driver rather than MySQLI because the latter seemed to be getting too memory-intensive. Sounds like that made things worse. I’ll change it back and see how it goes. Shortly before that, though, I updated to PHPBB 3.10. I wouldn’t expect that to cause an issue, but I can’t be sure.

I saw that too just now. Hitting reload made it go away, but it seems there’s an ongoing server problem.

I’m getting this error FREQUENTLY, and also messages from Chrome that the server sent no data. In all cases, a refresh gets me back into the board, but if I was posting/editing a message, the edits are gone, and no post was made.

I’d say that today, about half the operations I tried ended up with one error or another.

Another data point: I got this same error a couple of times yesterday (3/22) and once again just now. Although most reload fine, this last one took three tries to reload. Since then I’ve been bouncing around the board just fine.

I’ve also been getting the error from time to time over the last couple of days. Usually, a couple of hits to the “refresh” button are adequate to clear it up.

Robert Rothman

I’ve been getting such errors frequently for a few days now. I initially figured it was some kind of problem with the library WiFi.

It happens often: less than half the time, but more than 1/5th, I’d say.


… annnnnnnd … more info. Today, only about a third of my attempts to access threads were coming up in Chrome as “server sent no data”, and refresh “got it right”. However, I just got the SQL out-of-memory error:

[code]SQL ERROR [ mysqli ]

Out of memory (Needed 1048544 bytes) [5]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.[/code]

Here I thought I was lucky because I never got that error… I just did.

Also, maybe unrelated, but I seem not to be getting e-mail notifications of “new replies to watched topics” anymore. EDIT: Or possibly I AM getting them, after a long delay. I just got one with about 5 minutes delay - others I know I should have gotten I never did.

… and today, I’m getting Server Sent No Data from Chrome on almost every attempt to load a thread or a subforum, and it’s taking five or six refreshes to get it to work - if it’s six, the fifth refresh gets me the SQL error. Once I have the thread up, I have no trouble going page-to-page. But going back to the subforum level or from the subforum to a thread brings the error back.

There were quite a few rpm update processes running – presumably stuck. Killing them freed up plenty of memory. Until then, things were running pretty much maxed out.

I think it happened a few days ago when I was attempting to update the server. It sounds like the SQL errors were much more common since around that time. I hadn’t been getting them, but I’m not on nearly as much as others. The MySQL log showed plenty, on an ongoing basis.

At some point, I’m going to need to take HTTPD and MYSQLD down (possibly) and attempt another server update. But when I do, I’ll check the processes to help avoid this from happening again.

I don’t know if this will completely solve the memory problems, but it should help tremendously. You shouldn’t be getting SQL out of memory errors now, at least.

Thanks Merk!

+1 :slight_smile:

Ditto :slight_smile:

You might want to reboot the machine more often. Maybe once a day.

I could, but I think that was a fluke due to the botched system update. Are you still getting SQL out of memory errors even now?

I haven’t seen any errors since.

The problem seems to have cleared up. Thanks!

Just the usual amount of them.