Scroll Thief full release

There is now a full release of Scroll Thief, the second-place entry in IntroComp 2014. Let me know what you think! (Inform 7/Glulx, source code available.)

Eerie. Just yesterday I’d played an IntroComp game where I went “I would SO love to see this finished!”, and today this.

Congratulations on the release! Looking forward to playing it!

EDIT - BTW, you might want to consider a .z5 file for the InvisiClues. You say you want to be true to the Infocom style… well, all the InvisiClues booklets have been translated to .z5 and are more easily available than a webpage counterpart, so even though the web-page is closer to what Infocom did at the time, a .z5 file may be closer to the present reality. :slight_smile:

Plus, of course, I can’t read the InvisiClues on my mobile device, because it doesn’t have a mouse so I can’t hover any cursor above the text. Whereas I can open another .z5 file in iFrotz and easily switch between the two.

That’s a good thought, but I’m not quite sure how to translate InvisiClues for the Z-Machine. I shall look into it.

Does clicking the hints to show them still work, or highlighting? It depends on the level of CSS and JavaScript the browser implements but I tried to make it possible to use them even without a mouse.

Ah, I didn’t think to click them! In that case, you covered all the bases quite nicely. :wink:

A new version is posted, fixing a few relatively obscure but sequence-breaking oversights (one allowed you to get a palantir into the Clean Room while circumventing that entire puzzle, denying them the points; another allowed you to copy yonk without triggering the cutscene and thus prevent Act I from ever ending–it never came up in testing and wouldn’t happen unless you knew about the bug and deliberately tried to break it, but the loophole is closed all the same), and making a few cosmetic changes to the lleps failure messages.

Spent some time on this, without getting very far. Will spend more time on it, because it looks very good.

Also, as a wannabe IF writer, I really appreciate you sharing the source code (even though I haven’t yet looked at it, because it would spoil things)

Putting this game on my MUST PLAY NOW list. Thanks!

I think I found another sequence-breaking bug or two, plus a few more minor issues.

[spoiler]Once you’ve dropped a palantir into the Clean Room the ‘proper’ way, and have learned Blorple, you can Blorple something in the Clean Room through the palantir and then step out of it to enter the Clean Room yourself (as long as you remember to leave the other palantir behind, you can even get back out.) By doing this, you can get the Golden Box, which I gather I was supposed to have the Adventurer get in order to trigger an event. This prevents you from ever getting lleps (for some reason it doesn’t appear if you get the golden box yourself.) There are other bizarre things you can do with this, too, including ending up in a room with the adventurer after your mind-control breaks, while getting messages indicating you’re not in the same room with them.

Even when I don’t sneak into the Clean Room this way and send the adventurer home the normal way, the game talks about another scroll in the room that isn’t there. Did I do things in completely the wrong order by learning Yonk without first triggering the sequence that has you dismiss the adventurer? It wasn’t necessary to have them do anything down there after they hit the oven, as far as I could tell; I used rezrov to open the oven through the palantir, then copied the spell scroll no problem.

Also, by either using lleps while the adventurer is waiting, or by exploiting your knowledge of how to open up the secret passage from a previous playthrough, you can get vaxum before dismissing the adventurer, and cast it on them while they’re pissed at you. You will then continue to get messages about how much they hate you even when Yomin reports that they’re your best friend. This is less game-breaking (as far as I can tell; I haven’t gotten to later when you’re presumably supposed to use vaxum on them properly), but it results in weird messages for doing something that makes logical sense.

Also, perhaps a minor bug: When I cast Yonk, the command prompt says “lleps”. I assume it should say yonk instead.

Also, one minor objection to the way default messages interact with some objects: Frequently, in the caves, I tried to drop or throw a palantir into something (into the crack, across the pit), and the game objected that it would likely fall and be lost forever. Of course, because of the way the palantirs work with blorple, that’s not really true; it’s impossible to lose them as long as you have the other… granted that part of the reason for this might be the way I abuse the ability to cast blorple through them rather than at them, which lets you take them with you. But it still seems odd to get a default-ish response to a plan that makes logical sense (that is, dropping the palantirs into places you can’t reach in hopes that you can then teleport to them when they hit the bottom.) There’s probably more specific objections that the main character could raise to doing those things, though.

Also also, trying to blorple something from inside a nondescript blorple room gives you no message at all. No error, no results, nothing.

Another minor bit of weirdness: I found a way to drop the red sphere into the chasm (by giving it to the bird and then ordering him down; he falls and disappears, which seems odd given that he’s a bird. But maybe the sphere was too heavy for him to fly with.) When I then tried to blorple the blue sphere, it failed because the location of the red sphere was “nothingness”. EDIT: Update on this one; if you have the bird following you when you descend into the chasm via the rope, it will fall away into the darkness, too.

Is there a reason the bird is totally unaffected by Zifmia?

Also, you can use Zifmia to pull the adventurer back into the mirror world while they’re still mind-controlled. I’m not sure if this is a bug or not. They suddenly become talkative if you lead them to the chasm, which makes me assume that you’re not supposed to bring them here this way. You can bypass the entire bit where your control over them breaks like this, but you don’t seem to be able to get lleps.

If you try to blorb the inset mirror in the chasm, you will get a message about the spell failing, then get a message about the strongbox plummeting into the chasm. Nothing seems to happen, though.

Blorpling the rope while it’s tied to you and you’re hanging over the chasm causes weird stuff to happen. It ends up in the blorple room with you, then you get a run-time error when you try to leave:
*** Run-time problem P43: Attempt to remove the player from play.

In fact, trying to blorple any generic object while in that position causes the game to freak out. I blorpled the adventurer’s knife from there and it crashed my interpreter when I tried to leave the nondescript room.[/spoiler]

Guys, if you ever need a super beta-tester, I think Aquillion is the one you want.

Wow, thanks for all those reports Aquillon! I’m going out of town for a few days but I will begin working on them when I return; I can already tell what’s causing some of them (e.g. zifmia not handling animals, blorple in the Nondescript Room giving no message).

I must confess, though, the blorple trick you used to get into the Clean Room is entirely emergent gameplay, I did not plan that at all. It actually reminds me of the famous bug in Spellbreaker where (in early versions) you can use girgol and blorple to get the golden box by freezing the ogre (and the box), blorpling something, waiting in the Nondescript Room for it to wear off, then leaving to take the box before the ogre shows up. People couldn’t decide whether this was a valid (albeit dangerous, as it destroyed the flimsy scroll) alternate solution to the puzzle. At the moment I intend to leave it in, since it makes logical sense, but I’ll change things to prevent it from being a sequence-breaker. (Preventing the player from gaining the yonk spell before dealing with the Adventurer should fix two of the major ones, that was entirely an oversight on my part.)

Hah – good job, Aquillon. I missed that solution too.

Scroll Thief makes a good case study in why systems-style puzzle design is hard. Or rather, combining it with a gated plot is fraught with fraughtness.

For the record, it’s also possible to

…enter the messy Storage Area without using BLORPLE at all, which means you can do it in act 1.

(I reported this in v1 but Draconis left it in, so it counts as “deliberate” now. :slight_smile:

I’d encourage you to keep the solutions found by emergent gameplay and the alternate ways of doing things that work and that you hadn’t thought of, and maybe even consider leaving in some of the sequence-breaking bugs? I’ve spent the whole week watching Summer Games Done Quick, and the way those speedrunners find and use glitches to save time is really entertaining (and sometimes mindblowing) – my point is, I don’t think sequence-breaking bugs reflect badly on a game (provided your game doesn’t just break and quit), and it can be pretty fun to learn about them. But I guess it’s a whole other debate, and the speedrunning IF community is not very big :slight_smile:

In any case, sounds like everyone’s enjoying this! I hope having played Enchanter and the other ones is not critical to enjoying this game, because I haven’t played them :slight_smile: Congrats to you, and I hope I can get around to playing it soon!

Although I didn’t really expect it to work, [spoiler]giving the adventurer a spellbook or scroll and ordering them to memorize or cast spells gives no message at all, not even the usual “adventurer couldn’t follow your orders” default failure. If you try to have them cast a spell with “frotz [target]” or the like, you get an odd “they can’t converse while mind-controlled” message; if you try to have them cast it with “cast frotz on [target]” or the like, or if you try to have them memorize a spell, then you get no message at all.

Also, the game won’t accept any attempt to read Frobar’s spell book when he briefly hands it to you – it doesn’t seem to even actually be a spell book. While I’d imagine he wouldn’t let you search through it, it seems odd to not have a specific message for the attempt, given that acquiring spells is your main goal here.

You can order the adventurer south twice from the library antechamber to get them to the campus, then look through the palantir they’re carrying to see that it has no description. In fact, with the combination of exploits listed above, you can blorple your way to the campus yourself without ending the game… even when the ability to get blorple without dismissing the adventurer is fixed, you could probably get there by using the trick to enter the storage room early in order to get two pairs of palantirs, and have the adventurer leave one in the campus.

Casting Izyuk on the adventurer does not allow them to reach the dome above the library antechamber. Granted, I’m not sure why you would want to send them up there (and possibly they don’t understand that they can fly?), but I thought I’d note it down for completeness.

After chapter 2 starts, you’re able to walk out of the library through the front door. The description of the outside entrance and the ending you get are the same as if you never got any spells at all. (Really, there’s no reason why the protagonist wouldn’t leave at this point, so this should probably be its own ending. A player who missed the ability to blorple the mirror may just think the game is over; you can have no problems left at this point and no reason not to just make your way home with your spellbook.)[/spoiler]

Seriously, Aquillion, you’re a dream beta-tester.

I’ve put all the bug reports into an issue tracker to handle once I get back. Thank you for all of these! I’ll release a new version with various patches as soon as possible.

I finished the game (99 out of 100; zero achievements) early this morning. Very enjoyable, but perhaps I should write up and send a bug report too. There were several times I did something that obviously wasn’t expected, like blorpling my student ring which doesn’t come off, or blorpling via palantiri to the chasm while izyuking.

Haha, please do report all those bugs. I am determined to eventually eliminate them all, quixotic as it may be. Glad you enjoyed the game!

Okay, I made a bug report of what I could remember and I’ve posted it at

In creating the report, I managed to earn an achievement! So yay.

Thanks! I’ll add these to the list and start working on them asap.

Just got back, and got (almost) all the extant bug reports fixed. A new version is now up on my website (and the IFDB).

Among a lot of other things this adds Hard Mode for people who have already played through once, which forces more complicated alternate solutions to some of the puzzles. Notably, in Hard Mode (spoilers):

[spoiler]- izyuk is removed

  • the chain holding the alarm box is stronger
  • the snake is immune to magic
  • the aquarium is indestructible
  • the black sphere doesn’t fit in the vent[/spoiler]

Let me know what you think! (Note that the autopilot isn’t yet updated for some of the changes, so it’s disabled until I put the new walkthrough in. Apologies for that.)