Scroll Thief full release

Round two!

[spoiler]This time around, in order to preserve as many items as possible, I copied Rezrov off of the scribbled scroll onto a blanked newly-printed scroll, and gnustoed that, so I have both the scribbled scroll in my inventory and rezrov in my spellbook. Now, whenever I try to Rezrov anything with the scribbled scroll in my inventory (even if it’s in a closed container), it warns me that the scribbled scroll will be used up and asks me if I’m sure… even though it isn’t actually used (when I confirm that I want to rezrov, it casts from my spellbook instead.)

I can’t seem to refer to the battered scroll tube via the the small translucent sphere while that room is locked; it says that I can’t see it anymore, even though I can see it fine through the sphere. I can still refer to the rusty iron key through the sphere.

While trying to get the scrolls in the clean room, ordering the adventurer to “adventurer, southeast. open golden box. get all from box. put all in oven” results in a weird message that I can’t reach into the clean room. (Obviously, this was before I dropped a sphere down the grate – you can probably figure out what I was trying to do here.)

The adventurer now responds properly when given a scroll and ordered to cast it on me with eg “adventurer, cast frotz on me”, but I still get no message when giving them my spellbook and ordering them to “adventurer, memorize frotz”, and “adventurer, frotz me” gives the no-response reaction as if I were trying to talk to them.

The message for trying to blorb your ring is a bit wierd; it says “…but yourself is in the way.”

Is it intentional that you can get the aquarium? I was carrying it around, then yonk rezroved it open, and it said it shattered into a thousand pieces of glass… but I still had it, just open, and its description didn’t make it sound like it was shattered.

In the main stacks:
> blorb shelves
“The shelves is too big, and the spell dissipates…”

Casting lleps vezza anywhere where there isn’t something specific to see results in a weird response: You get first the lleps-vezza response (“For a moment…”), then the default “You cast the spell, the lleps enchantment twisting it around, but nothing obvious happens” response. I assume the second part isn’t meant to be displayed.

I meant to mention this before, but I forgot: Shouldn’t casting Izyuk allow me to descend the stairs to the Clean Room, or at least give some updated explanation of why I can’t descend? Presumably this could be fixed by making it clear that the entire passage is too narrow for your claustrophobia – the description makes it seem like it’s just the rickety narrow stairs in a wider area, and Izyuk would let you descend without using them.

It’s still possible to vaxum the adventurer while they are in the clean room (copy Yonk onto a scroll, cast Yonk via the scroll, rezrov the crates, all while the adventurer is glaring at you, then gnusto vaxum and vaxum the adventurer.) This results in the adventurer glaring at you with hostility while being your best friend. Actually, I didn’t really explore it before, but casting vaxum like this also allows you to order the hostile-glaring adventurer around, even while they’re glaring at you. Also, even if you later reverse your summoning, they’ll still glare at you whenever you meet them later (though they’ll obey your commands and be friendly otherwise.)

You can see the adventurer glaring at you with open hostility no matter where you go, even if you drop the sphere that lets you see what’s going on down there, put it in a closed container, or whatever. (Remember, in theory, a sufficiently callous player could just leave the adventurer there, at least up until they discover they need the adventurer’s help later. At least, that’s how things are right now.)

Ordering the adventurer south from the main entrance to the library while they are mind-controlled now produces a “you don’t want to leave until you have collected at least 12 spells” response, which seems a bit odd. Ordering the adventurer to do that while they’re your friend produces an “I don’t see how I could do that” response from them, which seems odd, too.

I can’t lleps gnusto my own spell book; the response is that it’s meant to be cast on scrolls, even though lleps gnusto is cast on spellbooks.

It’s possible to get 12 spells before you learn Yonk and end the first chapter (Gnusto, Frotz, Blorb, Nitfol, Rezrov, Izyuk, Lesoch, Lleps; plus 2 in the purple tome and 2 in De Evocatio.) Trying to leave will still say that you want to get 12 spells before you go.

I can gnusto spells into the tome and De Evocatio, but only while Frobar is waiting for me to copy stuff into his spell book, and only by dropping his spell book first. I’m not sure why I would want to do this (or if this is really a problem), but it seems weird. You can’t do it at any other time; the gnusto spell will look for your spell book and fail when it doesn’t find it, even if the other two books are available.

If you say “no” repeatedly to the enchanters, they cast setrav on you, but there’s no such spell in the encyclopedia.

[u]Stuff from the scene with Frobar and the enchanters[/u]

I can blorb Frobar, Helistar, and Haffibar. They don’t seem to mind and can continue to speak with me, interact with me, and so on from inside the strongbox. (I actually considered doing this the first time I played through, but assumed that the other enchanters would immediately deal with me, since they outnumber me three to one.)

They also respond generically to being hit by bozbar. Nor do they care when I lleps gondar them to make them burst into spectral flame.

You get a “nothing obvious happens” response when trying to serage or vaxum the enchanters (although I guess they’re not really hostile enough for vaxum.) They don’t mind.

You can blorple away from the enchanters, too (since Frobar’s spellbook has blorple in it, his handing it to you gives you an escape route!) They don’t react, and you get messages as though they were present. The weird thing is that doing this makes perfect sense from the PC’s perspective (they don’t know what the enchanters will do to them after they copy the spell), and fits into the rules as established – Frobar’s spell book should have blorple in it, and it makes total sense to use it to escape. Perhaps it shouldn’t work when you’re frozen to the ground? Or the enchanters could prevent you from memorizing / casting that spell in particular? Anyway, I managed to blorple to the mirror, then blorple through it, then make my way a fair way into the caves before they somehow put me to sleep.

I can cast Izyuk on myself while my feet are glued to the floor, and it will say I am “now floating serenely in midair.” I still can’t move in most directions… but for some reason I can go up. The scene with the enchanters continues as though I hadn’t left the room.

I can give a palantir (the black or transparent one) to Frobar, then later use it to zifmia him after he’s left. He has no reaction and just sort of stands around lost in thought. I suppose I could probably kill him by summoning him over the chasm. He doesn’t seem to have his spell book, though (I was trying to figure out a way to steal it, of course.) Presumably I could summon the other enchanters this way, too.

Other stuff I can do that Frobar and the other enchanters seem curiously unbothered by:

Blorbing Frobar’s spell book.

Dropping Frobar’s spell book.

Putting Frobar’s spell book in a bag.

Wasting the scroll Frobar gave you by gnustoing it into the tome or De Evocatio (by dropping or blorbing or bagging his spellbook first); or dropping / blorbing / bagging the scroll itself.

(Some of these might just get a comment, I suppose. But I’d expect Frobar to be more concerned about the weird things I’m doing to his spell book in general.)

Smashing the display case for the ancient gnusto spell using rezrov, then destroying the priceless scroll inside by gnustoing it, which you can do right in front of them because the scene happens to happen in the same room as it (and there is actually a reason to do this in front of them, since this lets you get the gnusto spell into De Evocatio or the tome without using up the last remaining newly-printed scroll. For that matter, it might make sense for them to have a reaction if you did this prior to their arrival, too, since the ruined display case and missing scroll will happen to be right in front of them and makes your crimes much more severe than if you’d just abused the spell dispenser a bit.)

Act 2

You can cast bozbar on the adventurer multiple times, getting the same response each time. Also, the wings don’t show up in their description.

bozbar bird should probably have a non-default response, since it already has wings.

lleps bozbar bird doesn’t do anything; it seems like it should logically have an effect. (That poor bird, though! But this is for science.)

The fact that yonk bozbar fails generically seems odd; it seems like a reasonable way to try and give someone wings capable of flight (although I assume it might break something or be too much of a pain to implement.) Possibly it should have a special response.[/spoiler]



I’ll add a check to that warning, I didn’t consider the possibility that you’d gnusto the newly-printed instead of the scribbled copy.

That is…strange. I don’t know what would cause that but I’ll look into it.

Hahaha, nice! You wanted to get yonk and lleps without making the serage spell end? I’m guessing this is something to do with the use of ALL in a command to a person in another room but I’ll have to experiment.

The “memorize” response is an oversight. The other one is more complicated: it seems Inform parses a command for an NPC by looking to see if the first word is a verb or a direction. If it isn’t, the whole thing is understood as a topic and passed to the “answering it to” action. So since “frotz me” doesn’t contain a verb (“frotz” is a spell name, implemented as a kind of value), it’s interpreted instead as “say ‘frotz me’ to Adventurer”, which then runs into the conversation rules. I’m not really sure what I can do about this except for perhaps parsing for spell names in the answer response? That would also catch “say dsaiuf saip asodiy blorb to Adventurer” but it’s better to err on the side of understanding. And maybe the Adventurer just recognizes potential spell names for some reason.

Sigh…this one’s given me a lot of grief. If you ever print the name of the player in lowercase (via [the actor], [the noun], [the holder of the second noun], etc), it gives “yourself” instead of “you” by default.

It is intentional that you can take it, the missing description afterward is an oversight.

Oops! I forgot to add an adaptive verb to that response.

This is an order-of-rules problem. The “inverse vezza fallback rule” is defined as a “last inverse effect of casting vezza”, while the “inverse fallback rule” (nothing obvious happens) is defined as a “last inverse effect of casting”, so the former is more specific. But the order of the “last” directives means the second one actually comes first. I’ve added an explicit ordering directive to clear this up.

I envisioned the stairs being in a narrow vertical shaft, so the walls are right up against the edge of the stairs. I’ll change the description to explain this better.

Amusing. I shall find some way to prevent this, maybe by not giving the ordinary scroll until the Adventurer actually leaves.

Oops! The fix mentioned above should help with one part of this, but I’ll add a visibility check to that rule.

Huh. I’m guessing I mixed up “someone going south” and “an actor going south” somewhere in there.

The rule preventing gnusto on a spellbook isn’t properly checking for metamagic. I’ll fix that.

Huh, I had a little patch for this (not a very satisfying one: if you get izyuk the number bumps up to 13) but it doesn’t seem to be working.

Huh…that is strange. There’s a variable holding the “player’s preferred spell book”, which is the one you want to gnusto into, and it’s switched to “Frobar’s spell book” for that scene to allow gnusto to work. But a rule must be checking for “your spell book” instead somewhere.

Really? There should be…I’ll check that. EDIT: Oops, it seems I clobbered it when I pasted in the new spell list. Fixed.


Oops, this is actually a different bug: it sounds like you’re learning the spells from Frobar’s spell book? He should prevent you from learning anything except yonk or gnusto, since most of those spells are only half-implemented.

I’ll fix that.

An excellent attempt, but Frobar shouldn’t let you memorize the spells from his spell book.

I forgot about the way to get izyuk early and didn’t plan for it in this scene. I’ll fix that.

Hahaha, I like it! The Enchanters aren’t supposed to accept anything you give them, but I might have broken the Conversation Framework giving rules when I added an exception for the obedient Adventurer (since giving is considered conversation, and serage prevents conversation).

Definitely an oversight on my part. I’ll add in some amusing responses for such things.

Very true! I had not considered that but they should react to seeing the scroll missing. I’ll change that.

You shouldn’t be able to cast bozbar at all in this version, so its code is just a stub. But I’ll keep these in mind when I do add it to the game proper.[/spoiler]
Thanks for all of the reports! These help a lot with debugging, since I would never think to try most of these things.

Another new version, with all these bugs fixed! Let me know if (“if”) you find any more. :slight_smile:

This whole thread with the bug reports and the variomatic has been instructional for me as someone who tested the original version–there were so many things to try that I missed, and I knew there were combinations that there weren’t time to check. So it’s great to see what people are trying post-release & also what I could’ve seen.

A rough estimate says you’ve fixed 140 or so bugs in 3 weeks, which is pretty awesome…good job not letting the reports get you down. That’s not easy.

Yeah, I’m really impressed by both Aquillion’s expert bug-finding and Draconis’s speedy turnaround.

Thanks! :slight_smile: I’m trying to keep up as best I can, as well as working on Spirals, because next week I leave for university and I’ll have less time for IF then. So I want to get as many bugs out of the way before that as possible. The current count is 153 on the tracker, which contains primarily the reports from aschultz, zarf, and Aquillion.

This version also adds a few miscellaneous enhancements which are unrelated to bugfixes, so tell me if those are helpful to you or if they cause any strange side effects.

All right, round three! These are getting more minor, but I figure it can’t hurt to mention them.

[spoiler]If you don’t cast Frotz, and instead wander north in the dark, you can reach the stairs; trying to go down them gets you a “you can’t bring yourself to put your weight on the stairs” message that implies you can see them.

Blorbing an object inside a container you’re holding results in a slightly weird message:

blorb pen
“A glowing strongbox forms out of the air, carefully enclosing the quill pen, which disappears from view. The box falls into the pen case. The pen case is too small to hold it, and it falls out. You are too small to hold it, and it falls out. It appears solid and secure, but you get the feeling that it would open at your slightest touch.”

Blorbing an object from your inventory while at the top of the staircase results in a weird message:

blorb total
A glowing strongbox forms out of the air, carefully enclosing Total Control by A. Schultz, which disappears from view. The magical strongbox would likely fall down the stairs, and you might never see it again.
You are too small to hold it, and it falls out. It appears solid and secure (etc.)
(The strongbox ends up in the room.)

The game won’t let you drop the compass, but you can leave it behind by blorbing it.

You can blorb something in the stacks, and it will leave a strongbox on the ground that mysteriously follows you as you go deeper into the stacks.

Blorbing the illuminated scroll while it’s inside the intact display case results in some weird behavior: It creates a strongbox that “falls into the display case”, which is mildly odd, but more importantly, if you then rezrov the strongbox, the illuminated scroll appears outside the display case, without having to break it.

The magical strongboxes created by blorb actually produce light. By exploiting this, you can avoid ever casting frotz, and therefore avoid ever setting off the alarm. (Eventually, you can order the adventurer to give you their light source to get one you can carry around with you rather than blorbing something every time you enter a room.) This causes problems when later traps, security, and plot events assume you set it off.

The glass box in the disused closet is present (permanently) if you enter the closet while the alarm is active, and remains so even once you use the password to disable it. However, it will not be there if you disable it prior to entering the room for the first time.

In the disused closet, “drop [object] into grating” results in the object being dropped nearby. (“drop [object] down grating” and “put [object] in grating” both work fine, though.)

If I blorb frobar’s spell book, then yonk gnusto yonk, the spell somehow appears in his spell book anyway… and he takes it from inside the strongbox, leaving the strongbox behind (empty, sadly.)

After seeing the new message when trying to give an object to Frobar, I naturally tried giving him my spellbook, and got this bizarre response:

give spellbook to frobar
Whom do you want to give: 1) Field Guide to the Creatures of Frobozz by S. Meretzky, or the Entrance to the Library?

The film doesn’t work on the freshly-copied scroll. Shouldn’t it? After all, it’s freshly-copied!

The library antechamber is described as “dark and silent” (in a counterpoint to how it looks during the day, with no sunlight shining in through the circular window) even if you wait until morning.

Although the brick wall keeps you from leaving, the room south from the library entrance still has a description that doesn’t make sense if you revisit it in chapter 2, since it reads as if you haven’t entered yet (“what if there’s an alarm?”)

Also, should the brick wall become a listed Problem once the player sees it? I assume you don’t want the player to actually fixate on getting past it, but from an in-character perspective I’d assume it’s a problem (although I guess there’s no reason the player couldn’t just fly off the roof to leave if they really wanted to get out.) The player’s real goal in Chapter 2 is to experiment with Blorple (since that’s what the enchanters ask you to do), so perhaps that should be a problem up until you find the caves?

If you use zifmia to summon the snake elsewhere, their room description still says they are slithering over the rocks in front of the eastern passage.

Ordering the adventurer east of the Splendid Cavern has them eye you dubiously and push the wall, even though the description implies that anyone non-claustrophobic could go that way.

While in the Splendid Cavern, the adventurer goes through their default actions from before, including ones that don’t make sense (like “The adventurer stares at the mirror, but doesn’t seem to see you” even when you’re in the room.)

If I take the little bird and / or the adventurer back to the library with zifmia, and then take them south of the entrance, it won’t let me walk out – it says that I shouldn’t leave them here where people might stumble across them, even if they’re following me (of course, with that giant wall there, it seems unlikely anyone would stumble across them either way!)

The ‘friendly’ adventurer still responds oddly when ordered to go up in the main library room after being hit by izyuk (it says they don’t have the ability to fly, then they look at me oddly and say that they don’t see how they could do that.)

When you order the adventurer to open something that is already open, their response has a stray line break before the quotation mark.

The rusty spike and damp paper (before being torn free) are too big for blorb; this seems a bit odd.

lleps izyuk bird should have a non-default response (maybe)

If you give the bird a sphere, and order it down into the chasm, then blorple the corrisponding sphere to teleport to it (while izyuk is in effect), the adventurer panics and says they were “watching you climb, then suddenly the rope was gone”, even if you never used the rope at all. Also, my Izyuk wore off immediately in the chasm, and it said I “settle gently to the ground.” A similar thing happens if you use blorple to teleport to the adventurer while they’re hanging from the rope.[/spoiler]

Right on schedule! :smiley:

Thanks again Aquillion, I’ll get right on these.

EDIT: One of these is intentional, the one about the alarm box: you never notice the box unless it’s making noise, but after you’ve seen it once you remember where it is and notice it in the future.
Also, the one with the Chasm is another sequence-break, you’re supposed to be forced to use the rope (to ensure you can get it in the Ruined Hall). I’ll add in some additional checks for that.

And another new version is posted to fix these bugs. Let’s see how long this one lasts.

Also note that the autopilot is back in this version, to make up for breaking your saves so often. You can ‘fly on autopilot’, so to speak, to points later in the game by typing (e.g.) “autopilot to checkpoint alarm” on the first turn. The game will then type in all the commands for you as though you’re replaying from the Skein until you get to the specified point. The “checkpoints” command tells you what points are available, and “option checkpoint alerts” gives you a note every time you pass a checkpoint during normal play.

Round four! Some of these are fairly silly things that nobody would have a reason to do, but I figure I’ll just write down everything that leaps out at me and you can decide what’s worth doing something about.

[spoiler]When you order the adventurer to push the button on the scroll dispenser, they do so, but nothing happens as a result. I suppose it might not work for people without identification rings or some such thing? But maybe it should give more of a response. (Of course, it wouldn’t really break anything for the adventurer to receive a scroll, either.)

The adventurer is unable to:
Tear pages from the calendar.
Go west in the stacks.
Put the correction film on a scroll.

…all of those give a default failure response, even though there’s no clear reason they wouldn’t be able to accomplish them.

Attempting to have the adventurer copy a scroll gives no response at all (I’d assume it’s not something they’re capable of, although I guess the map shows that they’re at least literate. Hrm, I should have thought to have them try and copy the scroll on the wall of the safe room from outside the room before it was moved… oh well, the scroll isn’t in a place where that would be feasible now anyway.)

The message for ordering the adventurer to leave the library is still a bit odd – it gives the “nobody is supposed to be hear” response (as if your character thinks better of it and decides not to order them to leave) and then the default “adventurer can’t do that” message.

Having the adventurer throw something at the alarm box has them try and miss, then gives the default “adventurer can’t do that” message. (As an easter egg, it might make sense for them to hit, since they’re much more physically adept than the protagonist – although this is completely pointless, because you have to have already disarmed the alarm with the password to reach that point.)

Additionally, if you give the alarm box to the adventurer and order them to smash it, they will do so, but you then get the “adventurer can’t do that” message (even though they succeeded.)

When you order the adventurer to put a palantir in the vent, they somehow manage to literally place it inside the vent as a container; it doesn’t fall down into the clean room. Additionally, the adventurer can put any item in there regardless of size, for what that’s worth.

If you give the adventurer a palantir, then order them to set off the cleesh trap, you can summon them back with zifmia, and they’ll be fine even though they’re supposed to be a newt (“I got better?”) I suppose this could be fixed by having them drop everything when cleeshed. This is a general problem whenever any NPC dies – if I collapse the dome on the bird while it’s carrying a palantir, I can summon it back, too… although I guess it might have survived?

The floor waxer seems like it should probably be heavy enough to set off the cleesh trap when thrown onto the table, although I suppose there’s different kinds of waxers (and it could be magical, so I’m not really sure how to picture it.) Granted that there’s no reason to do this unless you’re paranoid about the trap, since if you have the waxer then you already got the scroll off the table somehow.

When you try to write a word in your spell book, you get the “doesn’t make a good writing surface” error, then the “filled with enough magic that they cannot be written on normally” error. Presumably the first one shouldn’t appear.

Trying to write in library books gives the “doesn’t make a very good writing surface” response.

Typing “write on [object]” (without specifying what you want to write) gives a response of “you can’t see any such thing”, even if the object is present or in your inventory.

Casting “serage self” in front of the enchanters still says the librarians find you the next morning. I guess the enchanters might decide to leave you there?

You can no longer rezrov open the display case in front of the enchanters, but if you already rezroved it before they arrived, then decided not to gnusto the scroll inside, you can gnusto it in front of them and they don’t react.

The message when you blorb frobar’s spell book and then yonk gnusto yonk is a bit odd – it says the magic is looking for your spellbook (which is present.) I guess part of the oddity of this is that it’s not really clear how gnusto decides where to put a spell… presumably the PC is making the decision and intends to put it in Frobar’s spell book?

You can’t see the mirror through a palantir, at least not on the scrying room side.

You made it impossible to give palantirs to the little bird! But you can give an empty container to the little bird, then put a palantir in it while the bird is holding it, and use that. (Personally I would prefer it if the bird could carry palantirs or containers, since it’s cool and gives the player an alternate solution to both crossing the fissure and to getting back up from the misty cavern if they don’t have the rope, lack izyuk, and brought all their palantirs with them. But I can understand if it just introduces too many issues.)

Additionally, you can teleport to the bird’s location by giving them an object, blorpling the object, then giving them an order to move through a palantir in their old location and stepping out at the bird’s new location. This lets you teleport to the bird while they’re in the chasm, or after they’ve moved across the fissure, or up the cliff.

If you order the adventurer to go up or down while there’s no exit that way, they’ll push on the wall, which doesn’t make sense.

Lesoch doesn’t do anything to the old book, which seems odd. You can also frotz, blorb, or blorple it.

yonk jindak junk feels like it should get some sort of message when the normal version is fading too quickly to find anything.

The Rope
The rope is complicated enough that sometimes, I’m not completely sure what the cause of an issue I encountered is, so I’ve tried to note down what I was doing at the time. Some of these may still depend on aspects of the situation that I didn’t catch.
Note that I untied the rope from its initial state by blorpling it.

If you tie the rope to someone, it’ll say they can’t move very well while tied up. However, they can still move by following you, if you ordered them to do so, provided you’re not in an adjacent room.

You can order someone to pick up the rope while they’re tied to it. This results in a weird “the old rope is somewhat unwieldy while tied to the old rope” message.

Pulling the rope while it’s tied to a person (or both the bird and the adventurer) gives you “the impulse is transmitted to nothing.”

You can use zifmia to summon someone tied to the rope, and they’ll remain tied to the other end, even if that’s on the other side of the mirror. Amusingly, this can be used to cause the cave-in from the library.

If you have the rope tied to an object, then blorb the object, the message says “The old rope is pushed aside, and Dead End up wrapped tightly around the strongbox.”

When you pick up the rope while it’s not tied to anything, it still says “you take hold of the old rope”, and when you drop it, it says “you let go of the old rope.” This is slightly confusing when you’re just picking up or dropping the whole thing.

If I’m standing in the library antechamber, and tie the rope to the adventurer, then get the rope and go south to the entrance to the library, it won’t let me go north again until I untie the adventurer or drop the rope; it says “you’re tied up here”, even though it’s not tied to me.

If you blorple the rope while the adventurer is using it to climb, you will no longer be able to pull them up, but they won’t fall.

You can use zifmia to get the adventurer out of the chasm (whether you have the above problems or not), but they won’t report finding the mirror.

If you cast Izyuk on the adventurer, they still won’t be able to get out of the chasm on their own. Additionally, while they’re under izyuk, opening the strongbox doesn’t make them fall… even when Izyuk wears off (it says they descend onto the floor.) Also, if you cast Izyuk on them while they’re in the chasm, it says that they’re now hovering a few feet in the air.

Using zifmia to summon the adventurer into the chasm (while hanging from the rope yourself, say) gives a death message for them where it says that their “rope suddenly fails to provide support”, even though they weren’t tied to them. Amusingly, if they have a palatnir, you can use zifmia to summon them from nowhere and kill them like this again and again and again. You Monster, indeed. Then you can cast Izyuk on them, order them up, and have them pull you up as if you didn’t do anything wrong.

While you’re dangling in the chasm from the rope, casting izyuk on yourself and then untying the rope makes the mirror mysteriously disappear. (This isn’t necessarily an unreasonable thing to do if the player doesn’t realize that they can use blorple with the rope tied to them – they could legitimately assume that it just won’t work unless they untie it first.)

I assume this is a sequence break in that it assumes that I just came out of the mirror, but my overall opinion here: I don’t think you need to worry that much about ensuring that the player uses the rope so that they have it when they enter the mirror. Most of the ways I’ve found to get in there without using it involve doing obviously risky “save first” things, and by this point, between the palatnirs, blorple, izyuk, and so on, the player has numerous ways to escape, go back, and get the missing rope, smuggling it in by blorpling or the like. They’re still going to need it to get the last two scrolls, unless there’s an alternate solution I didn’t find; but since that’s nearly the last puzzle in the game, and the game gives them many ways to move themselves and objects around, I don’t think you need to worry about ensuring that they have it the first time they go there. Especially since all the alternate ways I’ve found to enter the chasm safely involve Izyuk, so the player can always go back and get the rope using that. I do think it’s a shame if neat tricks like having the bird carry a palatnir had to be removed just for that.

Oh, speaking of which: It’s possible to have the rope-item in your inventory while you’re descending to the mirror, tied to the rope and the strongbox. If you do, the message you get when you blorple the mirror says “the rope is pulled sharply from your hands” followed by “the old rope appears beside you”, which seems odd.

I can tie the rope to the aquarium, and drag it behind me, and use this to drag it through the giant doors in the clean room while it has magical stuff inside it. (Using blorple to get down there. Yes, there’s no reason to go there at the point in the game where you have the rope, so this is mostly just a novelty, and I suppose it might actually be a flaw in how the magic doors work.)

I tried to tie the rope to the aquarium, then give it to the adventurer to drag it around; but I got the weird “the old rope is somewhat unwieldy while tied to the old rope” message again, and they were unable to move (not even following me worked this time, although it spammed me with that message every turn.)

Ordering the adventurer to pull the rope while it’s tied to the sturdy box has no effect, and prints a weird message, as follows:
The impulse is transmitted to the sturdy box.
sturdy box: >[/spoiler]

Also, not a bug, but a setting logic issue (and one you might not be able to fix, because on reflection it’s an issue with the canon that dates all the way back to Spellbreaker itself):[spoiler]Frobar comments approvingly on your copying the yonk scroll, saying that such scrolls are hard to come by. But after reading that comment several times while testing the game, it made me think – how can that be? The very fact that you copied it proves that it makes no sense for it to be rare, since anyone can copy any scroll onto another one if they have a quill or a magic burin. In fact, Spellbreaker establishes that you can blank any scroll by dipping it in water, then rewrite it with a copy of a long and complicated one – though possibly this was only meant to be something the PC could do back then because they were a highly-skilled enchanter? Scroll Thief fixes this a bit by establishing the rules for Presence, which ensure that scrolls can’t be mass-produced… although the dispenser kind of breaks it again. Probably I’m just overthinking it; Zork is, after all, a setting with an underground flood control dam and a king who set the tax rate to 98%. The problem isn’t really Frobar’s comment, anyway, that just made me realize it – the setting clearly assumes that a scroll of Frotz is more common than a scroll of Guncho or Girgol, but there’s no real reason why that would be the case when they’re clearly so easy to copy.

Possibly it’s just rare because the enchanters keep it under tight control, which is relatively easy to do for long and complicated scrolls?

Oh, that reminds me of one other continuity issue with spellbreaker: Scroll Thief won’t let me write on the white cube, even though you could do that in Spellbreaker. Granted that there’s not much call to distinguish the one white cube you find, and this probably isn’t worth it for an object you’ll only have for a few moments…[/spoiler]

I’ll start addressing the bugs soon, but for the other issue: I have an explanation planned out, though (as you saw) not much of this got into the game. I’ll try to reveal more of it in the sequel, or add some more hints in the Dispenser area.

[spoiler]The process of putting Presence into a spell scroll is a long and complicated one, so blank vellum capable of holding spells is not a common object in general. According to the Spellbreaker feelies it costs 28 zorkmids a page. In that game even the Guildmaster is only able to copy one scroll in the whole game. (You find a vellum scroll in the cell after using the Time cube.)

Some suppliers use cheaper materials and less Presence, which works fine for some spells (frotz, nitfol, etc). But without enough Presence in the paper, the Presence of the spell itself makes it degrade quickly, and before long the parchment will crumble to dust. This works fine for the scroll dispenser: someone made a lot of cheap paper scrolls with almost no Presence in them, and loaded the Dispenser full of them. The scrolls don’t last long, but they don’t need to hold very much power, and if they burn up too quickly you can just grab another. But if you copied a more powerful spell to one of these it would fall apart in minutes. (Not enforced in the game because time limit puzzles tend to be annoying, but it would have disintegrated one turn after you used it.) And even if there’s a lot of paper there you’ll run out eventually, as the player character quickly discovers.

As for the cube thing, that’s just my laziness. :stuck_out_tongue: Since there’s only one cube I didn’t bother to implement writing on it. Should probably do that though.[/spoiler]

In Spellbreaker you write on cubes with a burin, which is a different tool from a quill.

New version with almost all bugs fixed. The last two are more improvements than genuine bugs and will take longer, so those are on hold for now.

Round five! Several silly things again.

[spoiler]There’s an extra line break in the [To move around… hint at the beginning, right before the last ‘]’.

When you look at the encyclopedia, is the random entry supposed to have no line break after “You flip to an entry at random:”? It looks a bit odd with spells that are too powerful for gnusto (since they get another line for the footnote, two lines down.)

When you tear away the cardboard backing from the calendar, it’s not described as dissolving, but you don’t get it as an item (I assume it should dissolve, since getting it and using it as a light source would break the game.)

You can get five points for shattering the display case for the ancient gnusto scroll, then fifteen points for recursively copying it using your blotchy scrap and a newly-printed scroll. This allows you to end the game with more than 100 points.

Other things the adventurer can’t do:
Open the Frobozz Magic Parchment Pack
Search the objects in the storage area

Ordering the adventurer to write in my journal gets no response, not even a failure message.

Ordering the adventurer to get the illuminated scroll gives both a “better not do that” response and a generic serage failure.

Ordering the adventurer to open the strongbox has them open it as a container, leaving an open strongbox in the room; it does not disappear as it does when you open it. (My assumption is that the adventurer shouldn’t be able to open it at all, since the spell is intended for protection.)

Ordering the adventurer to ‘get me’ results in “…the Adventurer attempted to take yourself, but was somehow unable to.”

You can blorb the adventurer through the mirror before summoning them with zifmia for the first time, and they don’t react… although maybe not being aware of being blorbed is a side-effect of blorb, if time stops for them while inside it?

If you order the adventurer to put a palantir in the vent, they will succeed, but you also get a generic serage failure message.

Achievements are lost when you undo or restore a game past the point where you earned them (which is bad when one of them is earned by dying!) I’m not sure you can do anything about that, of course, but I thought I’d point it out.

The rusty knife has no description (beyond the generic “nothing special”). It’s not an important object, I know, but it’s noticeable because you automatically see its description when you find it. Also, while the number-based disambiguation used in the game means it’s not strictly necessary, it might be a good idea to give the adventurer’s knife an adjective to avoid confusion with the rusty one.

Other items with generic descriptions:
The golden box (Which is bad because the player is supposed to fixate on acquiring it in order to trigger the adventurer’s rebellion.)
The small hook (in Above the Pit)
The rope (although it does say what it’s tied to.)
The splintered planks
The ducts in the clean room
The oven in the clean room (no description at all, not even the generic one.)

“Retrieving the scrolls from the clean room” is a listed problem once you’ve gotten a palatnir in there, but before the adventurer has rebelled. There’s no actual scrolls visible there now until after the adventurer has gotten the box. (Granted, I suppose the PC could simply surmise that they must be present somewhere in there.)

Ordering the adventurer to ‘follow me’ from far away (eg. via a palantir) results in a bizarre “you can’t reach into the [room]”, where [room] is the adventurer’s location.

If you blorb frobar’s spell book, then try to yonk gnusto yonk, you’ll “open” the strongbox to get the spellbook, without destroying it – leaving an open empty strongbox behind.

From atop the dome, I can blorple the Borphee River. Leaving the nondescript room that this takes me to leaves me back on top of the dome, which seems odd, since that isn’t really the river’s location per se. You can also frotz the Borphee River.

lleps zifmia [target] doesn’t give you a message for the target appearing, even if you’re at the location where they arrive or if you can see it via a palantir. (eg. if I lleps zifmia bird via the palantir while standing at the spot where the bird will be ‘unsummoned’ to.)

Stacking izyuk several times results in a “you settle gently to the ground” message once for each copy as it each one wears off in turn, even though you’re still flying until the most recent casting expires. Also, having it wear off while flying in the chasm still says you settle gently to the ground, even though you actually start plummeting towards your death – this could potentially kill an unaware player who cast it before leaving the mirror.

Blorbing the old book describes it disintegrating after the strongbox appears, even though you can’t see it at that point.

After you’ve seen the snake once, any attempt to interact with it (eg. ‘x snake’ or ‘get snake’) when it’s not present will result in a “The snake rears up as you try to touch it” message.

You get five points for asking the ghost of the young man any question at all, even if he doesn’t answer. On the other hand, you don’t get it for “talk to man”, even though he does respond to that.

“yonk jindak junk” seems to behave oddly. It only gives its special message (about the pile shifting) while there is still something to discover in the pile (the iron rod), but won’t let you discover it. After you find the iron rod, which you can only do with regular jindak, “yonk jindak junk” works like normal jindak, wasting the extra yonk power.

The young man’s ghost doesn’t respond at all to the iron rod. I suppose he might know nothing about it, but I thought I’d point it out.

The “Front Door” achievement doesn’t unlock if you’re dragging the aquarium by carrying the rope, only if you tie it to yourself.

I managed to get no response at all by putting almost all my stuff in the aquarium, tying myself to the aquarium, getting my spellbook, blorbing the aquarium, then trying to go northwest while the strongbox is tied to me. I didn’t get any message at all, not the doors closing, no failure, etc. I’m not quite sure what caused it. Opening the strongbox resulted in a normal “doors slam because you have your spellbook” message. Dropping my spellbook let me pass.

You can use “zifmia me” in the north end of the ruined hall, making yourself technically count as summoned; then after causing the cave-in, you can use “lleps zifmia me” to cancel your “summoning” and go back there to the supposedly-collapsed room. (Don’t remove the ability to combine zifmia me and lleps zifmia me to ‘recall’ to old locations, though – that’s a cool trick. I used it to escape after trapping myself in the clean room area with no palantir link out.)

You can also uze “zifmia me” in some other room before the enchanters arrive, then “lleps zifmia me” to escape them. (As before, they act like they’re still present.)

I managed to crash the interpreter by blorbing something, blorpling the strongbox, casting “zifmia me” in the nondescript room, leaving the nondescript room, opening the strongbox, then casting “lleps zifmia me” to return to the nondescript room and trying to leave the nondescript room again (presumably, the exit went to the location of the strongbox, which was nowhere.) I still don’t think the “lleps zifmia me” trick should be removed, though, since it’s just cool and makes logical sense. (I’d almost like to be able to keep the ability to “lleps zifmia me” back to an item’s nondescript room, which also makes a sort of logical sense – but it’s a bit buggy at the moment; the nondescript room points to the last nondescript item you blorpled, not to the item you cast “zifmia me” in. Oh well.)

You can also use “lleps zifmia me” to escape the nondescript room while leaving items in it. Or adventurers and birds you zifmiaed into it. This includes palatnirs, letting you teleport back to the nondescript room later on.

Oh, also, the message for “lleps zifmia me” (assuming you used “zifmia me” previously) is “You seem to waver for a moment, then disappears with a slight pop.”

The vaxumed adventurer refuses to give me the map; but they’ll happily drop it on request.

More rope stuff
While the rope is still in its original location, ‘get rope’ in the misty cavern, followed by ‘up’, results in this set of bizarre responses:
(coiling up your rope again as you go…)
(first trying to throw the old rope into the pit)
You don’t have any good way to climb up.

Following this, the rope’s “bottom” half is in the Hall of the Mountain King, for some reason, while the “top half” is still at Above the Pit; it is not present in the Misty Cavern between them, so you can’t climb up. And getting the bottom there after that says you can’t go anywhere but up, even if you try to go up.

While the rope is in its initial location, “blorb rope” results in a message that “nothing is pushed aside, and ends up wrapped tightly around the strongbox.” After that, you can still go up to climb the rope to Above the Pit, even though the rope is in the strongbox. Bizarrely, if you open the strongbox, you can no longer go up.

If you tie the rope to something, then blorb it, the rope ends up tied to the magical strongbox. If you later blorb something else, the rope ends up tied to the new strongbox, wherever it is.

“pull rope” while it’s not tied to anything produces no response at all.[/spoiler]

Also, some random ideas and suggestions for easter-eggs and the like that occurred to me:

[spoiler]There are several spells with durations that could be made to last longer (or even indefinitely) when enhanced with yonk. These include izyuk, nitfol, and vaxum (on the giant snake.) Of course, this might ruin some puzzles in act 3… or I guess it could be used for one, although it’s not much of a puzzle.

lleps vaxum dispels vaxum, but it doesn’t do anything else – or, at least, the only time it does anything for me is making the vaxumed adventurer murder me. It might make sense to have it make targets more hostile to you (causing them to kill you); granted that this would serve no purpose beyond committing suicide by making the snake or bird or already-hostile adventurer kill you… could the bird kill you? I have no idea. It’s a pretty tough bird, though.

It might be amusing to have a special message for putting the film on the illuminated scroll or the torn pages; it specifically says that the scroll has to be recently-written, so naturally I tried using it on one of the oldest scrolls in existence.[/spoiler]

Hahaha, I never expected anyone to try teleporting themselves like that! I am tempted to take it out, but it is really cool…

New version, with that trick left in (and an achievement added for it because it’s really cool) but the other things fixed.

All right, a few more! Nothing particularly big this time.

[spoiler]The small note begins with an open quotation mark, but has no closing quotation mark.

Is it just me, or is ‘undo’ very slow now? I assume this might have something to do with the fix for undoing achievements. It’s noticeable when you want to undo a bunch of stuff in a row. I’m playing in Gargoyle.

Also, this might be interpreter-specific, but undoing repeatedly until you can’t undo anymore

‘x staircase’ in Top of the Staircase gives you the response “The Top of the Staircase is not solid enough.” (You can “x spiral” or “x spiral staircase” to look properly at the stairs.)

Trying to ‘roll sphere’ (or anything other than scroll) gives a “You can’t see any such thing” response.

You can’t blorb the golden box, of course. However, you can (before dropping a palantir down into the safe room) order the adventurer to put the golden box in a bag, then blorb the bag. The adventurer, when they rebel, grabs the golden box from inside the strongbox somehow.

“give sphere to adventurer” while I have all four spheres lists the Field Guide to the Creatures of Frobozz among the disambiguation options. It seems to replace the red sphere. I’ve noticed that particular item replacing the first item in disambiguation in many circumstances; I’m not quite sure what causes it.

If I order the adventurer to drop a sphere at the bottom of the stairs, then later order them to “get sphere”, they do not respond in any way. “get sphere” works, though.

More things with generic descriptions:
The drawer in the desk in the tiny office.
The librarian
The sliding door
The small chair in the tiny office
The adventurer’s knife (I think its description was moved to the rusty knife? I thought it had one before.)

In the rope’s initial location, ‘get rope’ at the bottom and then going up now results in “The rope isn’t anchored well enough to hold your weight”, which really doesn’t make sense to me (it’s still tied at the top, after all.)

While it was in its initial location, I tied the bottom of the rope to the bird, grabbed it, and went up. When I tried to go back down, it said that I couldn’t go far while carrying the old rope tied to the small hook and the little bird, even though I was trying to descend the rope itself.

After I pulled the rope to cause the collapse (and after all the other messages), I got a “Nothing obvious happens” at the end.

Waving the iron rod by the fissure doesn’t do anything. If this is the rod from Adventure, isn’t it supposed to create a bridge?

“point rod [direction]”, “point rod at [direction]”, and “point rod at [room name]” produce no response at all, not even a failure message.

I was unable to get the Word of Recall achievement. Is it supposed to be awarded simply for using lleps zifmia me to transport yourself, or is there more to it?

If you return from the collapsed room by flying or magic, and later try try to “ask adventurer about map”, the adventurer will ask if you’re all right down there, as if you were still hanging from the rope.

While the rope is tied to me and the magical strongbox, and we’re in the same room together with the adventurer, ordering the adventurer to “pull rope” results in:
The impulse is transmitted to yourself and the magical strongbox.
magical strongbox: yourself: The Adventurer pulls yourself.

Trying to go through the doors in the Clean Room while carrying magical items now produces no response at all.

If you use “zifmia me” in the north end of the ruined hall, then cause the collapse, you will be unable to ever again use “lleps zifmia me” for transportation anywhere, even if you later “zifmia me” elsewhere. This is because “lleps zifmia me” takes you to the first place you were summoned from (and then clears your summoning origin), while later “zifmia me” spells won’t change it until you’ve successfully cast “lleps zifmia me”. If your summoning origin is an invalid place to return to, you can never clear it, and therefore can never set it to anyplace valid. It hardly matters, since the game is nearly over at that point, but I thought I’d mention it. This could be fixed by clearing your summoning origin when you fail at “lleps zifmia me”, or by changing the way the origin works in various other ways.[/spoiler]

Re that last point: I’d actually like to ask people about that.

[spoiler]The most logical way for lleps-zifmia to work in general would be to send the subject to the last place from which they were summoned. That’s how I had it implemented initially, actually. The problem is with the Adventurer in the Clean Room: if you’ve summoned them again, you’d need to use lleps zifmia repeatedly, which causes sequencing problems. (The Adventurer can then approach the player directly, and I’d need a different way to get the ordinary scroll out there.)


EDIT: Also having some difficulty with the UNDO one. It saves achievements to a file when they’re unlocked, and reads that file in when play begins. I made it also read in the file after undo and restore. But this isn’t a very fast operation. One idea would be to read it in immediately before displaying achievements, and immediately before awarding achievements. Thoughts?

EDIT2: Re the iron rod:

It resembles the rod from Adventure, but you can only make the bridge in Hard Mode.

Yeah, that’s how I assumed it would work initially. Hrm. You could have it work like that normally, and have the Clean Room have a special power that anything lleps-zifmiaed from there pops back through the entire stack and goes back to the first place it was summoned from rather than the most recent; you could even have a message when they unsummon the adventurer describing how the room amplifies the spell or some such thing. It makes sense, since the whole purpose of the Clean Room is to handle dangerous magical things safely, so they’d probably want to be able to banish things really well from there.

That makes sense to me.

Well, almost everything is fixed. I still need to figure out what’s going on with disambiguation…but that won’t be finished in a night. So a new release is uploading now for the meantime.

Regarding that last point again:

That makes sense. Implemented that way for now. I’ve considered also using a stack rather than a variable for each person. When you summon them, their previous location goes on the stack. Unsummoning pops a location off the stack and sends them to it if possible. Does that sound reasonable? (It’s probably a lot more memory intensive that way so if it won’t be helpful/understandable/interesting to players I won’t bother.)