Release candidate of Inform 7 IDE for GNOME - testing help wanted

Hi! Users of Inform 7 on Linux might remember that I have been porting the IDE to use more modern versions of the software stack so that it’s less annoying to install and use on modern Linux desktops.

I’ve finally fixed enough of the main blockers and weirdnesses left over from the code porting, that I feel it’s usable now. So I’d love some help testing release candidates.

Additionally, since last time I bogged down all the would-be testers with install problems, I’ve tried to make it easier to grab and install a version for testing. Not as easy as I’d like it to be, mind you! But easier. At least you won’t have to compile it yourself from source, hopefully!

How to get it

  • Go here: Actions · ptomato/inform7-ide · GitHub
  • (Edit: you need to be signed in to GitHub)
  • Click on the latest (should be topmost) entry on the list with a green checkmark.
  • You’ll get a new page, scroll down to the bottom of that to a section titled “Artifacts”.
  • There you should see links to download an RPM package, a DEB package, and a Flatpak bundle. (I’d recommend the Flatpak if your system supports it, as I plan to lean more heavily on that as the main distribution method.)
  • These are ZIP files, the real package is inside them, so extract it by double clicking or whatever you normally do to unpack ZIP files.
  • Ideally you should be able to install the packages by double clicking on them once you’ve unpacked them. I’m not currently on a system that uses RPM or DEB packages so I don’t know for sure whether that works or not. The Flatpak package should install if you double-click on it, but that actually… didn’t work for me, not sure whether it’s because I’ve messed up something on my system or it doesn’t work for anyone. If all else fails, here are the Terminal incantations to install each of these packages, assuming they are extracted in your Downloads folder:
    • Flatpak: flatpak install --user --bundle ~/Downloads/inform7-flatpak.flatpak
    • RPM: sudo rpm -Uvh ~/Downloads/inform7-ide-2.0.0-1.fc35.x86_64.rpm
    • DEB: sudo dpkg -i ~/Downloads/inform7-ide_2.0.0-1_amd64.deb

What kind of feedback I’m looking for

I’m currently looking for any show-stoppers that would mean it’d be a bad idea to take this version and publish it on Flathub to replace the older clunkier version. Unable to use basic functionality, crashes, data loss, etc.

Things that are only occasionally or slightly broken, or didn’t work well in the old version either, I’d still like to know about but probably wouldn’t hold things up for.

Sorry so slow :slightly_frowning_face:

I apologize for how long this took, my last post here was a year ago, and it was at least several months that I hadn’t touched Inform before sitting down for this final push. I hope that by having the big chunk of tedious work done, it’ll be easier for me to return to more regular maintenance.


(Applause and cheers!) Great to see a new version, Philip!

1 Like

I’m grateful that you’re still in there plugging away. Volunteer developer hours are precious, because they always have to take second place not only to life and health, but e.g. avoiding having the kids clustered around asking questions like: "Daddy, what are shoes?"

So thanks! :+1:


Hm. On the page

clicking on the topmost link (build #38) takes me to a page with “Artifacts” at the bottom, but none of them are links. Do I need to sign in or something?* There is a note with a red X above that box, saying “Flatpak: failed to save cache…”

BTW: I don’t know where this site is getting the “Delay Initial Load…” from. To me the page is labeled “Build packages.”

*user: My screen is completely dark. I’ve tried jiggling the mouse, but nothing happens."
support: There’s a round button on the front of your PC. Is it showing a symbol like a coffee mug seen from above?
user: No.
support: Try pushing it.

That’s a good point, and I think what you suspected is correct. You have to be logged in to GitHub to download the artifacts. (I tried logging out and going to that page, and I couldn’t download them either.)

1 Like

Ah, right. It looks like I’ll have to join, then. Hope there isn’t a test. :slight_smile:

I was really impressed by the file sizes. You seem to have shrunk the Queen Mary down to a rowing boat! :+1:

If anyone wants to try it out who can’t/doesn’t want to create a GitHub account, let me know and I can try to upload the packages somewhere else. (But you won’t be able to get the benefit of trying the most up-to-date version as I push it)

1 Like

As far as I know, the rule is that people without GitHub accounts can download assets attached to a release (like Release 6M62 has arrived! · ptomato/gnome-inform7 · GitHub) but can’t download built artefacts straight from actions.

Many projects hosted on GitHub have their actions set up so that every time a build runs, it deletes and recreates a “pre-release” release with the build artefacts attached, so that end-users can download them.

1 Like

If anyone wants to try it out who can’t/doesn’t want to create a GitHub account, let me know and I can try to upload the packages somewhere else. (But you won’t be able to get the benefit of trying the most up-to-date version as I push it)

Please send me the DEB package if you can. You can email me at

ptomato, installed flatpak on Ubuntu 20.04 with Unity (I don’t think this is relevant though :)) without issues.


Installed the .deb on Ubuntu: no trouble installing, and things seem to work at least as well as the from-source version I installed a while back. I’ll post again if I notice any issues… thanks again for your work on this!

1 Like

My mail provider doesn’t allow sending this file, so I’ve uploaded it to inform7-ide_6M62-1_amd64.deb - Google Drive

1 Like

Thank you

Hi @ptomato, I downloaded the .deb file from Google Drive.

On my system: Linux Mint 19.2 Tina 64-bit, Kernel Linux 4.15.0-171-genericx86_64, MATE 1.22.0 (which considers itself fully up to date at time of writing: 2022/03/19),

the .deb file wouldn’t install, giving the message: “Error: Dependency is not satisfiable: libc6 (>= 2.29)”

Would you prefer me to (try to) satisfy the dependency manually, or would it be more useful for me to keep my system as the “one button install” machine?

I wouldn’t recommend trying to update libc on your system (unless you do it as part of upgrading the whole thing to Linux Mint 20.x, of course). You’d be going into “should-work-on-paper-but-rarely-tested” territory and it could break too many other things.

I guess this is unavoidable, if I build the package on Ubuntu, that it won’t be able to install on some other Debian-based distributions. I guess Debian itself should be possible but Mint is probably too different. I can try to add a .deb package built specifically for Mint to the list of packages that GitHub automatically spits out … in the meantime I’d recommend the Flatpak version, if that’s supported by your system.

1 Like

Okay, thanks!

Yes, Flatpak support is built into Mint. I just wanted to offer to do my bit… but I think you’ve pegged my skill level accurately.

I’ve tried, but the libraries on Linux Mint 19.x seem to be too old — so I’d recommend using the Flatpak version. (I’m planning to lean heavily on Flatpak anyway for distribution in the future, to avoid exactly this sort of version mismatch…)

It seems likely that the existing .deb package would install on Linux Mint 20.x. If anyone tries that and it turns out not to work, let me know. I can make GitHub automatically generate a Linux Mint 20.x package.

1 Like

Offhand, would this version roll in the most recent versions of inform6 and parchment?

Libraries were too old on the most recent distro available on stock Chromebook Linux until this past December, when Debian 11.2 became available. From that perspective, this RC is timely.

It includes Inform 6.36 which is the latest. The version of Parchment I get from the files included with the Inform 7 compiler, so that will get updated whenever we get the next release of Inform 7.

@dizzydonut For Mint, you can see on this page which version of Ubuntu the base packages correspond to. So Mint 19.x is basically equivalent to Ubuntu 18.04 LTS for base packages.

@ptomato The deb file worked on my 20.04 LTS version of Ubuntu. You may want to make sure that this works with the upcoming 22.04 LTS version of Ubuntu. Maybe it already does…I don’t know.

Re: flatpak, I would prefer appimages, but that is just me.