New builds of Gargoyle for MacOS, please test

“Brew” is working for me.

I put up a new “brew” build which fixes the Unicode-pathname problem. Thanks to kerrymg for the patch.

That build works for me now, where the previous “brew” build didn’t. Didn’t realize I had a Unicode-pathname problem!

No, I just mislabelled the build! It should have been -mp-.

I’ve been playing on Mac OS Sierra (10.12.4) for a few days now and it’s worked beautifully. Zoom has been so shaky since Sierra that this is a real treat. Thanks!

I posted one more build:

This should work exactly the same as the last one, on MacOS 10.7 and up. (I figured out how to make Brad Town’s build script work right.)

And one more:

Dannii and salty-horse pulled in an update of the Hugo interpreter, to version 3.3.0, so I did a build including that.

With the new build script, I managed to compile this with the Retina patch. I noticed no performance problems on my 2014 Macbook, but it took quite a bit of fiddling with the settings to make the text readable. It also seems to report half the actual pixel size of graphics windows.

If anyone wants to try it out, the binary is here:

EDIT: I suppose it would be more correct to say that everything is half size.

EDIT 2: Hugo seems to work fine in the non-patched version, by the way.

Both of those seem to work for me on 10.10.5 Yosemite.

That crashed on 10.10.5, with this error:

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /opt/X11/lib/libpng16.16.dylib
Referenced from: /Users/USER/Desktop/Gargoyle with retina
Reason: Incompatible library version: Gargoyle requires version 43.0.0 or later, but libpng16.16.dylib provides version 35.0.0


Yeah, the new build script is not yet fully debugged for Homebrew builds. I will take another look.

…I took another look, and I’m not sure how you got a build in that state. It links to dynamic libraries in /opt/X11/, which will definitely not work for most people.

If you install all the necessary libraries through homebrew, you may get a better result. (But it might still fail on pre-10.12 MacOS.)

Interesting. For some reason it really wants to link to the XQuartz libraries. Uninstalling XQuartz (in Homebrew) seems to have fixed it. Another attempt:

I tried building (on 10.12) with XQuartz installed, and didn’t have that problem… Maybe because I installed XQuartz from the installer at rather than using Homebrew to do it?

It might also be an old problem on my side, perhaps something I messed up when trying to build fizmo back in this thread. It’s the kind of thing you don’t notice until you ask somebody else to run your binaries.

You can examine the library linkage by typing

otool -L
otool -L
(and so on)

Paths starting with @executable_path, /usr/lib/, and /System/Library/Frameworks are okay. Paths starting with /usr/local or /opt are stuff you installed which will not be present on all Macs.

Thanks, everything seems to be fine in the latest version I posted above.

I also find that the retina patch “just worked” with no noticeable perf problems on my 2016 rMBP on macOS 10.12.4.

To make the text readable, I had to double monosize, propsize, leading, and baseline. It would be awesome if Gargoyle automagically doubled all of those numbers under the hood in retina mode.

On 10.10.5, the latest retina-patched pre-compiled app does launch and display the File Open dialog, but nothing happens when you select a game file to open. Running the Gargoyle binary inside the .app package in Terminal gives this:

$ ./Gargoyle 
dyld: lazy symbol binding failed: Symbol not found: _AudioUnitInitialize
  Referenced from: /Users/USER/Desktop/Gargoyle with retina patch try (which was built for Mac OS X 10.11)
  Expected in: /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

dyld: Symbol not found: _AudioUnitInitialize
  Referenced from: /Users/USER/Desktop/Gargoyle with retina patch try (which was built for Mac OS X 10.11)
  Expected in: /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

Thanks for the retina tweak! So nice to have it looking nice and crisp. And thanks to zarf and others, generally, for keeping things up to date so I can run Gargoyle on 10.12. This programmatically clueless IFicianado salutes you!

Just installed this version on 10.13.3.

Been playing it for a few hours with no problems.

Zarf - Thank you for the fix!