New builds of Gargoyle for MacOS, please test

I’ve posted two new test builds of Gargoyle for MacOS.

These both include Chris Spiegel’s work version of TADS 3.1.3, as well as other interpreter engine updates.

I posted two because we have two contributed updates of the Mac build script, and I want to make sure they are equally functional. The file labelled “brew-mac” should work on MacOS 10.8 and up, but I’ve only tested it on the current 10.12.3. The file labelled “mp-mac” should work on 10.7 and up.

Last time we tried this, my first test build failed on 10.11 and earlier. So if you’ve got one of those recent-but-not-completely current MacOS installs, please download both and try them out. Same if you’ve got a current Mac, actually. Check a recent TADS 3 game at least; loading up a couple of other formats would be good too.


I’m on 10.11 (El Capitan).

It seems I cannot open French games (z5, zblorb, gblorb), on both versions. I get the following error:

(In fact, the same happens with the old 2011 Gargoyle.)

I can open English games however with the “mp” one. Nothings happens if I try to open an English game with the “brew” one: no window, the game doesn’t open.

I’m on 10.10.5 (Yosemite).

The brew-mac build doesn’t open any game files at all. Well, it lets me choose from the File Open dialog box, but nothing happens when I select a game file.

The mp-mac build works better: I’ve successfully used it to open a .gblorb, a .z5 and a couple of .t3’s. One of the t3 (TADS 3) game files opened successfully, but this one opened only to display an error message: “VM Error: this interpreter version cannot run this program (program requires intrinsic function set tads-net/030001, which is not available in this interpreter)”.

I haven’t tested anything extensively, but on my El Capitan system these both seem to work with everything I’ve thrown at them. I get the same error with No Quiero Verla, though.

Off topic, but does the HiDPI patch linked here still work? That would be nice to have as an option at least.

Hm, I’m surprised that the brew-mac build works on one 10.11 system but not another. It sounds like it’s not reliable, though.

The failure on No_Quiero_Verla.t3 is a matter of how the interpreter is built – maybe some sub-module is not being compiled in. I’m not the expert on that.

I never tried the high-DPI patch. The fact that someone described it as too slow on a fairly modern iMac is discouraging, though.

Can you list some examples of games where this happens?

EDIT-ADD: Ok, I see – this error occurs when the filename contains non-ASCII characters. Just renaming the file should be sufficient to work around it. I’ll file it as a separate problem.

Yes, you are right. However, all special characters have to be removed from the file’s path (not only from the game file).

My French games were in subfolders of a folder named “Français”. Replacing it with “Francais” solved the problem.


“Brew” is working for me.

I put up a new “brew” build which fixes the Unicode-pathname problem. Thanks to kerrymg for the patch.

That build works for me now, where the previous “brew” build didn’t. Didn’t realize I had a Unicode-pathname problem!

No, I just mislabelled the build! It should have been -mp-.

I’ve been playing on Mac OS Sierra (10.12.4) for a few days now and it’s worked beautifully. Zoom has been so shaky since Sierra that this is a real treat. Thanks!

I posted one more build:

This should work exactly the same as the last one, on MacOS 10.7 and up. (I figured out how to make Brad Town’s build script work right.)

And one more:

Dannii and salty-horse pulled in an update of the Hugo interpreter, to version 3.3.0, so I did a build including that.

With the new build script, I managed to compile this with the Retina patch. I noticed no performance problems on my 2014 Macbook, but it took quite a bit of fiddling with the settings to make the text readable. It also seems to report half the actual pixel size of graphics windows.

If anyone wants to try it out, the binary is here:

EDIT: I suppose it would be more correct to say that everything is half size.

EDIT 2: Hugo seems to work fine in the non-patched version, by the way.

Both of those seem to work for me on 10.10.5 Yosemite.

That crashed on 10.10.5, with this error:

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /opt/X11/lib/libpng16.16.dylib
Referenced from: /Users/USER/Desktop/Gargoyle with retina
Reason: Incompatible library version: Gargoyle requires version 43.0.0 or later, but libpng16.16.dylib provides version 35.0.0


Yeah, the new build script is not yet fully debugged for Homebrew builds. I will take another look.

…I took another look, and I’m not sure how you got a build in that state. It links to dynamic libraries in /opt/X11/, which will definitely not work for most people.

If you install all the necessary libraries through homebrew, you may get a better result. (But it might still fail on pre-10.12 MacOS.)

Interesting. For some reason it really wants to link to the XQuartz libraries. Uninstalling XQuartz (in Homebrew) seems to have fixed it. Another attempt: