IntroComp 2012 Entries Released, Voting Open

Hi, everyone.

The site at has been updated. The games are available, the voting page is live. Download, experience, vote and leave feedback, post reviews for the benefit of authors.

Voting closes August 15th at midnight Eastern.

Thanks in advance for supporting IntroComp by participating as a voter.

Best regards,

  • Jacqueline

PS - If you encounter issues with the comp site, please e-mail me using the information that can be found at the site rather than posting a reply here, as I generally do not frequent and will not see your issue here. Thanks!


It looks like a good variety–2 web games, 1 Quest game.

Congrats to those who wrote a game. I couldn’t get nearly enough done, but I hope to judge. Maybe I’ll even post a review topic here–I’d encourage others to do the same. Or maybe post a link to their blogs where they’re reviewing, in this topic.

Nice! I tried out Belief just now, but didn’t get very far with it. For one, there were a couple of irritating bugs (mostly cosmetic things, but a good beta-tester would have found them), and two, I had no idea what I was supposed to be doing. I attached a transcript of my playthrough, mainly for the author’s benefit. It does contain spoilers, so I wouldn’t recommend looking at it without playing the game first.

I am the author of Belief, for my sins, and probably any beta-tester would have found them, in fact! Circumstances conspired against it, though.

Thanks for the transcript; they’re always appreciated.

>PULL CORNER is the verb you were hunting. I had originally coded in at least some of the other verbs you tried, but I had to do some source-code thrashing at the last minute to fix an intractable compilation bug, and they seem to have fallen victim to that.

Speaking of which, and out of curiosity, is there any particular reason why the game was in glulx format instead of zcode?

I whipped through the games pretty quickly. Here are some brief reviews, in the order I played them. There are no spoilers.

This is a ChoiceScript game, set in a climate change-induced post-apocalyptic desert. It’s Dirtworld, essentially, and you’re Kevin Costner, saving villagers from roving gangs, at least in the intro.

I felt like it was more of a NoChoiceScript game than ChoiceScript. There are a few decision points of the type, Do you want to check out the obviously important thing, or ignore it? Even if you choose the latter, you encounter the thing, of course. There’s also a point in a flashback sequence where you’re presented with three clearly differentiated choices. All three lead to the exact same outcome.

In the credits, the authors deliberately misspell a word as a joke when thanking their testers. They then go on to make about two dozen actual spelling errors.

Do I want to play the completed version? No.

This is another ChoiceScript game. Your PC is unexpectedly tabbed to be a sort of regional honcho in a fantasy empire with the typical trappings: elves, swords, etc. The intro takes you through meeting a few NPCs, establishing your backstory, gender, and sexual preferences, and receiving your first mission. Most of the NPC-related choices are, Do you want to to be a jerk to this person, or not? Naturally, I tried both, and it didn’t change the course of the story that much, but I’d expect that the ramifications would be much greater in the full game. There are also a number of choices where there wasn’t enough context to understand what I was deciding. For example, what color armor would I like? Still, there was more choice here, and more meaningful choice, than in Wasteland.

There are also a great many spelling and formatting errors, including several pages where there are no spaces after periods. I’d recommend that the author enlist some testers and proofreaders.

Do I want to play the completed version? Maybe.

This is an experiment in using hyperlinks for the interface. On Gargoyle, it defaulted to an unreadable color scheme: the links were dark blue on a black background. I changed the links to yellow using the ini file, and it was much better after that, but still clumsy. Playing on a small screen, I had to hit the space bar multiple times after each click so that the links at the bottom were re-displayed.

The game is “An Interactive Genecide [sic],” but there’s not enough here to say what it’s really about. You awaken (actually he or she awakens – the text is in third person) in a dark room, attached to some menacing contraption. The player clicks a few links, and the game ends. It was not beta-tested.

There may be value in replacing the standard IF parser, but GENESIS doesn’t show enough to say why.

Do I want to play the completed version? Probably not.

A very short intro. You’re a recently-dead soul in a waiting room, trying to make your way to your final destination (or any destination, really). The intro is an escape-the-room scenario, made a little more difficult than it needed to be. I found the objects I needed in very short order, but had no idea how to make them go. Eventually things just happened and I escaped.

As an aside, this is at least the third game released in the last year to feature Charon the boatman, and probably the tenth or fifteenth time I’ve seen him in IF overall.

Do I want to play the completed version? Yes, I think so. The writing – what little I saw of it – was clever.

The Bafflingly Casual Adventures of No One of Significant Import
This is a My Crappy Apartment game, combined with some RPG elements and monster fighting. I found it aggressively unpleasant most of the time. The writing is conversational in a sort of asshole-buddy mode, substituting attitude for wit. I found it a chore to read.

The gameplay involves poking around your filthy apartment for a few items, heading to your bog-standard degrading workplace for a bit, and then returning to your apartment, where you fight a not-well-described monster using menu options (wait, attack, jump out of the way, etc.). Your PC’s health is tracked through happiness points, which you can lose either by being struck by the monster, or by having a sad (discovering you’re out of Mountain Dew). If you manage to defeat the monster before your happiness hits zero, the intro ends.

Do I want to play the completed version? No.

This is the most substantial of the IntroComp entries, and one of the more frustrating. The game advertises itself as An Experiment in Sound, and the ABOUT text strongly discourages you from playing without sound enabled. Normally, I don’t care much for sound/music in IF; usually I listen for a little bit to get a feel for it, and then turn it off. The audio in Compliance was pretty effective and creepy, though, and I kept it on the whole way through.

The game involves penetrating some evil corporate or government headquarters to find a secret file involving a missing loved one, and then escaping. I was immediately hooked; it’s a good setup.

The problem is in the implementation. Interactivity, in general, is pretty low. Most objects can’t be manipulated in any meaningful way. The one object I found which could be manipulated offered no clues as to how to do so. In fact, I’d go so far as to say it was anti-clued: the description actively discouraged the necessary action. There’s tons of unimplemented scenery, which makes for frustrating play, especially since so much of that scenery appears to be important. Exits are frequently not described. The main object of your search is not even mentioned once you find the room. You just have to guess it’s there. The ending that I found (maybe not the only one) was accessible through a dirty IF trick, one that was arguably unfair in 1976 when it first appeared in Adventure.

Do I want to play the completed version? Maybe. I liked the setup and the music, but the gameplay needs work.

There most certainly is! I set it that way while I was trying out an extension that required glulx, and then entirely forgot to set it back when I decided not to use it. And Now You Know!

Ah, the light doth shineth through. Thankee kindly, squire.

Thanks for taking the time to post this. I appreciate candor, and these design points are really helpful.

Huh. I must have missed that… I found an ending (one that didn’t require me to use practicaly none of the interesting things around that looked as though they were going to be very important, like

[spoiler]* luring a bot into Hydraulics, or

  • causing contamination[/spoiler]

I found no unfairness… could you tell me about your ending, please?

Major spoiler, needless to say:


attack worker
The worker is certain to call for help. With escape so close, do you really want to risk a general

The worker is taken completely by surprise, and falls into the effluent river, and is quickly swept
away by the current. A few moments later, your fears are confirmed as a siren begins to sound.
You hurry to the exit.

Alarms blare behind you as you descend the stairs, as quickly as possible. With luck you might be
able to make it out of the complex and flag down some transportation before security arrives–

*** To be continued ***


So on my first playthrough it looked exactly like the dragon puzzle
in Adventure, which was not my favorite puzzle. But on replay, I see you can also just


and get the same effect. So it’s much less of a dirty trick than I thought it was.

I appreciate the fact that you’re calling it candor. After I posted my reviews, I looked back at them the next day, and thought that I had been sort of a douche and not constructive enough.

Anyway, ChrisC, I hope you do finish the game. I’d be interested in beta-testing if/when you get to that point.

Aaaaaaaaaah. I got that, but I tried it even before I’d achieved what I’d gone there to achieve - as you pointed out, the machine you need to use in order to achieve it is woefully underclued, I had to try four or five different commands to achieve something that I thought might work and was surprised when one of them was actually accepted.

It’s not really the same as in Adventure, though…

[spoiler]Here, you’re being asked to take a risk: can you get rid of him before he sounds the alarm? And he’s unaware of you, and leaning into the waste.

In Adventure, you were asked if you wanted to kill a dragon - a big hulk of a thing, fully aware of your presence - with your bare hands, and if so, it cheerfully complied.[/spoiler]

Not at all. Maybe I’m just a weirdo for enjoying when people tear my stuff apart – I think brutal honesty is really important as far as knowing what and how to improve. That’s especially important in a case like this, where I’m going to fix up and expand on the initial work.

At least, hopefully. If it is received well, I’d hope Colin and I would ultimately be able to deliver. Don’t get me wrong, the partnership’s been fun so far – I enjoy the change of pace in terms of the working situation – and he’s been great to work with and has written some great music; but I guess giving up some autonomy is always at least a little scary.

Thanks for the offer, I’ll definitely keep you in mind!

I’m so looking forward to write new music for that game! I think we could deliver something quite nice. I was pleasantly surprised at how well the setting and the music clicked together.

I certainly prefer it to no feedback, or to tepid positive feedback that amounts to “well, it didn’t actually unplug my refrigerator”. The feedback on Belief seemed pretty constructive to me, if brief (I’d like more expansion on what constitutes a “sufficiently hard” escape-the-room puzzle to Mr. Patient, and I always like transcripts), but certainly all things I can actually target for improvement.

Sorry, I didn’t keep a transcript. As for the puzzle, what I was trying to say was that I think it might have turned out harder than you intended it to be, because it wasn’t clear how the pieces really fit together.

I found the brochure/coupons and the bell straight away, and rang the bell a few times, but nothing interesting happened. I then fumbled around for a few dozen turns. Then it seemed to me that the bell started mysteriously ringing itself, at which point I rang it a few more times, and voila. It was only later that I realized that to “activate” the bell you had to get the afterlife coupon (not merely get the brochure), and then examine the coupon, even if you already had examined it. It’s not obvious why this would be the trigger, hence my confusion.

I’d also add that

I expected the required action at the end to be GIVE COUPON TO FIGURE, or something similar. It wasn’t clear from the description that the platform was enterable.

Hope this makes more sense.

It does, thanks! Very helpful.

Ohhhhhh is that how it’s supposed to work. Yes, this is very similar to my experience. I did all of those things in not exactly that order; specifically, I didn’t examine the coupon after I cut it out. I did spend a lot of turns attempting to ring the bell in all possible configurations, like putting bell, coupon, and coin in the hole together, and having them all in my inventory with nothing else, and attempting to re-close the carpet. I also prayed, sang, jumped, and waited a lot of turns on the hopes that maybe something magical would happen after some round number of turns.

As general advice to the author, I would recommend either not requiring that specific order, or heavily cuing when a repeated action is needed. In this case, it’s that the player needs to examine the coupon after cutting it out, even if they’ve examined at it before. Requiring the bell to be rung thrice is similarly a bit unfortunate; I only rung it more than once because I was desperate and there was nothing else to do; ideally, you’d avoid the desperation in the first place with a bit more guidance.

That said, these are very fixable problems, and the overall experience is a fine one – the actual code is solid, and the story is intriguing if a bit generic. The fact that I spent as much time as I did in trying to solve it is a good sign; so far I’ve quit the few other intros I’ve tried after just a few turns.

Thanks! Your mechanical points are excellent. I actually gouged out a semi-conversational system to provide more backstory and exploration of the situation about three quarters of my way through working on the intro, because it was turning into a deep morass of inconvenience and I thought maybe I should get around to finishing the intro puzzle instead - so hopefully the story will continue intriguing while becoming a little less generic as I rework that.