[i7] Game pane blank after successful compile

Hello there. Hoping someone has some insight into a problem I have with Inform 7 for Windows (Windows 8) on a new laptop.

Everything appears to work fine until I compile one larger sized glulx game. The game will compile (and release) fine but afterwards the game will not appear in the right hand pane for testing. The index shows up as well as all the other tabs except for the blank game tab. I have uninstalled Inform 7 a couple of times and reinstalled with the same results. If I start a new project and just put in one room it will compile and appear in the game pane fine. It just does not show for this one particular game although he game compiles and the shows in the game pane just fine on my desktop (also running Windows 8).

I have spent the last day searching here and the Google for an answer but can only find some references to the game pane not showing up for any game, not just one in particular. Those suggested re-installation that helped one person solve it but the re-installation did not solve my situation.

Thanks in advance for any assistance.

Does the IDE think the game is running? (Is the “run” or “stop” button enabled?)

My guess here is that you’ve done something iffy in your code – could be your game setup, or something about the status line – and the result is inconsistent between interpreters. However, I don’t have a lot to go on here.

Hey zarf, thanks for the assistance.

I did not notice it before but after the compile the stop button is greyed out while the game pane is empty. I just removed any custom status line code and that did not solve it. I tried a different game with the same status line code and it worked fine.

I think you are correct in that it might have to do with some code I have but why would it work fine on my desktop and not on the laptop?

EDIT: I started stripping down the code and found that the Flexible Windows extension was causing the issue. Still trying to figure out why it would cause this error only on my laptop and not on my desktop.

Flexible Windows on its own should not cause this problem. Did you try doing a full release of the game to see if you can run it outside the IDE, whether in Windows Git or Gargoyle or Filfre?

As I said – it is likely that the bug is in your code somewhere, in the way you’re handling windows, and it just appears differently on the different machines.

Hello Erik,

The game compiles fine and runs externally on an interpreter just fine as well. I did a short troubleshoot attempt by creating a new game with only one room and the latest release of the Flexible Windows extension (and required extensions for it). This resulted in the same problem. I can eliminate my code at this point since this “game” results in the same situation, it compiles but the game does not show in the right panel of the IDE with the stop icon greyed out.


Include Flexible Windows by Jon Ingold.

Office is a room.[/code]

Maybe this is an unconventional way of “fixing” things but after another complete uninstallation and re-install resulted in the same situation I decided to try and copy the entire Inform 7 directory (minus projects) from my desktop to the laptop.

I don’t know which file is causing the issue but now Inform 7 works fine. I guess I can live with not knowing the exact problem with a fresh installation since it is working now.

Thanks guys.

I tried your test code but it works for me.

It is an odd problem for sure. On a fresh installation I can easily replicate the problem on my laptop. Simply doing a fresh install and then copying the files from my desktop over replacing those files fixes it. I can only guess that the installation package for Inform 7 doesn’t install something properly on the laptop.

I like the Flexible Windows extension very much and am glad I don’t have to think about working on my project without it.

From what I have found through online searches it is a very isolated occurrence, and since I was able to resolve it to my satisfaction, I don’t think anyone else should have to worry about it.

I wish you had found what was wrong, because I’m encountering the same problem.

It’s generating this error in quixe: Quixe init: glk_put_jstring: invalid stream

Are you also seeing the game pane come up blank in the I7 IDE? That’s what this problem was about, not a Quixe error.

Yes, it’s blank in the IDE; and Nutso’s minimal example reproduces the problem.

When I Release and run in Quixe, I get that error I mentioned. I expect them to be related, and the IDE isn’t reporting it for some reason.

I think this is likely to be related to the problem discussed in this thread: [url]IF Archive Hugo Downloads]

There the problem is an error in Flexible Windows. When the game is compiled in debug mode under the front-end, the error should lead to a “Run-time Problem” message. However, the error occurs very early on in the game, before its had a chance to set up any windows, so the game stops with nothing shown at all.

I suspect that the computer on which the game works has Flexible Windows version 12 as an extension, while the one that doesn’t work has version 13. Either drop back to version 12 everywhere, or use the updated version Danii posted in the above linked thread (I’m not sure if Danii’s update has made it to the Inform 7 web site yet).

Same problem using Danni’s updated version.

With version 12, it has the same problem in the IDE. The error in Quixe is different, “Quixe init: gli_set_style: invalid stream”, but it still doesn’t work.

(Apropos of nothing, this is why I don’t like the convention of tagging a forum thread as “[solved]”. The original poster found a workaround but that doesn’t mean the problem is solved for everybody.)

Not only that, but he didn’t stick around long enough for us to figure out why his workaround worked. I’d very much like to compare his version of every extension involved with my own.

For example, Inform7 seems to come with Glulx Entry Points version 9; but only version 6 is available on the website. What version did he have?
Maybe he was reinstalling an older version of Inform7 that did not have this problem?
Could he have overwritten an extension with an older or newer version without realizing it?
Maybe there was a different version of a extension included with Inform 7 sitting in his documents folder, keeping Inform from loading the included version that has the error?

I’d really like to find out since the only other option right now is to dig all the glulx code out of flexible windows and try to get something working the hard way.

I didn’t go anywhere.

The version of Glulx Entry Points that I have is version 9. I haven’t downloaded any version of this at all. I’ve only used the one that was installed by the Inform 7 installer.

Help - About Inform shows: Inform 7 for Windows (2nd March 2012; 6G60)

I stripped down all the code to the minimalist code that I posted earlier in the thread, basically just Flexible Windows (version 13) and Glulx Entry Points (version 9 as stated above). Would an extension that is not called for in the code have an effect and cause the issue I had?

Let me know if I can help with anything else.

Ha - I thought that would get your attention!

The newest version of inform is from April 25th, 2013, AFAIK.

Does anyone know where I can get the older version to test it? Nutso; I’d suggest you get the newer version but you’d probably just break your own stuff again.

I installed a second copy of Inform 7 (the latest one showing the April 2013 version date) and tried compiling the project I am working on. The results were the same as before, with a blank screen after attempting to compile. When I open the same exact project in the March 2012 version of Inform 7 there is no problem and it compiles fine.

I guess there is something in the latest version that is causing the issue. I’ll continue to use the older version for this project since it is working fine for me to this point.

Unfortunately I have a different issue with the older version where, once the game reaches a certain size, it craps out. And by a combination of a hyperlink interface, intelligent hinting, and threaded conversations, the number of objects in the game is really quite amazing.

Seems odd, though. AFAIK the compiler didn’t actually change between those versions. At least, it’s still version 6G60 of inform7. I hope DavidK can track down the problem and shed some light on why it’s also causing an error in Quixe.