Html panels in the linux inform7-ide are blank?

i have tested this will several releases of the app just encase it was the version i built from the git repos but this happens both with the built from git version and the flatpak release. it seems anything using html from the index, the results report, documentation, and extensions are blank in the ide. i would do more in-depth testing but i can not seem to find a way to get more verbose information from inform7-ide when it is running

In this topic, @Natrium729 had success initially with the rpm and then (last message) with the flatpak.

But to be fair, I have absolutely no idea what fixed it with the flatpak. And the RPM might not be applicable to you, depending on your distro, I believe.

Could you give more detail? What distro, version of Gnome, and so on.

With earlier versions of Gnome-inform I have found blanking issues (involving the menu and the icon bar) and I discovered that the blanking was related to the theme in use.

I never have haved blanking issues with the index and htm rendition in general, whatever the theme in use was, though.

Best regards from Italy,
dott. Piergiorgio.

distro: manjaro
(by gnome i guess you mean the gtk3) - 3.24.37
libxml - 2.10.4
glib - 2.76.2
gio - 2.76.2
gdk - 3.24.37
libhandy - 1.8.2
pango - 1.50.14
gtksourceview - 4.8.4
gspell - 1.12.1
goocanvas - 2.0.4
webkit2gtk - 2.40.1
libplist - 2.3.0
ratify - 2.0.0
chimara - 0.9.3

i have tried building the ide with both gcc 13 and clang 15 to see if that changes anything that did not change anything.
i have also tried changing the gtk3 theme for adwaita, breath, high contrast, and default. and nothing changed there

1 Like

tried downgrading to webkit2gtk 2.40.0 but that did not fix it.

EDIT: tried seeing if i can highlight the text inside of the documentation and that doesn’t work either

well i seem to have got it working now. the problem seems to be that it was trying to load a broken theme(even though that was not the theme selected in gtk3 settings), uninstalling that theme seems to have fixed the problem. well now i know that it tries to load all themes and then use the selected one


Thanks for the report. I’m glad it’s working now, but I’m mystified — Inform doesn’t interact with your GTK theme at all, so it’s not trying to load any broken GTK theme. The only themes it looks up are syntax highlighting color schemes, maybe the broken GTK theme also installed broken syntax highlighting?

the themes and syntax hiliting works fine (I use Kate hiliting, for consistency with my main editor) but the lone major issue with the source pane is already reported, the font size don’t change, remaining fixed to the default size, whose I find too small (not for myopia, but for ease of, how to say, quick legibility ?) when indeed the html-based panes duly changes their size (I can provide a screenshot if needed)

what really matters is that the issue with X window themes whose plagued the ide 1.x are gone, hopefully for good.

Best regards from Italy,
dott. Piergiorgio.

The preferences window is getting an update in the upcoming version. You’ll be able to select documentation font size and source font size separately, and both should use the size from your theme by default.

1 Like

ok, thanks. pls keep thge good work !

Best regards from Italy,
dott. Piergiorigo.