Issues using Inform 7 10.1's IDE on Linux

Asking here first before maybe reporting issues on the tracker.

I tried installing the latest version of Inform’s IDE on my Fedora 36 installation but encountered multiple issues. This post

recommends using the Flatpak on Flathub, but the page hasn’t been updated and still says it’s 6M62 and that the code is not open source. I downloaded it anyway and it’s actually really the 10.1 version. But the webviews in the app (the documentation, the index…) are blank (although I can still select the text). Also changing the font or the font size in the preferences doesn’t do anything.

I then tried the RPM available from the release page of the GitHub repo. The webviews work. Changing the font size only affects the documentation, the story, and others, but not the source. Changing the font only affects the story (after recompiling it), not the source nor the documentation.

Finally, Inform doesn’t use dark mode, although I’ve seen screenshots with dark mode enabled on the issue tracker, so I’m not sure if all these issues are only on my own.

Bonus question: If I want to use Inform on the command line (without having to compile it myself), what should I download (since the Perl script doesn’t exist anymore)? The compiler seems to be embeded somewhere in the Flatpak, but I don’t know where exactly. With the RPM installation, it’s located at /usr/libexec/inform7-ide/inform7. It would be great to have a default, “stable” path, say in ~/.inform/bin. I asked because I want to know what would be the “default” path to use in my VS Code extension.

Thank you!

My solution was to build from source, which requires locating some obscure other repositories: Chimara and Ratify. These are undocumented dependencies for the Linux IDE, but building them both from source worked.


Try the flatpakref on the I7 release page.

1 Like

I’ll look into why the version notes didn’t update there, thanks for reporting it.

Oops! Since this isn’t happening for me and it sounds like you have dark mode enabled on your system, that might be the cause. Does it go away if you switch back to light mode?

Unfortunately the Linux app doesn’t have dark mode. It needs another round of modernization before that can happen.

The Inform compiler’s build system, as far as I understand, intentionally doesn’t have an “install” function, rather it copies the compiler into the source tree of one of the IDE apps. A stable path sounds like it’d be a good discussion to have, but it does not exist right now.

If you want to run the command-line Inform from the Flatpak, you have to do it inside the app’s environment: from memory the command is something like flatpak run --command=bash com.inform7.IDE, this starts up the environment, then the compiler itself is located at /app/libexec/inform7-ide/inform7. To exit the environment, type exit. You might also be able to run it directly in one shot with flatpak run --command=/app/libexec/inform7-ide/inform7 com.inform7.IDE -- (compiler arguments go here).

I’m sorry to hear that these were difficult to find — I tried to set up the build system so that if you are building from source, and you don’t have these dependencies, they will be downloaded and built automatically. Do you happen to remember if you got any error message indicating why that might not have happened, or have a log sitting around of your build?

1 Like

Unfortunately I don’t think I have a log around any more. There was a warning that it couldn’t find them, so it would use its own version, then a flood of linker errors from being unable to find those two libraries.

I built it from scratch smoothly a bunch of times. @Draconis, did you maybe have existing outdated versions of those lying around under /usr/local or something? My first speculation would be that you didn’t have a fresh environment – I was doing it in a docker image.

1 Like

Not as far as I know. It’s possible, though, from some old version of the IDE.

Thanks for the answers! I recently switched to Linux, and the most confusing is installing apps (like, choosing between RPM, Flatpak, AppImage, DEB…).

Doesn’t the flatpakref simply point to Flathub? In any case, it didn’t change anything.

Nope. The webviews remain blank:

I can still interact, though: clicking, selecting and copying work (but it all remains blank). When I click and drag the selection or an image inside a webview, the selected content appears and follow the mouse, but that’s it.

Understood. It was issues like this one that led me to believe the IDE had dark mode.

Regarding using the compiler on the command line, at least the GitHub release page could also give the Linux executables, ideally with the retrospective too? (No need to do that for Windows and macOS since it’s quite easy to find them in the IDE installation, and like that it won’t confuse regular users too much.) But that’s a bit off-topic.

Anyway, if there are no ways to increase the font size of the source pane and use dark mode, the IDE is not really pleasant to use for me right now. (But I mainly use VS Code, so that’s OK, no need to rush and fix those issues only to please me. :slightly_smiling_face:)

Wait, it doesn’t have dark mode? For me if I go to Edit > Preferences > Formatting > Styles I can set the color scheme of the whole application; I’m currently using “Oblivion”. Is that provided by my desktop environment or something other than the IDE itself?

yup… sorry. Its URL gave me false hope.

Setting the style only affects the source pane (i.e. you get a black source pane but the GNOME bits like the top of the window or the buttons remain white).

I would have thought the GNOME app would respect my GNOME settings, but that’s not the case. I haven’t found a way to enable dark mode from within the IDE. (I’m on GNOME 42.4 on Fedora 36, if that matters.)

Granted, the following would probably confuse regular users at least as much as directions for compiling from source would, but one could download the .deb and then:

ar x inform7-ide_2.0.0-1_amd64.deb
mkdir scratch
cd scratch
tar xf ../data.tar.gz
echo "Lab is a room." > test.i7
usr/lib/x86_64-linux-gnu/inform7-ide/inform7 --internal usr/share/inform7-ide --source test.i7
usr/lib/x86_64-linux-gnu/inform7-ide/inform6 -E2wSDG test.i6 test.ulx

The important parts would be to copy inform7, inform6, inblorb from usr/lib/x86_64-linux-gnu/inform7-ide/ to something like /usr/local/bin and to copy all of /usr/share/inform7-ide to something like /usr/local/inform7 – that would be your internal dir. (And people on Red Hat derivatives could do something similar with the rpm.)

1 Like

Huh. For me, everything except the documentation and index (i.e. the HTML generated by Inform) is dark-themed: the skein, the interpreter, the toolbars, the menus, etc. I’d thought it was the style set in the Preferences, but you’re right, that doesn’t change the general UI elements.

Which means the rest of it is my GNOME theme, I guess? I’ve got 3.36.8.

Well, I reopened the Inform app installed from the FlatPak today, and now the webviews are all good. I guess some update fixed it at one moment. So at least this issue is solved.