Gargoyle on Ubuntu 20.04 not accepting input

Gargoyle runs, but it won’t accept input, whether from keyboard or mouse. It gave a warning about missing dependency (libcanberra), but while installing it solved the warning, the issue remains. The introductory text comes up, and then it freezes.

This unexpectedly frustrating. Does anyone know anything else I could try?

@Eleas Hey Bjorn, when I run the test for gnome-inform7 on 20.04 I will try to give a shot at building a new Gargoyle deb too.

2 Likes

@interactivefiction that would be great! Please let me know either way.

I attempted to make a build on 20.04, but it seems the OS is still very early in the development cycle and several libraries required to build it are not yet available in the repositories. Mainly libicu-dev_65. I am sure this will get addressed over time, but at the moment it is not possible to make the build on 20.04. I may give a shot at performing the build on 19.10 and then look to see if that build will run on 20.04. Will let you know.

1 Like

Ah well. Thank you for taking the time to check. Gargoyle is a convenience, so I’ll just wait for 20.04 to mature.

Well the good news is I found a way to address building gargoyle, the bad news is that the test build of gnome-inform7 needs to be uninstalled to do that. Turns out building gargoyle helped me find a issue with gnome-inform7. I put instructions to remove it here and advise you take it off your system:

Here is a link to a deb I built for gargoyle, it looks like it works fine. I loaded a game up and text input etc was working. Note: this build has SDL disabled so no sound.

1 Like