Gnome-inform7 6L38/6M62 IDE now running on modern Ubuntu & Fedora OS

It works! Installed it just as you said, it showed up in my apps, I created a 1-room game and ran it and everything seemed okay. It did crash after the first time it compiled the game and I had to reload it, but smooth sailing on the second compile. Thanks so much.

1 Like

@EarleyGrave Those ‘crashes’ are a known issue affecting gnome-inform7 overall. They wont be fixed in the current code base but the re-work will address it. I am considering back porting the fixes to the old code base that would avoid those spurious crashes but it will take some effort. Here are a few things that seem to affect the frequency of the crashes:

  1. Size of the inform7 project, very small projects crash more often than large ones. So… think BIG!
  2. Running gnome-inform7 from the command line instead of using the app launcher seems to let gnome-inform7 run with less crashes too.

Neither of those is a ‘fix’ but it might make life slightly less annoying :grin:

2 Likes

Nice. :slight_smile: Cheers!

1 Like

@Eleas Hi Bjorn, it appears that the 19.10 build also works on 20.04. I have performed an installation on the 03/15/20 build of Ubuntu 20.04. If you attempt an install, I would appreciate your feedback of how it works (good or bad). My approach to get it working followed the instructions I posted here:

Hey @interactivefiction, I successfully installed the new build. So far, other than a folder-clicking issue in the Create New Project dialog (which still works better than it used to, and in any case can be bypassed via the file path), I have no issues.

Much gratitude for the fix. This is great.

1 Like

Hi Everyone, I believe the latest build for 19.10/20.04 could have some issues because of the included libicu package in the deb. A cleaner way of dealing with the dependency is very much needed. Using it will likely have some unexpected side effects on the system.

@Eleas @EarleyGrave since you both installed the untested deb to help with initial checking, this post is for you!

For now I recommend that people uninstall it from ubuntu 19.10 / 20.04 gnome-inform7 package using:

sudo dpkg --remove gnome-inform7
sudo dpkg --purge gnome-inform7
2 Likes

Thanks for the heads-up.

1 Like

No problem, I just had some issues crop up attempting a build for gargoyle on ubuntu 20.04 that were caused by the gnome-inform7 test build including its own libicu (one of the reasons testing help is always needed for this stuff). Will let you know when I get a new build up and running that addresses the issue.

1 Like

I was having some video issues with Ubuntu 19.10 and switched to Linux Mint 19.03… which I know is a derivative, but it fixed my problem somehow and also is easier to use. Thought I’d let you know so that you didn’t do work that I couldn’t test out for you on this OS (though for all I know, since it’s a derivative, I might be able to).

That should still work! @Dizzydonut is a Mint user too :grin, believe Linux Mint 19.2 “Tina” was tested if you look up earlier in the thread. I believe @Dizzydonut used the older deb package for 16.04 / 18.04. One caveat, if I remember correctly the 6L38 build worked better than the 6M62 build on Mint.

I’m so discombobulated by Linux. I searched for Inform7 in Mint’s Software Manager and it actually came up, through “Flatpak” distribution, and it’s downloading the framework to be able to run it now. If that works, I’ll never backpedal to standard Ubuntu. If not, then I’ll try the other options. Why are things so complicated? lol

1 Like

I think the flatpak will work, but it does have some issues. @Dizzydonut actually was using the flatpak on Mint too so you might give a ping and ask for any tips :slightly_smiling_face:

As far as the complications, most of the issues for gnome-inform7 right now are caused by deprecation of APIs (in all Linux OSes) that the program had previously been using. Upgrading the program from those old APIs to the replacements takes a ton of effort.

It did install and run with the Flatpak. I’m surprised Ubuntu didn’t have Flatpak enabled by default… there’s no way I’d have even known about it. Mint is kicking Ubuntu’s ass so far. Anyway if I run into trouble, I’ll check with Dizzy about that or try one of your workaround builds. Thanks again for the help!

1 Like

Hi everyone, an interesting post that may be useful to others:

2 Likes

Hi there @EarleyGrave, I’ve been away for a while but I’m back home now, and have access to my Linux box again. I’m using Linux Mint 19.2 Tina, with the mate desktop. I found the latest flatpak rather crashy, but did have the file bar and the public library tab etc. working. (Though you have to enable net access via the command line.) So what I did was to install the latest, set my preferences and download all the extensions I wanted, and then revert to the previous flatpak which I’ve found more stable – not purging all the settings, obviously. The problem with the vanishing Menu bar (on the Mate desktop) seems to only happen when I’ve had I7 running for a long time, so I exit it when I go off to make a cuppa or something.

I’m no Linux guru, just an ordinary user, but if you’ve got any questions I’ll be happy to help.

1 Like

I can’t really use new Inform systems because I prefer to stay on the 6G60 system (I’m using French language), so I’ve kept the old binaries and I’m using a makefile to compile. There is a copy of my makefile there: https://sourceforge.net/p/la-vallee-mysterieuse/code/ci/default/tree/makefile

2 Likes

I am inspired by your makefile! I will be giving it a try myself :grin:

1 Like

I’m running Linux Mint 19.2 “Tina”, with the Mate desktop.

Just wanted to add that I’ve discovered a workaround for the missing toolbar. When the toolbar disappears (as it’s prone to do after I7 has been open a while), open a terminal, and type:

pid mate-panel

This will return a number (the process ID). Let’s pretend it was 1234:

kill 1234

This will shut down the faulty panel, and mate will notice, and then re-create it. It seems to remain working for much longer, too.

2 Likes

Hi Everyone, I have had to take a little detour from keeping gnome-inform7 legacy code alive because the workarounds are just not worth putting in place for Ubuntu 20.04 or Fedora 31 and forward. At this point the official gnome-inform7 gtk3 branch is really the best way forward. In the short term, I still needed a working environment for newer Linux distros and created a fully integrated console environment for developing Inform7 works (edit, compile, run, debug all from one place). If you dont mind working inside of a terminal the project might be of interest to you. Open source, installer, full documentation etc are all in the thread linked below.

3 Likes

Just FYI for anyone trying to get gnome-inform7 working on modern releases: I was able to get interactivefiction’s version above working on a fresh install of Linux Mint 20 Ulyana today by first manually adding the following packages:

libicu60 *
libgtksourceview2.0
libgtksourceview2.0-common
libgtkspell0
libjavascriptcoregtk-1.0
libwebkitgtk-1.0

The packages were obtained from https://packages.ubuntu.com and all versions were taken from the bionic release, using amd64 versions. The last five of the packages are directly required by gnome-inform7-6M62-ubuntu-1604-1804.x86_64.deb. The first one (libicu60, marked with an asterisk) is required by one of the other packages (libjavascriptcoregtk-1.0, I think), so it should be installed first. After that, the first five, and after those, the actual application.

Installation is easy enough using gdebi-gtk (GUI) or gdebi (command line) for each .deb file. Since Linux Mint 20 is based on Ubuntu 20.04, a long-term support release (and therefore the same process should work for both), this should be possible until at least 2025, assuming you can still get the bionic packages after 2023.

Thanks to @interactivefiction for your work on updating the package for the previous LTS release! It’s very much appreciated, especially the bug fix for the grayed-out folders problem. I haven’t tried out vimform7 yet, but it looks promising.

[FYI - Even though you’re not working on this any more, there is one other minor bug that you might look into: When creating a new project for an extension, the application creates a folder for the extension called Name.i7x and a file containing the actual extension called Name.inform, both on the same directory level. In other words ,the suffixes for file and folder are reversed, and the file is not placed inside the folder.

I did report this as a bug in Mantis, but that’s down now, it seems. I would think given what you’ve already done that this would take a pretty short time to fix, perhaps just swapping the relevant suffix strings to fix the names and adjusting a path to fix the file’s saved location. Is the source code for your version posted somewhere? If so, I would be happy to look for the specific lines myself, to assist.]

2 Likes