fizmo 0.8.0 released

The 0.8 branch of fizmo comes with a SDL2-based screen interface. Using the freetype2 engine, it allows for proportional font display and supports antialiasing, subpixel-rendering and provides HiDPI support (I had only a single machine to test HiDPI support, so your milage may vary).

There’s now also an additional “fizmo-remglk” interface, which is supposed to be used for automatic testing purposes. There are also a few more config options in the “libcellif” monospace screen interface and a few crash fixes in libfizmo.

This version was tested on Debian Linux and Mac OS 10.11.

You can get it either from github – … 8.0.tar.gz.


There is an issue with parallel builds. It only happens on a clean source directory, directly after unpacking the tarball:

tar xf fizmo-0.8.0.tar.gz cd fizmo-0.8.0 ./configure make -j4 ... pixel_interface.c:66:27: fatal error: drilbo/drilbo.h: No such file or directory

Note: This is only reproducible on the first unpack on the tarball. “make clean” or “make distclean” and then calling “./configure” again does not reproduce the issue. This results in automated builds (Gentoo build system) failing to install the package.

I added it to the Gentoo interactive-fiction overlay anyway, but disabled parallel make for the time being.

Thanks, I’ll look into it.

This is fixed in fizmo 0.8.1. The update is available from github or directly via … 8.1.tar.gz.


I’ve built fizmo 0.8.0, it works for console and ncursesw, but the SDL2 version just start a window and quit immediately, with no info in the terminal (built on linux mint 17.3). No gdb info either.


thanks for reporting this. I’ve tried to reproduce this with Linux Mint 18 – I couldn’t get Linux Mint 17.3 to install libfreetype6-dev due to “held packages” and other problems – but fizmo-sdl2 appears to start without problems.

Maybe you could try the following: When running the “./configure” command for fizmo ,add the “–enable-tracing” switch. This will add the debug symbols which should allow gdb to produce some meaningful output. This will also make fizmo dump a huge amount of information into a file named “tracelog.txt”, which might also hold a clue about the crash.

A little follow-up: In the meantime, the bug responsible for this problem has been found. A fix is available via the latest github version and it’ll be included in the next version of fizmo.

Same here on OS X El Capitan with the latest github code: I can run the console and ncursesw binaries, but sdl2 will just hang and must be force quit from Finder. No --enable-tracing on OS X, apparently: “ld: symbol(s) not found for architecture x86_64”.

Thanks for reporting this. I tried my luck with El Capitan 10.11.6 today, and at the moment I’m not able to reproduce it. For reference, this is what I did:

  1. Pull the build requirements via homebrew:
    brew install sdl2 freetype pkg-config libjpeg autoconf libsndfile automake

  2. Clone the latest version:
    git clone --recursive

  3. Configure, Build and install:
    cd fizmo
    autoreconf -fi
    ./configure --prefix=$HOME/opt/fizmo --disable-x11
    make -j4 install

  4. Run:

Maybe you can compare this to your build procedure and / or post about your setup.

When you say “No --enable-tracing”, do you mean that building with tracing enabled it doesn’t work for your OS X setup?

It seems I can build it all right, it just doesn’t produce any output when I try to run games. fizmo-console and fizmo-ncursesw work fine, but fizmo-sdl2 only gives me what looks like a hung process (an exec icon in the Dock, but no window or console output), and must be force-quit.

Following your instructions, I can successfully build with the --enable-tracing switch. Don’t know what was wrong before. I’ve never used gdb, though.

EDIT: This is on El Capitan 10.11.6 and with sdl2-2.0.5.

Before resorting to gdb we can take a look at the tracelog itself. As soon as you’re up and running with tracelog enabled fizmo dumps large amounts of trace data in a file “tracelog.txt” in the current directory. It gets really large really fast, and the game runs much, much slower with it, so maybe give it a few more seconds to start up. Once you’ve got a crash or hang, please compress the tracelog.txt and mail it to

Did you compile the sdl2 yourself or has it been installed via some package manager like Homebrew or MacPorts?

Well, that is a problem. As far as I can tell, no tracelog.txt appears anywhere. Does it crash before it gets a chance to write anything? Or is it still not properly compiled with tracing enabled?

I have installed sdl2 with Homebrew, and it seems to work fine at least when I compile ScummVM. I don’t know how useful this is, but I pasted the entire output of the build process here:

EDIT: Heh, I didn’t notice until now that the error still occurs in there (line 160):

Undefined symbols for architecture x86_64: "_turn_off_trace", referenced from: _main in fizmo-console.o "_turn_on_trace", referenced from: _main in fizmo-console.o ld: symbol(s) not found for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation)

You might want to give it a fresh github checkout and try. I had startup problems with fizmo-sdl2 on Ubuntu 16.04 x86_64 due to some language environment issues and that was fixed. I’ve been reporting bugs so that most issues/crashes are known.