Faeries of Haelstowne; Hint request

I’ve been methodically exploring the Vicarage and its surroundings. I got into the Vicar’s bedroom. In here, something is up with the base inside the wardrobe and the panel at the front of the wardrobe. PUSH BASE tells me I should opt for a more directed approach. MOVE BASE LEFT or RIGHT and PULL BASE don’t work.

Hint please?

1 Like

Ah, you’re very close! One nudge, then the answer:

Is there something up with the base, or with a part of the base?

PUSH CORNER

Ack! I’m kicking myself now, but also the author. I tried X RIGHT CORNER but synonym wasn’t recognized.

(I love the personalized “You don’t see that here” or “You can’t do that” messages in this game.)

Edit: Apparently, the corner isn’t an object at all. You cannot X CORNER either. PUSH CORNER must be a specialized command that doesn’t refer to an object. So I kept poking at the base-object.

Well, I was a beta tester so I should probably be in line for a kick as well! I know Adventuron’s parser and object-handling require a lot more manual labor than do Inform, TADS, and the other longer-standing languages, and this is a really big game to have to do that level of fine-tuning, I suspect.

I felt that, you know!

1 Like

From what I’ve read about Adventuron, it’s mostly aimed at creating games playable on oldschool machines as well as modern computers. If this is the reason that object-recognition or -creation is more hands on, then authors working with Adventuron should keep this in mind.

In this case: PUSH BASE should work. The player’s intention is clear, no?

TAKE ICEPACK
PUT ICEPACK ON CRISTOPHER’S SORE HINEY

Sorry about the kick and the “hiney”-comment. I got cranky from messing with the wardrobe so long and then finding out I missed a straightforward command.

I did kick myself too…

2 Likes

No problem! Noted that I need to fine tune to ameliorate player frustration in the wardrobe department.

1 Like

On a more positive note, I’m loving my stroll through the vicarage and its surroundings. You’ve really nailed the historical atmosphere.

2 Likes

Yeah, as Christopher will attest from looking at my transcripts, I completely bumbled my way through his game, but I still just loved it, since the writing really transports you to a lovely, lovely setting – I had a bunch of favorite characters too! I believe there’s a hint function implemented now, but if you need any others feel free to ping me.

1 Like

Adventuron is not really aimed at making games that run on old school machines. Nor really is it about making games that necessarily feel like they are running on old hardware (although that was part of the goal). It’s really about making a certain type of adventure game creation a little bit easier. To a certain extend it succeeds (lots of authors say they understand it very quickly and it has reasonable if not great multimedia features), and to a certain extent it fails (its object scoping, noun association, default world model is not as solid as Inform).

There is lots more to be done at the system level, and I apologise to ChrisM for whatever parts of the user experience have been let down by Adventuron in its current iteration. I’d be happy to see the transcripts too, or accept criticism of parser weirdness (in a separate thread).

1 Like

Gosh, no need to apologise. Anything wrong with the user experience is far more likely to be down to me not really knowing how to code and stubbornly deciding to write a large, complicated narrative game in an engine that hasn’t ever been used for that before, than to anything inherently skew-whiff in Adventuron.

Your “narrascope” got the better of you.

2 Likes

Apologies from me too – I definitely wasn’t trying to bag on Adventuron! I’ve really enjoyed a lot of the games I’ve tried, and one thing that’s helped me enjoy them more is realizing that the world modeling isn’t quite as robust for things like adjectives and generic versions of actions, so if I get a response that would make me think I’m off on the wrong track if I was playing an Inform game, I might still want to try messing around with some synonyms or alternate syntax before giving up on an idea. So hopefully having those expectations helps folks enjoy the awesome game Christopher wrote with your system!

1 Like

I can’t seem to get rid of the developer fluid in the porcelain dish after developing the negatives. I’ve tried OPEN SPOUT, EMPTY DISH, POUR OUT DEVELOPER, POUR OUT FLUID. I also went to the scullery in case I had to pour the developer in the sink (and poison the groundwater in the process). None of that worked.

You need to POUR DEVELOPER INTO an empty vessel such as the bottle, flask or bucket.

1 Like

I’m at the chemist, wanting to buy photographic paper. I have developed the film and hung it up to dry, but Salter won’t respond. Is there something I’m missing?

This is either a very easy or very hard place from which to try to unstick oneself:

If you’ve got the film properly set up and drying, you should have gotten a prompt like “now all (Arthur) needed to produce a set of finished photographs was to find a way of making prints,” and the film negatives should be described as “processed, hanging on the drying line.” Then you should be able to just go to the chemist and type ASK SALTER.

If that hasn’t happened, I can think of two possible issues: first, have you read the book that tells you about how to make prints? I think that’s just on the bench in the darkroom, but figured I’d mention it on the off chance you’ve reloaded or restarted and haven’t read it (and to be clear, I’m not sure you need to read it to be able to buy the paper, this is just a guess!) Second and more daunting, something might have gone wrong with the development process – if it seems like that’s the case, let me know and I can try to reconstruct the exact commands you need from my old transcripts, since it’s a rather fiddly piece of business!

1 Like

Gosh, I can’t remember if I got such a prompt. The film has the description you note, however. I have read the book on printing and the instructions on developing. Maybe one thing that went wrong was the actual photographs? I took one photo of the faeries dancing and the rest of them just ambiently in the bough, because I couldn’t get them to dance again. I don’t know, maybe it’s the development process, but I was following the instructions step by step? I’ll be really sad if I’ve broken it somehow, because even though I’ve used all four saves, in the befuddled nervous mess I’ve made of my journey I’ve since overwritten them all. Sorry for the trouble, but I would love to look at your transcripts if you still have them.

Uh oh, that sure seems like it should be right – I also just took a photo of the faeries dancing (after entering the hidden place in the rhododendron trees in the rockery, right?) Then I snapped the rest out on basically nothing, so I’m pretty sure that’s the only one you need. Only other thing I could think of is to ask whether you made a safelight? Not sure whether that invisibly messes up the developing process, or if it’s required to proceed. And do the HINT or STUCK commands do anything?

I’ve attached my transcript from the relevant bit – this was the beta so things might have changed, of course. It’s a long long transcript, and you’ll see me doing oh so much flailing, but I put “YYSTART HERE” where the development process starts.

transcription_The_Faeries_of_Haelstowne mr - 2.txt (1.1 MB)

1 Like