Build 6L38 of Inform released


(Graham Nelson) #1

A maintenance release, correcting about 150 bugs in 6L02 but otherwise making only minor changes, can be found here:

inform7.com/download/release/6L38/

As usual at this stage, the Mac OS X download is already present, and downloads for other platforms will follow shortly.

More excitingly: we hope that 6L38 will be the first build officially available for Android. We welcome Nathan Summers to the Inform team as our new Android porter, and I for one am very pleased that Inform is making its first steps in the world of mobile computing.

Many thanks to the very many people who helped, but a special shout-out to Liza Daly for fixing an 11th-hour, 59th-minute problem with our website.


(Jim Aikin) #2

Yay! Sort of….

In 10.8.5 on my elderly MacBook Pro, the Launcher window fails to create a new project. Nor do the “Open a sample project” links do anything.

On my second try at launching the IDE, Onyx.inform showed up in the Recent Projects area (didn’t notice if it was there the first time), and I could launch that source code from there. [Edit: Ignore the next bit.] However, It appears that Onyx requires (cough-cough) Spellcasting by Jim Aikin, without which it won’t compile. If the intention is to provide Onyx as a sample game that newcomers can try compiling and running, I’d guess Spellcasting ought to be bundled with the 6L38 release. [End of the bit to ignore.]

The Open… button in the Launcher isn’t working either. And the Open Project… command in the File menu also fails. Same deal with the New Project command in the File menu. Nada.

Possibly some user error or computer flakiness on my machine is at fault here – not trying to cast aspersions. But possibly this would be something to look into.


#3

I can’t speak to the rest of this, but Onyx does not, in its initial state, require Spellcasting. (Attached below is the entire source, if you’re curious.) So my best guess is that you’ve added that extension to an Onyx project at some point in order to test/play with it?

[rant]“Onyx”

[Here we have a little sample story based on Slavic folk tales. To try out this story, click the Go! button above. Then type TEST ME and press return to try out the actions of the story.]

The Deep Forest is a room. “You are lost in a deep forest. The trees grow so close together that you cannot see the sun or the sky, and no grass or small plants thrive on the ground.”

[Try changing the words inside the quote marks to give the room a new description.]

Baba Yaga’s Garden is west of the Deep Forest. "In this garden grow plants that eat insects and plants that eat birds. It is bordered by a bone fence, and the pavements are made of a giant’s kneecaps.

In the center of the garden is Baba Yaga’s hut, which walks on chicken legs. Currently the hut is squatting on the ground."

[You can add more plants to Baba’s garden by writing something like ‘A carnivorous plant is in Baba Yaga’s Garden.’]

Baba Yaga’s Hut is inside from Baba Yaga’s Garden. “From in here, there is no evidence of the hut’s chicken nature except that the wallpaper is made of yellow-white feathers.”

A gigantic mortar is in Baba Yaga’s Hut. “One corner of the hut is taken up by the gigantic mortar, big enough to stand in.” It is an enterable vehicle. The description of the gigantic mortar is “Baba Yaga flies around inside it whenever she is in too much of a hurry to make her hut walk.”

Baba Yaga is a woman in Baba Yaga’s Hut. “Baba Yaga sits at her work table, sewing symbols into a magic towel.” The description of Baba Yaga is “Her teeth are made of iron and her eyes can see in the dark. Though she is old, her fingers are nimble, and she has forgotten nothing that she has ever seen.”

Instead of entering the mortar in the presence of Baba Yaga:
say “‘Oh, I wouldn’t do that, Foolish Ivan,’ says Baba Yaga. ‘Where it would take you, you’re not ready to go.’”

Baba Yaga is carrying a magic towel. The description of the magic towel is “To judge by the spell worked into its fringes, this is a towel that can turn into a bridge across any river or chasm.”

The description of the player is “Some people call you Ivan the Fool, but you pay no attention to their rudeness.”

The player is carrying a magic ball. The description of the magic ball is “Whenever you drop this, it rolls in the way you should go.”

After dropping the ball:
if an unvisited room (called target location) is adjacent to the location:
let way be the best route from the location to the target location;
say “It rolls suggestively towards [the way]. You pick it up again before it can get too far ahead of you.”;
else:
say “The ball rolls around uncertainly and then comes back to sit at your feet with such an apologetic air that you have to pick it back up.”;
now the player carries the ball.

Test me with “look / take inventory / examine the ball / drop the ball / west / examine me / in / look at baba / examine towel / drop ball / look at mortar / get in mortar”.[/rant]


(Jim Aikin) #4

Yes, that would appear to be the case. Sorry for the confusion on that point. However, what that fact suggests is that the version of Onyx that I launched was not bundled with this release, but rather had been lying on my hard drive since May.

In any event, Disenchantment Bay doesn’t launch from the Launcher, nor does the correct version of Onyx, nor does anything else.


(Jim Aikin) #5

Also, whilst I’m busy nitpicking (although actually, I don’t think pointing out the fact that I can’t create a new project qualifies as nitpicking), the “Upgrading?” text, which you can get to from the Launcher, says this: “…for the full story, see the ebook “Changes to Inform”, which you can access from the Launcher.” But as far as I can see, unless my ancient eyes are failing me, there is no such ebook linked to in the Launcher window.


#6

inform7.com/mantis/ is still the best way of reporting actual bugs.


(Jim Aikin) #7

Edit: I’ve filed a report. Apparently at least one user of OS 10.9.4 is having the same problem. [End of edit.]

If I’m the only one having this particular problem, then putting it on Mantis would be pointless, because it’s a troubleshooting issue. Conversely, if it’s a problem that others are encountering too, then discussing it here is surely appropriate as a way of supporting the community.

What I don’t know, because no one else has yet chimed in in this thread, is whether other users of 10.8.5 are having the same issue. Once we have more information about that, filing a bug report may become the next step.

I also don’t know whether it was tested on 10.8.5 prior to release, or whether the fact that I have several older versions of Inform still living on that computer may be an issue. They’re all in a folder called “Inform Older Releases,” so my naive assumption is that the system wouldn’t see them. But a computer is a mysterious place.


#8

No problems so far with I7 6L38 on OSX 10.9.4.


(Hanon Ondricek) #9

Is anyone not getting the link arrows in error messages? The ones you normally click to jump to the error in the source it’s referencing?


#10

Hi all.

I’m new in this forum. Thank you to all the staff for your work.

I installed the last release of Inform 7 (6L38 ) on my MAC equipped with Mavericks OSX (10.9.4) but, unfortunately, the menu item “Install Extensions…” doesn’t work. No browsing windows appears.

Furthermore, the old installed extension are no more available.

Thank you!


#11

I’m REALLY happy I kept the old version. 6L38 is practically unusable on a Mac.
Can’t open existing adventure files that worked in last release. And… that’s just the beginning.
There are a number of other issues, but in total they add up to 6L38 being more trouble than it’s worth from my perspective.


(Hanon Ondricek) #12

My extensions were wiped also, but I was able to reinstall the library extensions from the button.


(Jim Aikin) #13

I was able to open an old .inform file in the IDE by double-clicking the file itself. I haven’t tried saving it under a new name and then erasing the content so as to start a new game. That may be a usable work-around.


(Andrew Plotkin) #14

Yes, those seem to have vanished entirely. Bug 1407.


(Andrew Plotkin) #15

Many of the file-opening options in the Mac app are broken due to “failed entitlements check”. This appears to be a screwup in the sandboxing process needed to get an app into the Mac App Store. The IDE maintainer will have to fix it, but at least all the problems we’re seeing are symptoms of a single bug.

The “Recent items” menu option (or link in the opening dialog) also works.


#16

Jim – I’m having the exact same problem on Mac OS X 10.9.4 – Looks like this is definitely a bug with the current build.


#17

I hope that I didn’t offend anyone by asking about the testing process.
I was a Software Test Lead for a number of years and know it’s a lot of work to put out a release.
The question was more one of professional curiosity.


(Andrew Plotkin) #18

Didn’t see you ask.

I know the core I7 compiler has a large test suite, although it hasn’t been posted.

The I6 compiler doesn’t have a test system, but it hasn’t changed much since I7 began, and I try to write tests for any changes that we do make.

For the IDEs, it’s up to the individual maintainers.


#19

It’s still possible to get the older releases at inform7.com/download/release/6L02/


#20

If the Mac IDE developer would like some assistance in testing the Mac IDE, I’d be happy to help.
Just send me a message.