Anssi's IFComp 2020 Reviews

A lot of the puzzles (including the color one) have you give a lot of examples and after you’ve done enough, they give you further hints. So ‘easel’ is only hinted after you say enough color names.


Oh ok, thanks for the advice! I thought I had already said nine or ten colors and I didn’t see it was going anywhere. With this knowledge, I will try it out again, together with some other puzzles. :+1:


I’m a native English speaker, and I’m not sure of its meaning, either. Here’s my best guess:

Rope ties things together. So maybe the “rope of chalk” refers to how the sidewalk chalk tournament, despite all of the point of view changes, ties the various parts of the story together. It is the common feature to all of them, after all. Again, just a guess.



You have been sent by the Federal Bureau of Druids back in time to the autumnal equinox to stop the Order of the Fiery Doom from burning down all of the Earth. Fortunately, the game takes itself less seriously than what the introduction leads us to think.The goal of the game is to stop the said Order, but the setting and the puzzles are frequently humorous - you start for example in a room where going north takes you a (bright) dungeon, while going south takes you to the laundry room. In the course of the game, you obtain a key to unlock a door by making a man fall down from a ladder and die , you pick milkweed from a meadow after making a cow drink a flask of whisky, after which you can push it out of the way and make it fall down to the grass . Not all puzzles are wacky, though - there is a good balance between “serious” and lighthearted puzzles in the game. A central device in the game is allowing the player to visit the same locations during different seasons, and many of the puzzles are based on this idea. The game was of a suitable length, as it took just about a couple of hours to finish. The language used was hilarious at times, even deliberately awkward in places. It was obvious that the authors of this piece have been enthusiastic about the theme, at the same time not taking the whole thing too seriously, and adding great humor throughout. I didn’t encounter any bugs. There were a couple of guess-the-verb moments (for example “dig in pot” to find something hidden in a flower pot) but otherwise everything worked well. 8



This cyberpunk story about a heist can be played either in the normal interpreter or as an online version with more bells and whistles. I started out by playing the text-only version but switched to the online version because got stuck early on, and as the instructions of the game mentioned that there is a list of all needed verbs available in the online version. That helped, and I was able to proceed. The protagonist is someone who has committed a crime recently and, at the start of the game, has to flee a police squad that is coming to arrest him from his apartment. He goes to his girlfriend’s place to hide. He doesn’t stay there for long, though. Almost immediately, his girlfriend starts talking to him about a company that she has noticed something fishy about in the course of her journalistic investigations, and the protagonist sets off to find out more about this company. This struck me as somewhat implausible: if the authorities are on his tracks, wanting him for a previous offense, and he has to flee for his life at the start of the game, isn’t it dangerous to start another risky undertaking (infiltrating into a big company) while escaping from the said authorities, just to help your girlfriend in some project?

A gimmick in this game is the ability of the protagonist (and other people) to enter cyberspace (using specific hub devices designed for the purpose). In the plot, this is needed to gather information about the company to be infiltrated in by the protagonist. The environments in cyberspace are often drastically different from the neonlights and skyscrapers of the city: the first scene is medieval, with taverns and knights, and the second scene is idyllic (rural) Oriental. This was another slight problem I found in the game: the setting of the story, as well as the interface of the online version, is cyberpunk, modern, streamlined, the included multimedia including an image of the city in the background and techno-style music soundtrack - and then suddenly we jump into wholly different settings, where the puzzles involve bringing beer to a knight guarding a bridge, or playing a flute to trance a snake and to capture it in a basket . Even if the soundtrack music changed accordingly when these scenes were being played, the music was still played with synthesizer, and the same modern interface as when playing the scenes in the city was present in the medieval and rural Oriental scenes. It might have been more coherent if the whole game had taken place in the city, with cyberpunk gimmicks and ideas like the hoverbike (which I thought was a very cool feature at the start of the story - “another dive in the neon sea”) popping up more frequently.

The story is good, nevertheless, and the puzzles as well. Due to there being no walkthrough, I got stuck in the second cyberspace scene (only finding two of the three coins needed to open the box in the pavillion and couldn’t play to the end. It’s a good game and an engaging plot with some fine gimmicks. The couple of issues I had with the plot were not too big and didn’t hinder me from enjoying the game. 8

1 Like

I have a transcript here in case you’d like its assistance to finish it: Stian's IFComp 2020 reviews


my game is no longer in the competition @Anssi

@silicon14 Oh, what happened? (It is still in the list though…)

@Stian Thanks, I will take a look!

They said the post asking for play testers counted as a public release

Oof. I’m so sorry that happened.

1 Like

It’s okay, they told me it happpens every year to at least someone and I’m plaining on releaseing my game on ounce I finish improving it


Yeah. For future reference you can post asking for beta testers, but send them the link privately (either PM or to an email address) so you can keep track of who has your game before the Comp.

1 Like


A short implementation of the well-known logic puzzle where you have to transport three things across the river. It was well-implemented but didn’t present anything new to those people who have already solved a similar puzzle in some other context. The only “original” thing here was the brief initial sub-puzzle of catching the sheep first, and there was a list of amusing things to try at the end. So, while everything worked, it was very brief, and familiar from before, and didn’t offer anything ground-breaking. 4


Another short game, presenting an alternative view to the background story of how Newton contributed to science. The idea is nice, and the story has bits of humour thrown in. There are several locations to visit, but basically there is only one major puzzle in the game. Well-implemented, and a neat original idea, even if very short. 6

1 Like


A fun, solidly implemented story with good puzzles. You’re a village idiot, and having been banned from the village you want to try out something else, ultimately ending up as a knight - well a sorts of one, anyway. The game has good humour throughout, for example in the ways the main character’s stupidity is regularly referred to. Even ‘x me’ has a hilarious response. The puzzles are mostly logical, carrying also a good degree of originality - a special gimmick in several puzzles is to make use of animal sounds . I would criticize only one of the puzzles - constructing a bird’s nest . This was maybe made more complex than needed.The steps needed to complete that puzzle were at a couple of points not very well clued (for example getting mud from the river bank, when mud, as a noun, was never referred to at the location, only the adjective “muddy”, and even that one only if you had the wits to specifically examine the river bank, and not merely the river. Other things not directly obvious were putting the leather ball in the nest and needing to put the nest in the forge. There are three (human) characters you encounter, the farmer, his wife and his daughter, and only two of them give you errands when you have become a knight. Maybe instead of the slightly drawn-out nest puzzle, which could have been a bit shorter, there could have been a third quest given by the wife? In any case, the game, as it stands now, was of a suitable length. Even one of the puzzles towards the end was optional - you could have the farmer complete it if you wanted him to - which was a nice option if you felt you had already played for the full time. In any case, this is a strong game with some hilarious moments, The hint system is good, and I liked the indirect underlying message that you can be a knight even if you just manage to complete some mundane everyday tasks. 9


Thanks for playing my game, and for your thoughtful review and kind words. Your constructive feedback is helpful as well. There were others who ran into similar problems with the points you brought up. I will be taking all of the IFCOMP 2020 feedback and doing another release afterwards that will incorporate what I have learned from all of the IFCOMP players as best I can, so this sort of feedback is very helpful. I appreciate you taking the time and effort to provide it for me.


I’ve given some thought to this, and while I can’t be sure this is exactly what the author was thinking, it probably isn’t wrong either.

A “rope of chalk” suggests a sort of continuous line drawing, an artistic challenge sometimes assigned to beginning art students. Up close these drawings can look like a tangled mess, but from a distance, in the hands of an experienced artist, the result can be quite dramatic. The continuous path also reflects the twisting (but unbranching) map design in each of the four acts (but conspicuously not in the epilogue). And it could symbolize the twisting path of the story itself, which eventually resolves into a unified tale.

Finally, a chalk drawing has a fundamentally ephemeral quality, much like a memory.


@lkcampbell Nice, looking forward to the post-comp release :slight_smile: Of course the game was already great fun to play as it stands presently. The best luck in the comp!

1 Like


The interface is top-notch, with a custom engine and interpreter, images and sounds included. The background music makes for a pleasant, relaxing playing experience, and you feel almost like you are actually wandering around in the forest that the story depicts. When you reach a new location, there is usually an image connected with it. The colored fonts also add to the atmosphere. All this contributes to it just being fun roaming around in the game map without even trying anything specific for a while. There is also an excellent walkthrough/help file included, explaining typical interactive fiction commands and gameplay in general in a thorough way. It is obvious that the author/s made a great effort to make this game really polished and impressive. And they have succeeded pretty well. The story is also very good: you and your companion are getting late for a wedding and must find your way through a forest that it sprinkled with characters from well-known traditional fairy-tales. These various characters present problems to the protagonists that they have to solve before they can proceed.

The only issues I would have with this game are: 1) the forest is somewhat complicated to navigate, with many almost identical descriptions for locations. Some kind of map would have been great; now there is a lot of walking around, and it becomes exhausting after a while; 2) Even if there is a walkthrough provided, it would have been nice with some kind of hints as to what to do in the various situations. 3) If you don’t type anything for a while, there is an extra prompt popping up after a while, pushing the text up and away from the screen.

Otherwise, this is an excellent effort and does a good job of creating an immersive atmosphere for the story. 8 1/2.



So many problems right at the start. “Your arch enemy, having stolen your girlfriend, throws you down through a hole in the ceiling.” How does he throw me down a hole in the ceiling? I can take a torch, but it is unlit. I can’t light it, because it says “You don’t have a torch.” even if I just took it. I put it back. I don’t have any inventory, but “light torch” now works (“You light the torch with a match.”) The first location description instructs: “You can go up, east, north, south and west.” but the next sentence is “The hub of King Haputet’s tomb and the only way in or out.” (sic). Somehow I don’t feel like going on, because of the problems with the language, the conflicting descriptions and the obvious problems in the implementation. Maybe I’m being unnecessarily cruel or impatient or nitpicky, but this is the first game in this year’s comp that makes me not want to go on after the first initial moves. 2