Anssi's IFComp 2020 Reviews

I will be posting short reviews of some games. There will be regular spoilers.

ACADEMIC PURSUITS (AS OPPOSED TO REGULAR PURSUITS)

spoilers
A game where you have to unpack some cardboard boxes after moving into a new office, and place the items into this new office.It was no big problem finding a place for each item (some I had to discard in the bin, but anyway). I played through once so I am not sure if there are multiple endings, and whether placing the unpacked items differently in the room would alter the final outcome. There is a background story that unravels little by little, and placing the items in various places in the room unveils alternative viewpoints and attitudes of the main character with regard to his supervisor whom he’ll meet the next day. Coding was competent and I didn’t encounter any problems. One curiosity I noticed was that the assistant that guided the main character to the office at the beginning of the game was referred to as “they”, gender-neutrally. I couldn’t figure out the reason for this. As the main puzzle, placing the items, didn’t offer any real challenge, I think the main point of the game was the background story that unraveled in the course of play. It was a nice twist and was hinted at already in the blurb of the game. Summary: a nice diversion, rather short, not that groundbreaking. 6 or 7

ALONE

mild spoilers
A strong opening with a spooky atmosphere, because it is not immediately clear what is going on. However, rather soon it turns to a traditional “find-key/card-to-open-door” etc kind of chain of puzzles, and the atmosphere is pushed somewhat to the background -even if there are newspaper articles/ journals etc to illuminate the underlying story. I didn’t finish this in the allotted two hours (I proceeded as far as the lab area), but it held my interest and was competently implemented. 8

ASCENSION OF LIMBS

mild spoilers
A strategy kind of game where you have to run your antique store in successful way. By starting with a limited set of verbs (commands) and items, you gradually gain more of them, at the same time obtaining more means of running the store. At the same time, the history of the store and how you obtained it are explained. I played through once, until I had run out of financial means (the game stops when you run out of money, and a happy ending, if I remember correctly from the instructions, is when you have managed to sell a certain number of antique items. This game has undoubtedly a high replay value, but because I am not a fan of this particular type of games, I played once only. No big problems, smooth to play. 7

THE BRUTAL MURDER OF JENNY LEE

mild spoilers
You’re investigating a murder that happened 17 years ago, through some kind of virtual computer program that takes you to the time and location. There were some implementation problems (I can open a cabinet directly, even if a code entered into a keypad is supposed to open it; however, the items inside the cabinet become available only after the code has been entered). Some nouns and obvious verbs are not recognized (at one point, I am supposed to look under a table, but the parser doesn’t understand me). Some disambiguation problems (“Do you mean the pen or the pen?”). At times, the player is pulled out of the virtual reality of the crime scene and spends some time in limbo (why the limbo is several turns long and requires going in certain directions, is not clear), then transferring to a new location. The story doesn’t allow the player to make guesses as to who did it: the involved characters are mentioned briefly, maybe even once only, and then soon afterwards the outcome is presented. The player is not drawn into the story in a great degree. A good effort, though, and there is a surprise twist at the end. 5

4 Likes

You could use the details tag to hide the spoilery reviews until somebody clicks on the arrow to open them. Might be helpful! It looks like this:

Spoilers.

And you do it like this:

[details]
Spoilers.
[/details]
1 Like

BYOD

A short game about your first day at a new job. Mainly you have to perform one simple task, and then the game ends, commenting, though, that maybe you left something undone. You go back and perform that other task, (a very mild spoiler:)

much along the same lines as the first one.

Very brief, but solidly enough implemented. 4

2 Likes

Thanks Victor! But when I try it in my second post (above), it doesn’t seem to work…

I think it’s because of the . sign behind the second tag!

1 Like

Yes. your [details][/details] tags need to be on separate lines all by themselves with no other characters.

You can also use [spoiler]Spoiler text.[/spoiler] to blur inline, or also use those tags on separate lines to blur multiple paragraphs. It looks like this:

You don't want to know the [spoiler]secret[/spoiler]!
You don’t want to know the secret!

Or…

This paragraph isn't a spoiler.
[spoiler]
But this one is.

And so is this one.
[/spoiler]

This paragraph isn’t a spoiler.

But this one is.

And so is this one.

You can also put a message by the Details clicky arrow:

[details="Click here to reveal text"]
This text will be hidden
[/details]
Click here to reveal text

This text will be hidden

2 Likes

OK, I got it now. Thank you to both of you.

1 Like

CAPTIVITY

Now this was great fun. A good old-fashioned puzzle fest about escaping a castle where you are being held captive. After you’ve escaped the tower chamber you’re locked in, you can wander around in the castle, and the funny thing is that all the characters just let you do it. The puzzles are good and mostly fair (I would have an issue with one puzzle in particular, though:

You are supposed to find something in a boot, and you are able to search and examine the boot when you are in the room, but you will only find the item hidden in it after you have examined the boot by looking down at it from the room above, and seen the item in the boot from that upstairs location. It would have been better if the item could have been accessible immediately and if the upstairs option had been just an extra hint for the puzzle.

All in all, a fun, well-implemented game, with a couple of small rough spots but nothing major. Definitely a favourite so far. 9

DEELZEBUB

The premise is fun - you’re a member in a sanctuary dedicated to fighting an impending demon invasion (a threat according to the leader of the sanctuary). One day, the leader invites you to his office and asks you, rather absurdly, to summon a demon. The one you will be able to summon is not quite what you would expect, though. The early part of the game is more successful than the latter part. You can wander around with the creature you summoned, and do various things. After going around for a while, however, it is not very clear what you should do next to bring the plot forward, and there is a side plot (one character stalking another one) that doesn’t lead much anywhere. I had to resort to the walkthrough to see what I was supposed to do next. After a while, the funny being that I summoned in the beginning becomes irrelevant and the plot moves to something else. This made the game feel a bit incoherent. I was not able to finish it in two hours, but when the time was up, I didn’t feel I wanted to go on any further, either. Summary: very good start, lost some of its appeal later because of the unnecessary side plot and discarding the funny element that was present the beginning. Well-implemented with helpful hints, though. 6

DESOLATION

This game claims to be a sequel to “Two braids girl” (but I couldn’t find a game of that name, and the author also just mentions “which I didn’t write myself”, not mentioning who might have written it.). After playing this for a while, however, this actually turns out to be, for some reason, a rip-off of

Andrew Plotkin’s Shade. Everything is similar here - exploring your apartment, everything turning to sand, the radio playing tunes in the background.

I don’t know exactly what the point is. Moreover, after a certain point there seems to be no way to proceed, and there are no hints or walkthrough. Strange, and pointless.
2

Hi, thanks for taking the time to write a review of my game. That isn’t the end of the game, however, and I just released an update the improved the game in quite a few small ways, so I would really appreciate it if you gave the game another run. Also, if you let me know exactly where you got stuck in the Shade homage/dream sequence, I would be happy to help.

1 Like

Hello, and thanks for responding to my review. Yes, looking at another review of your game, before reading your reply to me, I already realized that there is indeed more to the game, and that I have missed a significant portion of it by getting stuck. So, I might have another look. To further explain my reasons for the low score and giving up on my first playthrough:

in the apartment, going in a direction doesn’t give any response at all (= Not even “You can’t go that way”, except when trying to go east, it still mentions “You don’t want to go back to the mansion…” (or something to that effect), anyway, the same response as the ‘east’ command yields when in the desert.

You can interact with the apartment door, even if it is not mentioned in the room description, but the walls, ceiling and floor are not implemented. They would be nice to have there as it is a confined space and the player wants to try out various things.

‘Turn on sink’ felt a bit unnatural; ‘use sink’ or ‘turn on tap’ would feel better.

Mimicking Shade felt a bit pointless, in the sense that it wasn’t for example a parody, or some other kind of different take to the original. Also, the lacking implementation felt it didn’t do any great honor to the original.

All this, together with the fact that the game seemed to halt after I had reached a certain point, until which point I had made reasonably smooth progress, made me feel that there might be nothing more to it, and for that reason I gave it the low score.

I progressed as far as having the game mention me starting to have serious doubts about my apartment (again, I don’t remember the exact wording), and another mention that I probably must be dreaming. I tried to wake up (and sleep) but they didn’t work. I had managed to turn almost all things to sand, but the stereo, if I remember right, was still there, and I didn’t manage to open the blinds. I was carrying the peanut butter jar. I would be grateful if you could give me a nudge in the right direction from this point.

(Mind you, I downloaded the games folder from the Comp website and am playing all the games as they were released on Oct 1, so I won’t be trying out updated versions of any games.)

Thanks, and good luck with the game :-)!
Anssi

1 Like

Small nudges in case they’re helpful (first one least spoiler-y, the rest pretty explicit):

  • The notepad on your desk will give you some prompts on what to do next (they change over time)

  • It sounds like you might still need to take out the stereo stand?

  • You also need to open the blinds to end the sequence, but you can’t do that until everything else is done.

2 Likes

Thank you Mike! I’ll use these as needed.

2 Likes

DESOLATION (revisited)

As I learned, after playing this game for the first time, that I had missed a portion of it on my first playthrough, and as I had not yet used the two allotted hours of play to the full, I gave it another try. It is a nice homage to traditional, old-school text adventures and includes some references to earlier works of IF. I had earlier got stuck in the apartment scene of the game, and as it felt like a direct copy of an earlier, well-known work of IF with no twist or take of its own to contrast with that original game, I initially wondered what the point was. Even now, having been able to proceed to the end of the game, that portion feels as if it would have benefited of the author including some kind of take of their own to it, instead of that scene now feeling like a straight-forward copy.

The plot of the story (finding your way through a desert to escape your captivator) is interesting enough and keeps the player involved. The puzzles are entertaining, and difficult enough, even if mostly of the traditional type. I would comment on two specific puzzles:

When opening the bag and taking the hoodie, the main character automatically uses it as a bandage for the bleeding wound; however, it could have been left to the player to figure out this use of the hoodie.

I liked the final puzzle where you had to take the rope with you that you used for climbing; leaving it in place enables your chaser to catch you in the end. This was a smart design feature.

There are some implementation issues - even if you’re supposed to be hungry, tired, thirsty etc, ‘x me’ yields the basic “As good-looking as ever”; you can take objects that are not meant to be taken (for example the shower, the palm tree and the cacti), and there are spelling errors at a couple of places. No hints or walkthrough are provided, either. Even with its shortcomings, it is fun enough to play but offers hardly anything new to the well-trodden genre. 5

1 Like

DR EGO AND THE EGG OF MAN-TOOMBA

A nice jungle adventure in the spirit of Indiana Jones - as the author acknowledges in the about section - which took me about an hour to finish. The narrative is in the first person, and the descriptions are short. There are many small nice touches - in the jungle, you can get lost if you go in a direction not mentioned in the location description, and you even get a point for figuring out how to find your way back. A hen in the tribal village escapes you when you try to catch it and disappears into the jungle, to return after a few moves. The location descriptions change when you have visited adjacent locations, for example: “An unexplored path leads west” which becomes later “A path leading to a clearing is to the west.”, etc. There is a good hint system (which I had to use twice). The author knows, or gives the appearance of being familiar with, the geography and the environment of the setting of the story (Papua New Guinea). The only thing that caught my attention was the mention of the guide using an oar to steer the canoe; a paddle would maybe have seemed more natural, but that’s nitpicking. The puzzles were fair and there were no bugs that I could find. The parser is helpful and understands readily what the player intends. Inventory items are automatically placed in a bag when the main character is carrying too much in his hands. When the main character was carrying something heavy, there was a regular reminder of it (every turn, or almost every turn), but it didn’t have any consequences I could find, so those messages seemed redundant. All in all, I did enjoy this quite a bit. 8

4 Likes

THE ELEUSINIAN MISERIES

In contrast to the previous game I reviewed above, the narrative style in this game is extremely wordy, a kind of high-brow English especially in the style of P.G. Wodehouse (of the Jeeves and Wooster fame). This style fits the setting, even if the game deals with an initiate to a secret fellowship in ancient Greece, and for having been given the chance to participate in such initiation rituals, he has to act as a kind of servant to his acquaintance who agreed to take him there, and in the beginning of the game he has to carry out some household tasks before the actual rituals begin. The language is hilarious, and for example the first-time ‘x me’ response induced a LOL moment. The location and object descriptions may be rather long, but fortunately examining them repeatedly yields shorter responses. In the beginning, the puzzles are on the easier side, in spite of the general wordiness of the game, and they get a bit more difficult as the game progresses. Sometimes the puzzles are even too easy, for example

one of the rituals that the initiate has to go through can be solved ideally just by waiting.

One puzzle involving the rituals was a bit unclear:

In the ritual, you were supposed to pray to the gods, but this was mentioned only once, and if you missed that bit, examined something else for a while and then tried to ask an NPC what the present ritual was about again, there would be no helpful response. Also the ritual itself was somewhat inadequately clued: the puzzle with this ritual was that you would be in danger of falling asleep while concentrating to pray. However, praying repeatedly just yielded the response that your eyes were almost closing, but you actually never fell asleep. The game didn’t proceed from there, however; so, it wasn’t actually enough that you didn’t fall asleep, you also had to be wide awake. This was not adequately explained, and hints were needed to proceed.

Later on in the game the puzzles get a bit harder, and fortunately the hint system is available throughout. However, in a couple of cases the hints jump from gentle nudges to the outright solution, and there is no in-between (before the outright solution was spelled out, there was a warning about it, however, so there was no big harm). A couple of cases involved guessing the verb, might have been also just me though. After the polished language of the beginning, there are also some spelling errors here and there in the middle and towards the end. These are forgivable, though, as the language used in this game is very high-standard in general. and even something like “smörgåsbord” is spelled properly with all the dots and circles. One aspect of the humor of the game indeed is that even if it is set in ancient Greece, various terms originating in more modern times are used.

I couldn’t finish this in two hours (the wordiness of the descriptions takes its toll, especially with a non-native speaker). Based on what I was able to play, it was a hilarious, fun experience, and definitely worth checking out for the language used. The slight unevenness of the puzzles (some easy, some guess-the-verb or otherwise a bit on the unclear side) didn’t distract too much. 8 1/2

(I played to the end after the two-hour mark, and the final puzzle felt

a bit drawn-out, and I am not sure if all female players appreciate its subject matter (I am a male myself, but it just crossed my mind), even if it is relatively innocent. Anyway, it feels like the ending - the trip home and what happened afterwards - is not as strong as the other parts of the game. The game could have very well ended when the main characters exit the gates of the location where the ritual took place. There are some long passages of text after that, and one grows a bit weary of the wordy style by that point.

2 Likes

Hi Anssi – thanks so much for the review! Glad you enjoyed it, and thanks for flagging some stuff I should smooth out in an update.

That response to a premature PRAY command in the ritual gave me some trouble to write, so very helpful to hear that it still needs some work. And you’re completely right that unlike the other ritual steps, on the final one there’s no easy reminder if the player isn’t quite sure what they should be doing – thanks for catching that. On the silent part of the ritual, the idea there is that the player needs to stop sneezing, so while it’s probably fairly easy there should be a little work involved… the ritual puzzles are actually drawn fairly directly from what we know was involved in the actual Eleusinian Mysteries, and that was probably the least inherently interesting of the lot.

Thanks again for such in-depth feedback!

2 Likes

Thanks, Mike, for the comments! It’s a strong game, and it’s also interesting to hear you have taken the ideas for the ritual puzzles from what is actually known about the real rituals in the historical context. Best luck in the comp! :+1:

3 Likes

ELSEGAR I: ARRIVAL

Oh-oh. A typo on the first line (“hitns”). Well, let’s keep an open mind and begin :-).

Ok, there is no introduction, unless I type “h”. The introduction is basically identical to the blurb of the game, amounting to that I ended up in a strange new world after examining a strange object, and I have to find my way back.

I am lying on a bed in a cabin. There is a hole in the ceiling. ‘x hole’ yields “It probably got there when you fell through the roof.” - Just probably?

Finding a way to open the door of the cabin gives me 11 points for some reason, even if the solution to that puzzle was rather basic. But thanks! Why not live a little?

I am supposed to be in a strange new world, but there is a toilet in the cabin that has “a U-shaped lid like the ones found in public restrooms”. (and yes, I can use it.) There is also a radio that spews music, commercials, etc.

“Huge mountains surround you from your left and to your right.” I am not sure if that’s entirely correct, but what the heck…

But this game is not to be sneered at. It is very obviously made with honest intentions and the author might not be a native English speaker. This might also be their first game? After some exploration, your main goal is revealed: you have to find and defeat a monster that plagues a village. As a reward you are promised a gold coin, and with that coin you could then buy a train ticket and find your way back to your own world - or at least to some other place hopefully closer to home. I’m totally in.

In the midgame, there are some things that are not immediately obvious. There is even a hint system implemented, but sometimes the hints are rather unhelpful. For example : How do I open the labyrinth door? - Find the key. or: How do I get out of the labyrinth? - You’re on your own. Something more tangible would definitely be in place to help the player here. But thanks anyway for thinking about providing hints :slight_smile:

Yes, there is a labyrinth - “of twisty little passages, all alike”. And no helpful twist or take to it. So I mapped it. This halted gameplay considerably, and progress was slow as compared to the other portions of the game. That’s why it is considered a good idea to implement some kind of helpful feature to assist the player to navigate in a maze, in some other way than purely by experiment. There could be a wind, or smell, or sound of some kind that the player can use as a means of navigation, or anything to that extent. For those interested, here is how I found the monster once inside the labyrinth:

Once inside the labyrinth, go N three times. Then W, S, W, S, S, W, S.

When I encountered the monster, the blurb of the game already had instructed me what to do. So, it was pretty straightforward. I was able to finish the game in the allotted time.

Even if things were rather basic, everything worked well enough and there were no real bugs (save for one place near the village where the sign showed wrong what is to the north and to the south). There were, however, some under-implemented things - often you could not examine things found in the location, etc. I liked certain random responses such as when examining the sky through hole in the ceiling: “A bright cloudless blue. You smile at it.” or flushing the toilet: “FLUSH. Your business is appreciated.” and various other ones. I liked the humor also in the other places throughout the game.

I appreciate the author making this game and it was very obviously inspired by some early works of IF (the author mentions this in the credits). I had fun playing it and it would be nice to see the sequel. Thanks! The final score is affected by the general level of implementation, language, typos and the helpfulness of the hint system. 5

Thank you for your review @Anssi (Also what version are you playing because I fixed some grammar issues in release 24 and if you have other issues feel free to message me for improvements in the next release and when I start development on the sequel)

1 Like