Stian's IFComp 2020 reviews

Thanks for the transcript and the kind review - glad you enjoyed the game!

1 Like

By Morgan Elrod-Erickson, Skyler Grandel, and Jan Kim

This is a game where I found myself resorting to hints. Not because the puzzles are particularly difficult, but because the parser was frustrating, to the point where it was not fun any more, and I just wanted to finish it within the two hour limit. In addition to guess-the-verb-issues on every corner, most of the progress is being done with “ask/tell person about something”, which in the end resulting in me adopting a brute-force approach, asking and telling everyone about everything in turn. On top of that, I also ran into several cases of runtime errors – nothing game breaking, but certainly adding to the frustration.

I would like to point out, however, that I loved the premise, the characters, and the writing of Deelzebub, and I sincerely wish I had played a more polished version of it.

Since QTads is not very accommodating with transcripts, I’m afraid I wasn’t able to supply more detailed comments for the authors.

Academic Pursuits (As Opposed To Regular Pursuits)
An Interactive Fiction by Ruqiyah

Puzzleless and for the most part smoothly implemented, Academic Pursuits uses the parser format to tell a story in a clever way. While not essentially humoristic, the gradual discovery of new information – conveyed by the thoughts and feelings of the protagonist in the process of unpacking – has twists and turns that made me smile. It’s all well written and I really appreciated this way of storytelling.

Comment for the author (contains spoiler, sort of)
  • The parser was confused by certain ways of referring to “book” and “shelf”.

>x bookmark
A flimsy old paper bookmark. Wasn’t this marking a page in a book?

>x book
A chunky, fancy-looking hardcover book titled Solving the Mysteries of the Sangsue Town Murders. A square is cut out of the back.

>put boomark in book
You glance around the office, but can’t see any such thing.

>put bookmark in hardcover
You flip through the hardcover book until you find the marked page, and slot the bookmark in.

>put souvenir on shelf
(the bookshelf)
There might be space for the souvenir on the narrow upper shelf of the bookshelf.

The souvenir is too tall to ever fit on the narrow shelf.

>put it on bookshelf
There might be space for the souvenir on the narrow upper shelf of the bookshelf.

The souvenir is too tall to ever fit on the narrow shelf.

transcript.txt (40.6 KB)

1 Like

Vain Empires
An interactive memoir by Thomas Mack and Xavid

“I’m from Hell, and I’m here to help.” … and Vain Empires is off to a very good start.

The premise for this game is a quite unique take on demonic intervention, and as a consequence the method of interaction with the world here is both interestingly different and somewhat tricky to get used to. Having finally accomplished the first part (standing at 11 out of a possible 75 points) in exactly two hours, I feel that the hour-and-a-half estimate in the blurb is overly ambitious. There is nothing wrong with the puzzles though, quite the opposite: They are clever and challenging but so far also entirely reasonable. What makes them particularly challenging is that they often are timed, or rather turn dependent; starting off a chain of events, success depends upon performing certain actions at specific turns during those events. This leads to a lot of trial and error, but also to a great sense of accomplishment in the end.

Sporting a suitably unique backstory, the protagonist has a lot to say about itself in the beginning. This felt a bit too verbose, that it was overemphasising its difference to humans in a way that was annoyingly quasi-philosophic and devoid of humour. Although that may just be the way demons are… After a while it turns mostly silent, however, and what we are left with are very much textbook room descriptions; unoriginal, but solidly implemented. In fact, the whole implementation is impressive throughout the first part. I’m definitely looking forward to finish Vain Empires later on!

Comments for the authors (contain spoilers
  • The first sentence “It’s a mistake to anthropomorphize humans” is not particularly logical, since “anthro” means “human”.
  • The dealer is described but not implemented:

>x cards
Cards shuffle across the felt as the onlookers rap on the tabletop, make inscrutable gestures to the dealer, and grimly flick chips into a small pile in the center.

The fine details of the game are alien to me. The fine details of human nature are not, though; and judging from its expression, I’d say that the gambler has quite a lousy hand.

The gambler cautiously throws another batch of chips into the pot.

x dealer
I don’t see any dealer here.

incomplete transcript.txt (269.4 KB)


The Impossible Bottle
An interactive fiction by Linus Åkesson

The turn finally came to play The Impossible Bottle, another game I have really been looking forward to. Åkesson is the creator of the Dialog authoring system and his three games seem to have been made in tandem with its development. Being fundamentally different in terms of both premise, story and interaction, they each play to different strengths of Dialog. This time, the author presents us with a real puzzlefest, and it is as delightful as they come.

Taking on the role as a six year old girl you start the game tidying up your toys, but it soon turns into a clever, whimsical and imaginative journey through your house in order to make everything ready for dinner. Storywise, The Impossible Bottle certainly alludes to Alice’s adventures in wonderland; it is equally surrealistic (though admittedly far less trippy). And like the books about Alice, Åkesson’s story also contains hidden layers of depth that are gradually uncovered during play. Despite a few instances of parser strangeness, the implementation is mostly brilliant, and the writing, though sparse, is perfectly suited to the protagonist and her world.

It took me just over two hours to finish The Impossible Bottle, and I loved every minute of it!

Comments for the author (contain spoilers)
  • “turn switch with shovel” gave a funny pair of choices, which should be synonymous but only one works:

> turn switch with shovel
Did you want to:

  1. turn the light switch with the shovel, or
  2. switch the light switch with the shovel?
    (Type the corresponding number)

> 1
You can’t reach the light switch.

> turn switch with shovel
Did you want to:

  1. turn the light switch with the shovel, or
  2. switch the light switch with the shovel?
    (Type the corresponding number)

> 2
You manage to reach the switch, only to be rewarded by a cracking sound and a bright spark. The bulb has burned out.

  • The description of the pillow, saying it is supposed to be on the bed, should probably be different when it is on the bed:

> x bed
Nibbles lies slumped in one corner of it. There’s also a pillow.

> x pillow
Soft and fluffy. It’s supposed to be on your bed.

  • “shoe” is apparently a synonym for the outdoor clothes, which seems a bit strange in this case:

> x shoe
Outdoor clothes for rainy days. You haven’t had much use for them lately.

  • While small, it seems unlikely that there is no room for you under the sofa (this may be the case for other furniture too, I didn’t check too closely):

> go under sofa
You drive over to the huge sofa.

There’s no room for you under the huge sofa.

  • I don’t really understand where the gaping hole in the landing came from; it’s only there when you are small, and apparently it can’t contain things:

Landing (in the fire truck)
A vast floor spreads out in all directions. In the middle, a gaping hole leads to a series of platforms, half surrounded by sparse columns that connect in the form of a gigantic railing high above you. There are doors in the far distance to the north and west, and an open doorway to the south.

> look into hole
The gaping hole can’t contain things.

  • If I take the music box from the doll house while the hamster is inside the large version of it, and go to where the large version was, the description of that room still contains the hamster running in the cylinder. The same for trying “x hamster” in that room:

>take music
As you fumble with the music box, the microscopic hamster falls onto the floor of the upper right room.

Got the music box.

> i
You have:
a music box

> s

> s

Room with striped wallpaper
A window in the eastern wall overlooks the main street. Open doorways lead west and north.

The hamster runs as fast as it can inside the cylinder, driving the musical mechanism. A low-pitched, slightly wrong La Cucaracha fills the room, on repeat.

> x hamster
It’s a perky brown hamster with bright, curious eyes and the cutest little paws. Pushed down over its ears is a hamster-sized woolly hat.

The hamster runs as fast as it can inside the cylinder, driving the musical mechanism. A low-pitched, slightly wrong La Cucaracha fills the room, on repeat.

  • The sink contains “a water” and can’t contain things:

> search sink
A water is in the sink.

> x water
A few drops of water are in the sink.

> look inside sink
The sink can’t contain things.

  • I tried to pry open the crate, but pry is here a synonym to push.

> pry
(I only understood you as far as wanting to push something.)

  • The oil can can’t contain things, and the water could get stains:

> empty oil can
The oil can can’t contain things.

> put oil can in water
The water could get stains.

  • Typing “roll” when in the rolling chair thinks you mean the woolly hat:

> x chair
Mom’s working chair can spin and roll across the floor.

> enter it
You get onto the rolling chair.

> spin
You practise your moves.

> roll
A black hamster-sized woolly hat, with “ROCK’N’ROLL” in white letters across the front.

  • You can’t put things in the water:

> put bundle in water
You can’t put things in the water.

transcript.txt (446.5 KB)


Shadow Operative
An Interactive Cyberpunk Fiction by Michael Lauenstein

When given the choice, I strongly prefer to play IF in a local interpreter rather than a web browser. It’s faster, uses less memory, and I can adjust the fonts to my liking. In the case of Shadow Operative, the author was quite insistent that I play the web version. So I tried it, and I’m glad I did.

Visually, the interface of the web version is really nice. The colours and fonts are somewhat similar to the Alien Night theme here at, which, combined with the good looking cover art in the top right corner, sets the mood nicely. For further mood enhancement, there is also music, though it was impractical for me to listen to it while playing. The window is divided into three columns: the leftmost lists accepted verbs and available exits, the right column shows the inventory beneath the cover art, and in the middle we find the command window which works exactly as I’m used to from Lectrote.

Of particular note is that relevant nouns in the output are links. This makes it possible to play the game using only the mouse; I tried it a bit, but for me, typing was faster. The downside to this is that playing it in an interpreter would have been quite a frustrating experience, as most nouns are not links, and therefore not implemented at all. I’m not entirely sure this is the case; I tried a few non-link nouns and they were not recognised. Another consequence of this is that the play experience becomes extremely streamlined, the exploration limited, and the puzzles really easy with such a small noun space. As such, the challenge was next to none and I was able to finish it in less than an hour.

Still, the writing is decent enough to make Shadow Operative engaging for that time. The cyberpunk elements are stereotypical – including VR cyberspace, biohacking, and touches of Japanese culture – as is your eventual mission, but in a rather cute, nostalgic way. There is also a brilliant twist in the story that took me by surprise.

transcript.txt (119.5 KB)


Woot ALIEN NIGHT! (I was hooked on the Ghost theme for a while after abandoning Vincent. )


Turbo Chest Hair Massacre
A real piece of work by Joey Acrimonious

This game contains many elements I had not expected. Suffice to say it makes the story peculiar and interesting. It is nicely imaginative and features a surprising mechanic as well. Puzzlewise, it felt a bit strange, like an ocean of red herrings. In sharp contrast to Shadow Operative, the author seems to have created takeable objects for almost every conceivable thing that reasonably could exist in the house, including a full wardrobe and tons of kitchen utensils. After a few turns of “take all” my inventory list felt demotivatingly long.

One major problem with Turbo Chest Hair Massacre (the version marked 8 Oct) is that a certain item completely takes over the “it” pronoun, something I obviously kept forgetting about every two minutes. I encountered a few other bugs too, though nothing big. Overall, the game is quite well implemented, and the story is good, though I think the playing would actually be more enjoyable with slightly fewer pairs of socks in the inventory.

Comments for the author (contain spoilers)
  • It’s the prototype that takes over the “it” pronoun:

>x table
You feel like the coffee table is the most important piece of furniture in the room. Apart from the listening console, of course. It just adds that convivial vibe that the room needs.

>search it
(the prototype hypothetical temporospatial recoordinator #1)
One part of a pair, this strange handheld device is shaped sort of like a rhombocuboctahedron, except with something that looks kind of like an umbilical cord. You can turn it on with the press of a button.

>take cheddar
You pick up the wedge of cheddar.

>x it
Which do you mean, the wedge of cheddar or the prototype hypothetical temporospatial recoordinator #1?

  • The fan is described as on after switching it off:

>switch off fan
You turn off the fan.

>x fan
This small electric fan sits on the floor, pointed toward your desk. The metal blade is exposed, the front grill having been unscrewed. It’s currently switched on.

  • LOOK doesn’t always tell the exit, even though it’s claimed:

You can’t go very far that way without running into the wall. If necessary, you can LOOK to see where you are and what exits are available.

your bedroom (listening post)
Your bed is, of course, the centerpiece of the room. Your desk and bookshelf reside in one corner, while your dresser and mirror are on the other side of the room. Your closet, where most of your clothes can be found, is open, and a compact metal-bladed fan sits nearby.

kitchen (listening post).
The granite countertop lends class to this otherwise unremarkable kitchen. Drawers and cabinets are stocked with all kinds of things, but probably not your razors. A fridge and an oven are the most important appliances in the room.

  • Marigold claims she is not capable of using her brushes:

>take brush
Which do you mean, my soft brush or my wire brush?

my soft brush: Subjective knowledge (external): I pick up my soft brush.
my wire brush: Subjective knowledge (external): I pick up my wire brush.

>use soft
Subjective knowledge (internal): Some androids are built with specialized hardware and motor subroutines to use an integrated my soft brush in a wide variety of situations. I’m not one of them.

Subjective knowledge (hypothetical): I could modify my body to gain that functionality, but the expense would be more than it’s worth.

>use wire
Subjective knowledge (internal): Some androids are built with specialized hardware and motor subroutines to use an integrated my wire brush in a wide variety of situations. I’m not one of them.

transcript.txt (93.3 KB)


Elsegar I: Arrival
By Silas Bryson

Retro or underimplemented? In any case, the implementation of this game is certainly minimalist. With extremely sparse descriptions and mostly empty rooms, Elsegar I is part frustration and part charm. The puzzles are very straightforward in themselves, though they are made slightly harder through a strict parser constantly having you guess both verbs and nouns. At one point, you even have to repeat an action before it has an effect; this was for me the most difficult point in the game and made me consult the walkthrough. No estimated play time is mentioned; it took me around 25 minutes to finish, albeit with less than a full score.

The writing has quite a few typos, so even if the minimalist approach is an artistic choice, a lot of polish is still needed. As for the story, who knows? The player starts in a peculiar situation, but no answers are given throughout the game. I guess they will come in Elsegar II.

Comments for the author (contain spoilers)
  • It should be “a flower” or “some flowers”:

You’re standing in a meadow knee deep high with wild flowers.

There is a path to the west and a forest lays to the east.

You can see a flowers here.

  • The liquid shouldn’t be part of the cauldron, and the cauldron should not be capitalised:

>put liquid in cube
(first taking the liquid)
That seems to be a part of the Cauldron.

  • “earth” is mentioned but not implemented:

Forest Glade
You have emerged from the forest into a pretty glade. The earth at your feet is a rich brown color.

The forest is back to the north.

>x earth
You can’t see any such thing.

  • “asphalt” is mentioned but not implemented:

Governor’s Street
The long, straight street leads directly up towards the State Capital Doors to the west. The street is paved with asphalt.

There is a path to the east.

>x asphalt
You can’t see any such thing.

  • The plaque both has and has not text:

>x suit
It’s bright and shiny suit of armor apparently wore by some hero from a long time ago, or at least that’s what the plaque says.

>read plaque
Nothing is printed on the plaque.

  • The governor and the guard should have proper descriptions. The desk is not implemented:

Governor’s Office
You have entered the Governor’s Office. The room is in a round, oval shape. The Governor himself is an old man with gray hair. He is so occupied with the paperwork on his desk that he does not even raise his head when you enter the room.

The there is an exit to the east.

The Security Guard stands at his post wearing a red shirt, black tie, dark blue pants, black assault boots, equipment boots, armor vest and helmet.

>x governor
You see nothing special about the Governor.

>x guard
You see nothing special about the Security Guard.

>x desk
You can’t see any such thing.

  • The guard’s outfit lacks articles:

>x helmet
You see nothing special about helmet.

>x vest
You see nothing special about armor vest.

  • “put mug in cauldron” gives no response:

>put mug in cauldron

  • “use” gives a peculiar response, both with and without a noun:

>use mug
You can’t see any such thing.

You can’t see any such thing.

  • Loki should be able to answer about the beast:

>x posters
All the posters have the words “Welcome to Fabulous GoldenLeaf!”… Except for one. It says “One Gold Coin for Any one who kills the beast”.

>ask loki about beast
There is no reply.

  • This sentence contains at least two typos:

We have a labyrinth that was originalily use for something tourist to go in and try to find their way out.

  • The counter is not implemented:

Doctor’s Clinic
It’s one the best doctor’s clinic you have seen in a while!

The exit is to the east.

The doctor herself is standing behind a shop counter near the entrance smiling.

>x counter
You can’t see any such thing.

  • All the food is described as inedible:

>eat bread
That’s plainly inedible.

  • “there” and “aisles” should not be capitalised:
    The exit is to the west and There are Aisles to the north and south.

  • “scoop” doesn’t work:

>scoop shadow with mug
I didn’t understand that sentence.

>put shadow in mug
You use the mug to scoop up the Shadow Residue.

  • A full stop is missing after “hazardous”:

>take shadow
That’s stuff can be hazardous Put it in something so you can take it with you safely.

transcript.txt (73.7 KB)

1 Like

By Dark Star

A particularly well implemented parser game, Entangled is primarily a social realist sci-fi story. The emphasis is on getting to know and understand a typical small town and how it has changed through the years rather than about actually solving puzzles. Actually, in this case there is only a single puzzle: how to get back to your own time. I got the impression that there may be more than one way to achieve this, but it doesn’t seem to matter much. My solution took me to the end in about half an hour.

Exploration is key to understanding the game, but although I felt that I did it quite thoroughly, my final score was only half of the maximum number of points. This probably means I missed out on quite a few details. Regardless, as a story narrated through a parser interface, I regard Entangled as largely successful. Mainly through talking with other characters, who all have a rich set of responses to all sorts of questions, you get a good glimpse of the hopes, dreams and situations of the town’s inhabitants. There were a few things I did not understand, in particular at the very end, but I still quite enjoyed the story.

Comments for the author (contain spoilers)
  • The guy in the park kind of promised me the scarf if I gave him some liquor, but he just disappeared.
  • The ending claimed I hadn’t talked to certain people that I did talk to. It seemed like I should have talked to them again in the present after having changed the past, but the game had ended by then.

transcript.txt (96.5 KB)


hank you for your review, I will try to implement these fixes in the next release, thank you (Also you giving me your transcript and notes on fixing things is really usefull)


Thanks for playing through this. I hope you had fun. Your points are well taken, and they give me a reason to do a post-comp release. I’d like to talk about it some more, but after the competition, if you’re interested.

1 Like

Hey @Stian I fixed many of the issues you had with the game and I recommand you check the latest version and telling me if I missed something or there seems to be a bug or an error when I was trying to fix the complaints. Thank You!


Of course, I’ll be happy to. Just let me know when the time arrives.

1 Like

Sounds good. I will try and finish the rest of the parser games before re-playing anything, but can have a look when it’s done.

1 Like

The gaping hole (when you’re small) is a description of the staircase. You can’t go down in the firetruck


Ah, of course.

1 Like

A Rope of Chalk
edited by Ryan Veeder

It’s hard to say much about A Rope of Chalk without revealing any spoilers, but it certainly is a masterful implementation of exemplary interactive storytelling. I would hardly call it a game; rather, it is parser fiction proper – a story that would not have been as good if told through any other medium. Framed as a true story edited together by the author from individual statements, it recounts an event that is rather trivial from the outside but had a drastic effect on the characters involved. Throughout the narrative, the interaction lets you experience this event from the perspective of several of these characters, in various states of consciousness. Although essentially puzzleless, navigation eventually becomes a hassle, though in a particularly interesting way. I would not necessarily say that I loved it, but I am mightily impressed.

transcript.txt (138.7 KB)


An interactive murder mystery by Rob Fitzel

Written entirely in javascript by the author, Happyland is a showcase for a custom parser engine initially inspired by both Infocom games and choose-your-own-adventure books. It has been developed beyond that, however, and sports functionality almost on par with games written in Inform or TADS. Lacking some fairly standard verbs, such as pull and move, your interaction with Happyland is confined to walking, talking, taking and examining, though it also features a neat system for taking and comparing fingerprints.

Considering the importance of asking questions in an investigation like this, character responses are very brief and to the point, which makes for simpler deduction but takes away some of the immersion; you never get much of a deep understanding of the characters. The same goes for descriptions of rooms and objects. As a puzzle, it is quite simple and straightforward; visiting all the locations and talking to all the characters makes it obvious who the murderer is. Nothing is well hidden either, and there are no red herrings to speak of. In the end it took me less than an hour to complete. It was not particularly challenging, but rather enjoyable nonetheless.


For a Place by the Putrid Sea
An interactive apartment hunt by Arno von Borries

For a Place by the Putrid Sea is a novel of a game, narrating an epic everyday story full of surprises. Despite its size, it’s not particularly verbose, and it took me quite some time of puzzling and exploring before I started getting sense of the protagonist and her world. Having just died after roughly two hours of play, I decided to leave it for now. With two hours with this game, it seems I only have scratched its surface, but it’s just enough to get properly intrigued.

The writing here is peculiar, and it does feel like a novel. While it’s hard to say exactly why, I note a few things: The writing has been allowed to take its time. I have previously played a lot of parser IF where sparse descriptions are indications of lazy (or at least quick) implementation, but here it seems intentional, and just right. The story also seems to be operating on several levels, not only gradually unfolding in a linear sense but also in terms of interconnectedness with people, places and more. While it remains to see how the rest of the story plays out, I have ended up with the impression of this as a work of high artistic and professional quality.

At the same time, there certainly are puzzles here, and they are actually among the more challenging in this year’s IFComp. Still, they also feel right, like they belong in this novel, and the implementation is so far impeccable. For a Place by the Putrid Sea is something special, but I will not know exactly what until I have finished it.

transcript.txt (172.7 KB)