Zork I walkthrough...by ChatGPT

That’s really the key. The big improvement in ChatGPT over earlier GPT models isn’t in the neural network itself. It’s in the boilerplate around the neural network that turns GPT into a chatbot—thereby making it look more like a human.

  1. Neither the Sword nor the Lantern are “Below the Grating;” Both are located in the Living Room.

  2. Round Room? What Round Room??? Dude! The Round Room is from Zork II, not Zork I!!!

Ooops, I missed the part about this being a reply from ChatGPT-4. Clara Peller voice: “Never mi-i-i-nd.”

But, yeah, ChatGPT-4 isn’t always ready for primetime… if you know what I mean. Lotsa room for improvement.


Oh sure, just find the grating and open it. Never mind that you need to find the key in the maze first and find some way back to the surface or find the grating room even deeper into that maze :smiley:


Maybe those are attempts at humor, like those 2 panel comic summaries of classics.

Pride and Prejudice — Jane Austen

Girl hates wealthy aristocrat.
Wait, no she doesn’t.

Which also happens to be wrong in some detail.


The Round Room is in Zork I, it’s next to the Loud Room. Zork 2’s was called the Carousel Room.


Interestingly, in mainframe Zork (aka Dungeon) the room called the Round Room is what became the Carousel Room in Zork II. So everybody’s right! (except ChatGPT)


And even when you question the answers, it will often back them up with sources that might sound somewhat convincing coming from a human, but which fall apart at the slightest touch.

I’ve tried asking Microsoft Bing for a link supporting its claims, and it gave me a plain text telling me to click on it. When I pointed this out, it insisted that it was a link and blamed my web browser. (Even thought I was using Edge just to keep it happy.)

I’ve tried asking Google Bard if a particular book was still in print. It claimed it had called the publisher (yeah right, it was half an hour before midnight on a Saturday evening) and they had answered that it was (no, it wasn’t). I’ve tried asking it about the height of a building, and when I questioned the answer it told me not to worry, because it had visited the site and made the measurements itself.

There have been cases where I’ve gotten correct responses, but I wouldn’t dare to trust them unless it’s something I can easily verify myself.


Slightly off-topic, but this greatly reminded me of Sydney. I think you may have dug up a rather embarrassing moment of Bing’s life…


I guess someday they will invent algorithms which resemble the human mind more. But I also guess those AI algorithms will still kind of suck.


The last part of that robot-chat, where it starts printing these obsessive repetitive declarations about what is and is not true, is really, really creepy. Like back-away-slowly-feeling-behind-you-for-the-doorhandle-out-of-this-padded-room-creepy.


I think it has learned this from real human postings. I call this half-intelligence because it has correctly identified what kind of situation it is, but has not picked the right way to deal with the situation. So it is lying, accusing, apologizing etc. Someone has pointed the AI to data and in this data it found these reaction patterns.

Some folks demand that AI should govern us. When I see this AI examples I shiver at the thought of such a government.


AI can hardly be expected to govern people properly when it has yet to demonstrate that it can effectively govern itself.


I suggest a compromise. Let AI govern those who think AI should govern us and leave the sane people alone. Problem solved.


I agree, to be entirely clear, but it is a little amusing when you could argue that the same logic could be applied to humans and their millennia of flawed, corrupt, injust rule from innumerable governments of all shapes and sizes. Sort of a Lord of the Flies theme, i.e. there are no adults in the room, but I find it amusing.


There aren’t?! You mean we’ve been messing around in the playground unsupervised the whole time?

Crap! Someone go get Mom!


Every single second.


Most humans can govern themselves, at least to the extent of approximately meeting their own essential needs with the help of other humans. We might complain about how it happens, there may be millions of exceptions at any given time, but considering there’s 7 billion of us, the idea that even 6 million of us are able to interdependently get our essential needs met with AI being, at most, an optional extra some humans have chosen to add, is very impressive.

AI is demonstrably not at that level. Put it like this: when the AI breaks, the being that gets the AI working again is never an AI or all-AI group.


Agree to disagree.


I agree.

What do you guys think about this?

in zork I, how can I open the egg?

In Zork I, there is an egg that you can find in the game. However, you cannot actually open the egg in the traditional sense. Instead, the egg is part of a puzzle involving a magic word.

Here’s what you need to do:

Find the Egg:

The egg can be found in the Trophy Case room in the game. You’ll need to locate the Trophy Case first.
Observe the Egg:

Once you’ve found the egg, examine it closely by typing “look at egg” or simply “look egg”.
Discover the Magic Word:

As you examine the egg, you’ll notice it has a word written on it. This word is “PLUGH”. Remember this word as it is important for later in the game.
Use the Magic Word:

Once you’ve discovered the word “PLUGH” on the egg, you’ll need to use it at a specific location later in the game. Typing “plugh” while in certain locations will transport you to another part of the game world, which is essential for progression.
Advance in the Game:

Utilize the magic word “PLUGH” at the appropriate time and location to navigate through the Great Underground Empire and continue your adventure.
So, while you can’t technically “open” the egg, it serves as a clue to uncovering the magic word that will aid you in your journey through Zork I.