YAC!oss unplayable in Parchment

Wasn’t sure where to post this. It’s either ADRIFT news or Parchment news, I suppose mods can sort it if needed. Anyway, I saw that ADRIFT games are now playable on Parchment (thanks to @Denk for pointing it out to me). So I checked out a few oldies but arguably goodies from Tiberius Thingamus and it looks like Pirate’s Plunder! runs alright, but Yon Astounding Castle! of some sort freezes at the intro (or at least the original IFComp version does, I haven’t been able to try out the post-comp release as it doesn’t have an IFArchive version logged apparently). Sound effects don’t play either, but I suppose that’s just a limitation of Parchment.

Any thoughts on what might get it playing or at least what might be causing it to freeze would be appreciated. Thanks.


Works well for me. Can you explain how you start the game? Is it a link online or are you using an IP address you constructed?

EDIT: I am assuming you are using the Play Online button on IFDB? If so, it is currently using the WebRunner which is intended for Adrift 5 games. I will just go and change that. Back in a minute :smiley:

I have just made sure that the Play Online button points at Parchment for that game instead of the WebRunner so it seems to work much better now.

But your right about the missing sound effects are due to a limitation in Parchment / Scare.

A lot of Adrift 4 games are still pointing at the WebRunner - it will take some time for me to get through them all.

1 Like

If it’s really the case that all Adrift 4 games play better in Scare then the default IFDB online play option should be changed.


Ideally yes and then use the WebRunner for ADRIFT 5 games but both v4 and v5 games can have the .taf-extension. If it is an easy fix the IFDB admins should just go ahead but if not we could utilize the fact that no one is making Adrift 4 games any more.

So I have begun to add an extra “download link” to ADRIFT 4 games pointing at Parchment which also makes the Play Online button point at Parchment.

It is going to take some time but I am also fixing broken links at the same time etc so it isn’t a waste of time.

As soon as Frankendrift runs in Parchment, IFDB should simply point at Parchment for all ADRIFT games.

Checked again just now. Still locks up at the title screen on PC using Chrome, also on mobile (Android). I have tried from the Play Online button and the “Play online using Parchment” link.

Are you saying you’re able to get it playing, like you can climb the nut tree and everything, or just that it loads?

I might be able to write the author using a carrier pigeon and see if he could modify the game, but my guess is Parchment or Scare don’t like the “waitkey” tag. Fixing might be a simple issue of removing that and making the title screen respond to a command to start. If that is the issue, though, it might be reason not to update some of the older games that use it.

1 Like

Just tried again. I can climb the tree by going up and then go east from there etc both on my Android phone and on my PC using Chrome and also using Windows Edge browser.

However, right now I have just changed http to https in all download links to see if that helps? Could you try again and if it fails, try to hit the refresh button in your browser?

NB: You have to hit space four times before the prompt appears.

1 Like

Hmm. Nope. I’m still getting the same as before. Frozen on the title screen, no prompt. I’ve tried in Edge now too, along with using Chrome on PC and Android. Maybe there’s some setting I need to change that I’m not aware of?

1 Like

I 'm not an expert at all but had recently a problem with another file on the IF Archive where I could not view the contents of a zip-file. Yesterday I got a reply from IFDB that the problem was gone but it wasn’t gone for me until late today.

This mgiht be completely unrelated but the advice I got was I should try clearing out the caches in the browsers. I thought clicking refresh should solve this but apparently not.

I was also told about ISP cache which I never heard of before but it seems that some internet providers also use cache and you can’t really get around that I understand - you just have to wait until they decide to update the webpage. Hmm - thinking about it - my problem went away when I started looking at the mirrors of the IF Archive. Not sure if that triggered an update to the ISP cache…

If the ISP cache is the culprit you could try twice on your phone, first with wifi and then with cell phone data with wifi disabled. And you should try to click refresh in both cases. Just an idea - not an expert at all.

What exactly happens when it’s frozen? What does it say?

1 Like

It doesn’t say anything special or extra. It’s just hanging there at the title screen. I get as far as “[presseth of yon return key to continue]” and get a blinking | if I click on the screen, but no >. If I press space four times as suggested, the | seems to respond to the first space, but no others. Ideally I should just have to hit enter, the screen should clear, and I should see the first room description and a tutorial message, but I haven’t been able to get to that.

Clearing cache was a good idea, but unfortunately I didn’t find that it helped.

1 Like

Okay, I managed to reproduce your issue and I think I kow why (sort of - still seems like an interpreter bug).

I reproduce the bug like this:

  1. Click on the Play Online button and get the following text:
    Prepareth yeself, adventurer,
    for ye hath enter’d…

  2. Wait about 7 seconds and more text will appear:

  3. Wait one second more and you get:

  4. Wait a final time to get the remaining intro ending with:
    [presseth of yon return key to continue]

Now it seems the game won’t start and it is too late to hit the space bar.

To prevent this problem you must hit the space bar BEFORE the game says “YON ASTOUNDING”. It is enough to do that once, then you can just wait through the remaining intro.

I haven’t encountered this problem in any other Adrift 4 game in Parchment. However, I also tested this in Gargoyle which did not have this problem. It may have to do with how Scare plays together with Parchment. @Dannii might be able to answer that.


Thank you for pinning this down! Yes I can see it too now, there is a Javascript bug. I’ll investigate.

1 Like

Sorry it took so long, but I finally worked out what the cause of this bug was, and it’s fixed now.