Xvan 2.5

I have finished XVAN version 2.5. XVAN now has an understanding of plurality and there also is an undo function.

And everything is on my new XVAN website now, so no more downloading zips from Dropbox.

www.xvan.nl

Thanks for reading…

Marnix

3 Likes

Hi @Marnix

Thank you for sharing this.

When I downloaded the macOS release, the Interpreter was named “Interpreter - macOS” so it had to be renamed “Interpreter” to match the documentation. I then ran it on your example cloak.xvn downloaded from the homepage:

./Interpreter -i cloak.xvn 

But this produced an error:

Initialization error (015): memory allocation error in function: GetNextCode32(
).

Initialization error (024): ReadStoryInfo(): error reading title.

Hit a key…

Do you have a public source code repository where you take bug reports?

Hmm, I tried compiling first…

$ ./Compiler -i cloak.xvn -o cloak

… but this generated a different error:

                 *******************************************************
                                       XVAN COMPILER
                                        version 2.5
                   Copyright (c) 2016 - 2020 Marnix van den Bos
                 *******************************************************

                       max  298 locations
                       max  297 objects
                       max   25 common descriptions
                       max 1001 local descriptions
                       max  125 common flags
                       max  475 local flags
                       max 1001 common attributes
                       max 1001 local attributes
                       max  109 common triggers
                       max  690 local triggers
                       max 6000 words
                       max 2000 verbs
                       max  100 timers

Reading story information

******** Error ********

File: cloak.xvn, line: 12

(000) Error opening file: ./XVAN Library v1-4.lib.

*** hit a key…

Hi Jeremy, thanks for trying XVAN.

The first error with command: ./Interpreter -i cloak.xvn I can explain. The interpreter expects a compiled binary file and cloak.xvn is the uncompiled source code. So you’re trying to run the uncompiled source.

In the second error with the compile command ./Compiler -i cloak.xvn -o cloak the compiler complains it cannot find the library file XVAN Library v1-4.zip.

Did you download the cloak sources zip from the sample stories page ? The zip contains the cloak source, the XVAN library and also the compiled story called out.dat.

If you only downloaded cloak.xvn from the homepage you miss the library.

edit: if you do have the library, you may want to check the path in the cloak.xvn source file. If libray and source are in the same directory change the $insert statement to $insert “XVAN Library v1-4.lib”. I will change this in the zip as well.

Hope this helps.

Thanks for your help, Marnix. I clicked on the homepage, clicked on Executables, and clicked Download (macOS).

https://www.xvan.nl/executables/executables.html

Should the library / libraries be installed separately? And if so, where?

…got it. Copied that library into the working folder, compiled cloak.xvn to cloak, then ran cloak with the interpreter, and it worked.

It seems that the cloak.xvn has a bug. The player can leave the cloak of darkness in the cloakroom, and the bar is still dark.

Foyer of the opera house

You are standing in a spacious hall, splendidly decorated in red and gold, with glittering chandeliers overhead. The entrance from the street is to the north, and there are doorways south and west.

w

Cloakroom

The walls of this room were clearly once lined with hooks, though now only one remains. The exit is a door to the east.
There is a small brass hook on one of the walls.

put cloak on hook

The black velvet cloak is now on the small brass hook.

e

Foyer of the opera house
There are doorways south and west. The entrance from the street is to the north.

s

It is pitch black.

Oops…

That’s not an XVAN bug. but my crappy implementation of cloak. I assumed people would use “hang cloak on hook” but put must ofcourse also work.

An easy fix is to do a find for “hang [o_cloak] on [o_hook]” in the source file cloak.xvn (it’s line 207) and add the line:

“put [o_cloak] on [o_hook]” -> t_hang

under it and recompile. But “hang” will work in the original.

I can make a better fix with synonyms but for playing around this will do as well.

Thanks for noticing this.

1 Like

I fixed the cloak code. It now accepts more actions to put the cloak on the hook (hang, put, throw, drop).

New files are in the zip at the XVAN samples page

1 Like