When changing exits: Programming error: tried to find the “.” of (something)

I’ve seen multiple topics about the same error, but they don’t seem to apply to my problem.

Here’s the code where the error occurs:

	say "A1.";
	change the south exit of R to R2;
	say "A2.";
	change the north exit of R2 to R;
	say "A3.";

and here’s the output:


[** Programming error: tried to find the “.” of 
(something) **]

[** Programming error: tried to find the “.” of 
(something) **]

Now obviously there’s a lot of code I haven’t copied here, but what does this error even mean? And how could it occur as a result of such an innocuous statement?

Could it have something to do with the fact that there are 189 rooms?

This incredibly unhelpful error message means that Inform, at a low level, tried to read a property of something that didn’t make sense. Trying to read properties of “nothing” can do this, under certain circumstances.

The real takeaway here is “something is broken at the I6 level”.

1 Like

Ah, thanks for the nudge in the right direction. I audited my code for places where I might have been careless about leaving nothings hanging around, and that seems to have solved the problem. Thanks!