Viv Dunstan's ParserComp 2022 playing notes

I’m starting tonight to play through some of the games. I am not sure how many I will manage. I am very ill neurologically. But going to see what I can do! I do not intend to write detailed reviews, but more impressionistic thoughts. But trying to be constructive where possible. Thanks to all the entrants and organisers.


Thanks for your efforts vivdunstan!

When it is harder to do things, that is when they show how worthy they are.

Thanks for that constructive approach! Good vibrations and impressionism are always welcome : D


python game by theernis

First up thinking of things that might be getting less attention (though I can’t be sure yet, with the ratings counts not publicly viewable yet) I jumped straight to the python game entry.

This is supplied as downloadable Python files and a README, in a bundled ZIP. Note to get it running on my Mac I had to use Python3. Running it with my default Python2 which python executes gave lots of error messages. So yup, use Python3.

It’s a home brewed minimal adventure simulator. After a flash by of the commands it accepts (copy/paste these out for ready reference if you don’t want to be typing “help” a lot!) I was quickly in a fight. The user interface is sparse with limited commands accepted. “fist” was the only fighting option I had. But I defeated the monster, and got some haul. Then another monster appeared, tougher, and I used “run” to flee from that.

There are very few locations you can move to, listed by “all_loc” and “go_to ” e.g. “go_to forest” lets you move. But the locations are very sparsely implemented.

One fun thing was trading with the traders that pop up. This lets you sell the stuff you get from winning a fight, and turn it into coins and health potions. There is an inventory command that helps. Though having taken damage I was disappointed there wasn’t a stats command to show my vital stats re health etc.

After leaving trading I moved between the two locations but despite using the ‘nap’ command a lot I couldn’t make any other monsters appear to fight, and just got traders. I don’t know if I’d waited longer I’d have seen more, but I stopped eventually.

The game has some appeal, and feels very retro. It reminded me of early 1990s hacking/UNIX typing, or even back into the 1980s or 1970s! The commands available are varied but not easy to remember, and as I say there are some omissions.

It’s not ideal that if you type a command the game doesn’t understand you don’t get a response. It would be good to say ‘Sorry, I didn’t understand that!’ or similar.

There are typos e.g. “its” rather than “it’s” at the start. And I was exasperated when the game assumed I was a “Mr”! I recommend fixing the “you napped for 1 hours” response.

So promising, but it could benefit from polishing to make it more user friendly. And make events happen more often, e.g. I shouldn’t type ‘nap’ that many times and see just a trader … Thinking laterally maybe I was running into some problems with the Python execution. But yup, I needed to see more action. It seemed to run out.

But if people can run the Python 3 code I recommend giving it a whirl :grinning:


The Euripides Engima by Lazzah

Going for what looks like the last game without a rating yet entered on Itch I’ve just spent the last 90 minutes playing The Euripides Engima. This is an ADRIFT game, so I had to install FrankenDrift on my Mac. Which installed ok, but I found had a nasty habit of crashing a lot mid game. So I was saving a lot. I hope I wouldn’t have needed to play the boom box to win cos trying crashed for me repeatedly.

There’s a lot that I like about this game. I should say first that scifi set games aren’t usually my thing. But I really liked the mystery of the base, and the initial setup with a whole team of marines. Though erm that doesn’t last very long!

I coped with the first few puzzles, and liked exploring the geography of the base. I wasn’t however keen on the different commands needed to search for things. Eg I would get very different responses in the same location to EXAMINE, LOOK IN, and SEARCH. Which became rather frustrating, and led to a lot of repeating the same bunch of commands over and over in different places.

The hints seem to be in-location, so eg if you’re stuck in a specific location there are a series of hints you can often get if need be. Though not always, and I got very, very stuck.

I didn’t find the walkthrough too helpful because it was difficult to relate my playing to it, partly based on what I’d done versus it, partly versus on trying to understand the geography from the series of walkthrough commands was tricky. I would have preferred to see a higher level help. And not in game. Because with FrankenDrift on the Mac I couldn’t copy out the walkthrough text with copy/paste. And scrolling through it repeatedly was aarrgghh.

In the end I got stuck at 175/400 points. I was exploring a new area (specifically in the crawler on the planet surface) but seemed to be in a state where I couldn’t move things on (I was stuck in crawler 3, having found crawler 1 and searched it, but unable to make crawler 3 move on again. Inserting the yellow token and pressing the white button just made the crawler stop every time! No more moving.) despite what the walkthrough suggested I should be able to do. I don’t know if I found a nasty hidden bug. But after banging my head on the puzzle for nearly half an hour I gave up.

So yup, a lot I enjoyed. The writing is good, the characterisations good, it’s a nice explore the locations and find the objects to use game. Also scary! But I think I may have hit a bug. And the walkthrough needed to be more user friendly. Especially for such a huge game. Because it is a whopper.

But folks do check it out. You may get further than me! And I did very much enjoy my time playing. Just remember especially if you are using FrankenDrift to save a lot and often.


Of Their Shadows Deep by Amanda Walker

Wow. That was just beautiful. I don’t want to say too much to spoil the experience, but it was lyrical, magical, emotional and beautifully implemented. Very player friendly with good hints. The textual play with ASCII graphics was excellent, but also described well in words in the text, so I think people who can’t see the graphics shouldn’t be missing out.

I just loved it. Thank you to the author!

A couple of minor suggestions for any post-comp release:

It would be good to code a response to STROKE CAT gets a similar response to TOUCH CAT, rather than the current “That’s not something you want or need to do.” I would also recommend adding some sort of response to things like THREAD RIBBON THROUGH WORDS which I tried, and got a “You don’t see that here.” response. Obviously I couldn’t take that shortcut, and had to do things in steps. But might be nice for a post-comp release if the game catches this and similar player attempts.

P.S. It only took me 20 minutes to play through. I rattled on quite happily and didn’t get stuck, apart from one HINT early on.


Thank you so much for this lovely review. I’m so happy you liked it! And your suggestions for the post-comp release are much appreciated.


I made a transcript of the walkthrough for The Euripides Engima if you, or anyone else, want to access it outside ADRIFT.

TEE_Walkthrough.txt (4.2 KB)


Things that Happened in Houghtonbridge by Dee Cooke

Just played and enjoyed this very much. It’s a mystery set in England, with a detailed story to uncover, as well as good use of typical parser based puzzles.

I was particularly impressed by the writing. The world is rich and the story deep to uncover. There is a lot there! Best of all the story is well integrated with the puzzles and world.

I particularly liked the smooth implementation of things. For example if I’m carrying multiple keys UNLOCK DOOR would try them all. Similarly the character needs to drive from location to location and that is very smoothly and intuitively handled. Likewise the conversations are very well implemented. The hints system is also well implemented and friendly, and thank you to the author for providing a walkthrough.

I have a few minor points re tweaks to make in any post comp release. Plus also comments for puzzles I found particularly tricky. I will put those in a spoiler section at the end.

But yes, basically a great fun parser game, with good puzzles, strong story to uncover, and intuitive implementation. Thanks!

Notes for the author:
Maybe add more aliases for putting out the bonfire. Eg I tried PUT OUT BONFIRE without success.
I loved that when I took the ladder into the car the game automatically put the ladder on the roof. Magically smooth implementation! Though I did have serious doubts about carrying the ladder down from the attic :wink:
It would be nice if GET PIPE worked as well as UNSCREW PIPE if you have the wrench. I had to go to the walkthrough.
The timing for the locking other patient door was really tricky to get it right, even though I knew what to do.
And aarrgghh re the field maze! Though yes it did feel very Alice in Wonderland esque. Which was a nice touch.


Thanks so much for your review and for your helpful notes! I’ll make those tweaks in the post-comp release :slightly_smiling_face:

1 Like

Uncle Mortimer’s Secret by Older Timer

Just had fun playing this one. I’m a Mac user but couldn’t use the Mac version provided because it needs too new MacOS for me. However I was able to get the Windows version running under CrossOver. I suspect it would also work under Wine.

It’s a home brew system and it was a little exasperating as someone who benefits from much larger fonts not to be able to change the font size. However the font size wasn’t too bad for me, especially at the low zoomed in resolution I run. So I was able to play ok. Though I don’t know if the game would work for blind people using screen readers. I did like the sound effects.

The parser is pretty good but had some exasperations. Lots of things were unimplemented, with an apology from the author. But the main bugbear I had was how things in containers or on objects were handled. I might just have typed EXAMINE X to see what was in it and be told there is a Y. But if I tried to GET Y or EXAMINE Y it wouldn’t work and would tell me I couldn’t see Y, even though it had just told me all about it. I had to type GET Y FROM X. That got quite exasperating quite quickly.

However that aside the game was a fun timey-wimey adventure with some really neat gameplay mechanics. I especially liked the time travel aspects, though I wasn’t so keen on another device you had to use (the transmuter, for changing keys).

I did rely on the walkthrough when I was stuck. There were a few puzzles I got extremely stuck on and I think need more clueing. There was also quite a reliance on number/letter puzzles throughout. There was definitely a feel of an old school text adventure game. Which I rather liked.

Thanks to the author for providing a good in-game hints system as well as a walkthrough.

I enjoyed this a lot. I think some things could have been smoothed, but I found it an entertaining 90 minutes or so play and would certainly recommend it to others.

Notes for the author:
I initially tried 1589 for the Armada but then thought of going back a year. I do like how the machine deals with you if it’s not an accepted year.
The computer code clue near the end was too hard and needed more clueing. This is something most players had only seen right at the start of the game and would have forgotten. Add more of a hint from Uncle Mortimer re this, or from what Watson and Crick say.
It was a little exasperating that Watson and Crick both gave identical responses. They seemed like twins! Add differences.
I totally missed the cube in King John’s time. I only got to it thanks to the walkthrough and the hints. Something that important shouldn’t be so easily missable.
The Whitechapel section needed more content I think. It felt very unimportant apart from getting the dagger. Add another NPC or something for more interaction. Eg a policeman patrolling that you try to show the handkerchief to but ignores you.


October 31st. by P/o. Prune

Just played through this and had fun. It’s a very old style parser game, with a spooky house, and lots of mysteries to uncover. A nice use of place, and puzzles, and NPCs that you run into.

On the downside I ran into a lot of hunt the verb/command issues. I’m going to list some of them at the end in a spoiler-hidden note for the author. So I did have to resort to the walkthrough. Thanks for including that. And thanks too for the in game hints, though I sometimes found these sparse, and had to go to the full walkthrough to see what to do. There were also an awful lot of doors to open, which got a bit exasperating.

The best thing for me was the spooky atmosphere. Ghostly figures that would flit in and out of view. And a growing sense of unease. It was well done.

The puzzles I liked too, but it was hampered a bit for me by the hunt the commands issue. However it was enjoyable.

For anyone wanting a spooky game do check this out. It would have been a very strong entry for ECTOCOMP!

Notes for the author:
In the attic OPEN EAST DOOR doesn’t open the chamber door, but the attic door which isn’t to the east. I needed to use the walkthrough to find out how to open the door I wanted.
As I commented in the review there were so many doors that needed to be opened. Often to the east! It got a little exasperating after a while.
I struggled a lot with the screw and keyhole puzzle. Eg I’d try PUSH SCREW IN KEYHOLE and PUSH SCREW INTO KEYHOLE. The also unsuccessful PUT SCREW IN KEYHOLE got the response “The screw can’t fit inside the keyhole at the moment.” Please add more alias options. Again I had to go to the walkthrough to find out exactly what to type here.
The padlock was another issue. I tried BREAK PADLOCK or HIT PADLOCK. It was a bit exasperating to find PULL PADLOCK worked. Maybe help players by allowing others.
At the very end please allow STAKE DRACULA. Stake is definitely a viable verb in this case! Thanks.
I really liked a lot of the puzzles. Especially the witch/cauldron one and geting into the hidden parts of the library. And the mouse one. Thanks!


Gent Stickman vs Evil Meat Hand by AZ

Wow. This is different! A parser game with virtually no text on screen and hand drawn graphics instead. Which work remarkably well, for a very bare bones game.

On the downside it is brutally difficult, more so than I like. And getting the in-game hints fully displayed was a bit excruciating to step through.

However it made me laugh. And I was especially impressed at the getting past the chasm puzzle, where the series of pictures displayed had me on tenterhooks, wondering if my character would safely make it through! Thankfully yes.

I can’t remember ever seeing anything like this before. So kudos to the author for a very original game. I just wish it had been less brutally hard, and the hints less painful to access.


All good points, and I’ll implement most of them. Unfortunately, as I’ve said to others in the past, the parser was developed about 40 years ago (although it has grown a bit since) and the problem with having to TAKE [item] FROM [container] is built-in. While I can fully appreciate this being an irritation, I couldn’t alter it without a complete re-write, and as I’m pushing 80 this just isn’t going to happen :slight_smile: . I presume you discovered that you can use F1 + {RETURN] to partially get round this.

As regards King John, at least you can return to get the cube from Runnymede, but it was only later that I realised if you hadn’t noticed King John mentioning ‘Eagle DNA’ at the time there was no way you could return to get the information (unless you happened to be scripting). I’ll also have to think of a way get the player to pay particular attention to this. Maybe John could write something and leave it before he exits the tent.

I always like tinkering with “completed” games, and your comments have given me something to get my teeth into.

Many thanks.


Nope, and as a Mac user I have to jump through some hoops to properly enable function keys. So this isn’t something I tried.

Glad the review was useful!

The Impossible Stairs by mathbrush

This is a traditional parser text adventure game written in Dialog. It is a sequel to The Impossible Bottle game.

I liked a lot about this. The implementation is generally very smooth. Without wanting to give too much away it’s a spatial-temporal puzzle, where you try to complete a list of tasks, and scurry around from place to place trying to accomplish them.

As such it uses a very compact geography, but one that expands. It’s possible to tackle puzzles in different orders, but some things need to be done before others can be completed.

I did find the balance between the puzzles slightly uneven, in that there are a big set of puzzles to complete later (at least as I played it), which were much more involved than early on. On the one hand that could be a nice learning curve for a novice parser player. But it did feel somewhat unbalanced to me.

Best of all I found it to be a sensitive musing on family relationships, change over time, and loss. My dad died a couple of months ago, not suddenly, but after a long illness. And I am still grieving. So there were aspects related to that in the work that I could strongly connect with. In a good way.

I wasn’t quite sure about the very ending, where one choice leads to a winning outcome. I’d like to see it wrapped more automatically. Because by that stage you’ve surely won.

And kudos for the big reveal re one character (Rob). When my brain realised what was happening it was an “Aha!” moment.

The in-game hints were helpful. I did have a few minor disambiguation issues (I am playing the latest download version). But nothing major. And thanks to the author for providing a walkthrough, which I always appreciate.

Definitely recommended.


All the suggestions in your Notes have been implemented. John now hands you the cube, and the clue to the next timeline is in the canister found in the barn. If you ask Crick some questions he will pass you on to Watson, and vice versa. Also, when you ask Crick about Mortimer he mentions that Mortimer kept going on about snapdragons. The policeman (a good idea I thought) is now present, though he doesn’t do much :slight_smile: .

Obviously I had to re-write some of the hints and the walkthrough.

I haven’t uploaded the new version as I don’t think that’s allowed before judging ends.


Thank you very much!

Improv: Origins by Neil deMause

Just played this, which is a brutally tough parser game. There are almost no built-in hints, and if it hadn’t been for Dan Fabulich’s Invisiclues I’d have given up in frustration.

It’s especially frustrating because the puzzles are good - the core challenge is to open a safe, but there is so much more to do to get to the end successfully. And the writing is good and amusing. But I was constantly battling the parser, having to find exactly the right phrasing to make things work. There was also often a need to repeat the same thing over.

I think this could be a strong game if the parser coding was improved to catch more variant commands. And if in-game hints were added. At the very least a walkthrough. Because there’s only so much fun I can get out of banging my head repeatedly against a parser and tricky puzzles without help :slight_smile: Thanks again to Dan for the invisiclues, without which I would have given up in frustration.

So yes, some great ideas, and what could be a really good game. But it needs to be more user friendly. Not in a making the puzzles easy kind of a way. But to reduce the frustration.


Desrosier’s Discovery by Ben Ehrlich and Isabel Stewart

This game is a curious mix of parser and choice. There’s a key section where the choice you make dictates what happens after. The writing was so entertaining that I replayed a lot of times to try out other options. Though with a custom engine and no SAVE/LOAD facility it was a bit laborious to replay.

The writing is amusing, but much of the game isn’t implemented enough. Many things I tried would get the response “Undefined response”. Which was exasperating. There was also a bit of a hunt the verb, and different responses to EXAMINE and SEARCH. Which has a logic to it, but can end up annoying a player. Especially on their umpteenth replay …

However as I say the multiple endings were very amusingly written. Particular praise for a couple (the Father Angus one - bagpipes! - and also the not-Scooby Gang). And it’s credit to the game that I wanted to replay like this. I don’t usually.

But it would be a better game if more responses were implemented, and also if a LOAD/SAVE facility was added. Because when you’re making a key choice repeatedly at a specific point it would be appreciated not having to replay up to that point every single time.

But fun! Thanks.


Cost of Living by Dorian Passer and Robert Sheckley

I believe this is an interactive fiction version by Dorian Passer of a story written in 1952 by Robert Sheckley. The main interface is to type in words to fill in blanks in sentences. It’s not a parser game for me, but more like an Eliza type program, responding to particular words. In a clever way yes, but not a parser.

I ran into some problems with the interface. I run my Mac on a zoomed in low resolution. It’s 1024x640 resolution. I also run my Firefox browser with a pretty large font. When playing the game online I found text would vanish off the central section and I had to scroll to read that. With two big bands down the sides.

The next hitch I ran into was with one of the first boxes I typed a word into. The word I wanted to type was “blanks”, but the game insisted I type “blank” or something else. Mmm. Later on I wanted to type “thinking” into another box but the game wouldn’t let me.

As the story went on I enjoyed it, but it did feel like a choice based interactive fiction with overly long sections to read in between interactive places. I’m not keen on this, and always comment about it in reviews of choice games that do this. If I wanted to passively read a long story I’d choose to do that. I want a higher proportion of interaction versus story text.

Typing words into blanks felt very similar to some other input mechanisms for web based interactive fiction. For example Texture where you drag words, or other systems where you can cycle through word options. Often I felt that what I was typing was predictable. But the good thing is I did feel as though I was in the role.

However whose role was I in? The piece works at a variety of levels, and I wasn’t sure who two of the participants were (Harris and Vesper). However I could relate to the family situation depicted in the story, and I tried to understand how those characters felt when giving my answers.

Frustratingly the piece either ended prematurely for me or ended unclearly. In the last big chunk of text the final piece I had was “It would have been great to be a rocket pilot, to push a button and go to Mars.” but that was the end. And I couldn’t tell if it had just finished abruptly, or if I’d hit a bug.

So in conclusion I quite liked the interface, even if it’s not parser for me. But I found the chunks of text between interaction were far too long. And I was rather puzzled by some of the meta level bits. But I had fun trying it out.