Update on Hugo for Unix

(Ice Cream Jonsey) #1

I’ve recently started using Hugo on a Linux system every day and wanted to confirm that it’s working, after some very welcome help from Marc, nothings, zarf, Zach, Juhana and Kent and others.

I’m using the compiler that can be downloaded here: bitbucket.org/0branch/hugo-unix

(I’m using Linux Mint / 16 / Petra / Ubuntu Saucy)

I am able to compile my work in progress successfully.

I am playing games on Linux with Hugor, which can be downloaded from this link: ifarchive.org/if-archive/pro … ux.tar.bz2

I know there’s no real central repository of knowledge on this stuff, so I thought I would confirm success here.

#2

Since the other server I was using to host Hugor is no more, I uploaded the testing version (with Linux video support) to:

qtads.sourceforge.net/hugor/testing/

#3

That link doesn’t work for me.

#4

I uploaded it somewhere else. It should work now.

#5

Sorry that I have to ask, but how do I download it from BitBucket? I assume I have to compile from source, and I assume that the all the stuff I need to compile is found in the “Source” tab. It looks like the “Source” tab is the contents of a tar archive. But there’s no link to download the tar, and I can’t find a way to download the listed files individually; I can only view their contents.

Also, I followed the link back to generalcoffee.com and looked at this list of official ports again – what’s this new wxWidgets engine? How does that work? Does it run the Windows version via a VM or something? And if it’s just the engine and not the compiler, what’s the point of it, since we already have Hugor?

#6

As far as bitbucket goes, on the “overview” page, there should be a link for downloading the whole repository on the right side of the page.

As for WxWidjets, I think it was the best solution at the time for getting Hugo looking nice on Linux/Unix, but most distributions have updated in ways that make it harder to get running these days. It’s definitely not a new addition and has been on the General Coffee page for years. As far as the interpreter goes, you should go with Hugor, yes.

(Andrew Plotkin) #7

The download link is in the right column next to “Size”. Somewhat buried, I admit.

#8

Thanks.

I succesfully built the compier. I looked into the subdirectories and noticed the README that explains how to build heglk by unzipping the Glk Hugo sources into the subdirectory. This confuses me, because I thought heglk was an interpreter, rather than a compiler.

I’m assuming the Glk Hugo sources are here:
github.com/salty-horse/garglk/t … hugo/heglk

#9

If it has “he” in its name, it’s an interpreter (stands for “Hugo Engine”). The compiler has “hc” in its name instead (“Hugo Compiler”). heglk is the Glk port of Hugo. Note that It’s for text-only games.

(Ice Cream Jonsey) #10

Wow, this was last updated almost a year ago. Argh.

Adam Thornton (bruce) took a look at the Mac Hugo compiler. He identified why it wasn’t compiling certain projects. He described what he did here:

joltcountry.com/phpBB2/viewt … 7&start=20

So I believe he started with Unix Hugo (on BitBucket) and put together the patch noted at the link to make everything seem cool. I’ve compiled my WIP on the Macbook I have and everything seems cool.

I realize right now there’s no Mac repo to grab a working hc compiler from. I’ll fix that and bump this thread when that’s possible. I’m also going to make sure that the Unix and Mac packages are on the IF Archive. Hugo is still pretty great to develop with, I’m using it almost every day myself.

(The Windows compiler and engine haven’t had any problems, so if you want to develop on that platform, no changes have been necessary.)

Robb

(Ice Cream Jonsey) #11

Mac compiler for Hugo is here:

bitbucket.org/rsherwin/hugo-mac (Mercurial)

Let us know if you run into any troubles.

(Andrew Plotkin) #12

You should add two lines in hcheader.h before the “#define strcpy”:

extern char *hugo_strcpy(char *s, const char *t);
#undef strcpy

Makes it cleaner, and shuts up a lot of distracting warnings from clang (Mac C compiler).

(Ice Cream Jonsey) #13

Awesome - thanks for the help, zarf. I committed that change and pushed it. :slight_smile:

#14

Weird. I’m getting the same file name problem with the compiler from BitBucket that I observered from the old compiler last year, but back then the new compiler worked once I built it from source.

Sometimes the compiler removes the last letter of the name of the source file you give it, and sometimes it doubles it:

[code]$ ./hc @lib=…/lib …/projects/embers/embers.hug

Fatal error: Unable to open …/projects/embers/emberss.hug
[rhyndos@hp-smallformfactor-part2 compiler]$ ./hc @lib=…/lib …/projects/embers/ember.hug[/code]
[…]

$ ./hc @lib=../lib ../projects/embers/ember.hug Fatal error: Unable to open ../projects/embers/emberr.hug [rhyndos@hp-smallformfactor-part2 compiler]$ ./hc @lib=../lib ../projects/embers/embers.hug

(Ice Cream Jonsey) #15

I’ll try to see if I can reproduce that, Bainespal.

(Ice Cream Jonsey) #16

Two things, sorry for the necrobump. First, I don’t think I ever reproduced what you are seeing, Bainespal. I have a script that compiles using the Unix Hugo hc executable and sends me a mail if something goes wrong and it’s worked. Let me know if you see this, I would be happy to send you my compiled version.

The second is because I can’t find a dedicated Hugor thread - I put up a game of mine on Steam using Hugor and it works pretty great. So that is an option for anyone looking to do that in the future for game distribution.

#17

This version seems to work on Ubuntu 16.04

#18

This version doesn’t work for me (Ubuntu 16.04)

hugor: error while loading shared libraries: libQtGStreamerUi-0.10.so.0: cannot open shared object file: No such file or directory
#19

Try the original 1.0 version from here:

github.com/realnc/hugor/releases

(I really need to do a new release. It’s been on my to-do list for years now…)

(Ice Cream Jonsey) #20

That would be great. And I should update the IF Wiki’s entry for Hugo to be the ones that was made before clowns at Wikipedia deleted the page. It was in really good shape.