Unofficial Gargoyle build for MacOS 10.12

#21

Working in Sierra for me. Thanks again!

0 Likes

(Nathanaël Marion) #22

I can open it on El Capitan, but I wasn’t able to run a game. When you try to open one, nothing happens, no window appears.

0 Likes

(Andrew Plotkin) #23

That implies that the embedded interpreter binaries aren’t linked right.

What kind of game was it? Can you test a glulx game, a zcode game, a TADS game?

0 Likes

(Dan Fabulich) #24

I opened Anchorhead in Gargoyle on El Capitan. I tried it both with double-clicking on the Gargoyle app, and by double-clicking on the .z8 file.

Notably, when I double-clicked on Gargoyle, the app appeared in the dock and stopped bouncing, but it didn’t claim focus; I was still in the Finder. I had to click on Gargoyle in the dock to get it to pop open a window to select a game. Similarly, when I double-clicked on Anchorhead, it opened a window, but the window appeared behind my current Finder window. I had to click on the window and/or on the dock.

Natrium729, I don’t suppose this is what you’re seeing?

0 Likes

#25

Hmm…seems I was too hasty in stating the libraries weren’t an issue in earlier OS X releases.

I’m not seeing this at all (on Sierra, though). Are you running Gargoyle directly from the .dmg? I did notice things didn’t work right in that case (e.g. I couldn’t open a game by draging to the dock icon)

0 Likes

(Leugengroot) #26

Tried running the latest release on macOSSierra 10.10.1 beta. Some games (e.g. Photopia) run fine without any problems, other (e.g. City of Secrets) stop at the title screen.

Jens

0 Likes

(Andrew Plotkin) #27

Hm. That happens to me too (in CoSv3.blb). The stack trace shows a null-pointer exception in gli_piclist_clear. So it’s not a dylib problem, it’s an unrelated bug in garglk.

0 Likes

#28

Gargoyle image handling bug fix (fixes CoSv3.blb for me). I can submit a GitHub pull-request if wanted.

These lines in “garglk/imgload.c” need to change from:

77:            gli_picture_decrement(tmpptr->picture);
78:            gli_picture_decrement(tmpptr->scaled);

to:

77:        if (tmpptr->picture)
78:            gli_picture_decrement(tmpptr->picture);
79:        if (tmpptr->scaled)
80:            gli_picture_decrement(tmpptr->scaled);

Bug introduced by recent enhancements to picture support (not included in any official release that I’m aware of). Not guaranteed to fix all bugs.

0 Likes

(Andrew Plotkin) #29

Yes, submit that PR, please. Thanks.

(I still intend to look at building a statically-linked version, just didn’t happen this weekend…)

0 Likes

#30

A statically linked version would probably help with bundling Gargoyle and a story file - I never managed to work that out for Kerkerkruip.

0 Likes

#31

PR submitted (#235).

FWIW, this bug affects all Gargoyle builds.

0 Likes

(Andrew Plotkin) #32

Okay, kids, one more try.

eblong.com/zarf/tmp/gargoyle-2016-mp.mac.dmg

This has been tested on MacOS 10.7 and 10.12 but nothing in between. It has the fixes for the keyboard-input bug and the image bug (which was crashing City of Secrets).

EDIT: moved to Github; see github.com/erkyrath/garglk/releases .

0 Likes

(Andrew Plotkin) #33

…let me know if it works (or doesn’t). If this build looks solid, I can push forward on making an official Gargoyle release.

0 Likes

(Leugengroot) #34

This looks very good on macOS Sierra 10.12.1 Beta. Even City of Secrets works fine.

Jens

0 Likes

#35

Yup, working on my end too. Thanks again Zarf.

0 Likes

(Hanon Ondricek) #36

Is Gargoyle the only thing needing update IF-wise for Mac OS Sierra? I’ve been avoiding the update because I don’t want to break anything while two comps are happening.

0 Likes

(Andrew Plotkin) #37

Zoom and Spatterlight are still out of commission on Sierra. Nobody has been looking at updating those. (…in years and years.)

0 Likes

(Hanon Ondricek) #38

I think if Lectrote gets glulx sound support, it will be my new favorite interpreter.

0 Likes

(Andrew Plotkin) #39

Keeping this in my /tmp directory is silly, so I have pushed it up to github at github.com/erkyrath/garglk/releases .

If the Gargoyle team wants to grab it and release it officially, that’s cool.

0 Likes

#40

I just tried the latest Gargoyle. On Leadlight Gamma, it locks after the title screen has faded away. The audio cuts abruptly at the end of the visual fade (not the normal behaviour) and the screen stays black. The program seems frozen at this point.

-Wade

0 Likes