Tweego v2.1.1

Tweego v2.1.1 has been published.

Downloads & documentation: http://www.motoslave.net/tweego/

Changelog highlights:

  • Fixed a crash in watch mode that could occur when moving or renaming files within a watched directory—because of an uncaught API change.
  • A few minor improvements.
3 Likes

Thanks, a lot!

I’m sure this is a stupid question, but can Tweego work with Sugarcube 2.3.1+ ??
I’m getting an error: “Story format named “SugarCube” at version “2.31.1” is not available.” when I try to decompile a story html into twee code.

I’m running the desktop version of twine at 2.3.1 sugarcube - do I have to roll back to a previous version?

Thanks

Yes, it works with all versions of SugarCube v2. However, the SugarCube story format “format.js” file has to be installed somewhere that Tweego can find it. See “Story Formats and Search Directories” in the Tweego documentation on how to set that up.

Also, you need to make sure that you’re using the correct format ID for the “story format” parameter. You can do:

tweego --list-formats

to get a list of story formats that it can find. Then you’d need to set up the “story format” parameter like either of these:

tweego -f sugarcube-2
  - or -
tweego --format=sugarcube-2

(See the Tweego “Options” section for details.)

Finally, the latest version of SugarCube is currently v2.33.2, so you might want to download and use that instead.

Hope that helps! :grinning:

1 Like

Thanks heaps.

So when I list formats by running “tweego --list-formats”
in the command line, I only get up to Twine 2.30. I’m pretty sure I’ve installed the latest 2.33.2 correctly? It’s showing up in the twine program (offline).
But still no dice with Tweego decompiling.

I’ve replaced the old “format.js” file (2.31.1) with the new one (2.33.2) in the default location on my pc:
C:\Users\gibbw\Documents\Twine\Stories\storyformats\sugarcube-2

And my URL link to add the new format in the Twine editor was this, and it seemed to work fine:
file:///C:/Users/gibbw/Documents/Twine/Stories/storyformats/sugarcube-2/format.js

This is what the Cmd line looks like when I try to use Tweego in the twine stories folder:

C:\Users\gibbw\Documents\Twine\Stories>tweego -d -o Global_Gamewise.twee Global_Gamewise.html
error: Story format named “SugarCube” at version “2.33.2” is not available.

Available formats:
ID Name (Version) [Details]


chapbook Chapbook (1.0.0)
chapbook-1 Chapbook (1.0.0)
harlowe-1 Harlowe (1.2.4)
harlowe-2 Harlowe (2.1.0)
harlowe-3 Harlowe (3.1.0)
paperthin-1 Paperthin (1.0.0) [proofing]
snowman-1 Snowman (1.3.0)
snowman-2 Snowman (2.0.2)
sugarcube-1 SugarCube (1.0.35)
sugarcube-2 SugarCube (2.30.0)

Originally I assumed that maybe Tweego only went up to Sugarcube 2.30.0, but if it can do later versions that is amazing. But I’m not sure why it’s not detecting it? Any ideas? :stuck_out_tongue:

Tweego does not look in the Twine editor’s directories for story format files. Thus, what you see within the Twine editor is totally irrelevant to what Tweego sees.

Again, see “Story Formats and Search Directories” in the Tweego documentation on how to set up what directories it checks.

TL;DR: Put the SugarCube v2.33.2 “format.js” file in the “Tweego\storyformats\sugarcube-2” directory. You can then use the --format=sugarcube-2 parameter with Tweego.

Oooh ok do you mean Tweego WON’T look in Twine’s directories even if tweego is in that directory as well? That does seem counter-intuitive if so, not that it really matters I guess…

Haha yep so I have read the “Story Formats and Search Directories” section of the Tweego documentation multiple times now :slight_smile: If it were simply a matter of reading the documentation I’d never be on the forums right? :stuck_out_tongue_winking_eye:

As per the Tweego documentation, it seaches "the following directories: (in order)

  1. The directories storyformats and .storyformats within its program directory—i.e., the directory where Tweego’s binary file is located.
  2. The directories storyformats and .storyformats within the user’s home directory—i.e., either the value of the environment variable or the operating system specified home directory.
  3. The directories storyformats and .storyformats within the current working directory—i.e., the directory that you are executing Tweego from.
  4. The directories specified via the environment variable. See Environment Variables for more information."

AFAICT my directory already IS what you suggested ("Tweego\storyformats\sugarcube-2") where "Tweego" is the "Tweego.exe" file. (Is that a binary file??)``Is the fact that that *also* happens to be the Twine Stories folder problematic or something? It seems to me that this directory structure should satisfy both 1 and 3 above - but obviously I must be missing something?

Update: Ok so I tested the exact same structure just in another folder on my PC and it worked. So it seems that there is something weird going on with the Twine stories folder that Tweego doesn't like? Or there's another error somewhere...blerg. I guess I don't mind too much anymore because it's working somewhere...

Thanks for your help.

``