Tweego not finding Start passage

Tweego version: 2.1.1+81d1d71 [linux/amd64]

I’m having a fundamental problem with tweego: I give it a file in tw3 format, and it swears blind there’s no Start passage.

This is the whole of my file:

:: Start

This is the start of my story.


:: Fred

This is Fred. He's a passage.

and when I run “tweego tfg.tw3”, I get the following error message:

error: Starting passage "Start" not found.

Either I’ve clearly got something fundamentally wrong somewhere, or it’s emitting the wrong error message.

1 Like

What do you have in your StoryData?

Example of the StoryDate passage below:

:: StoryData
	"ifid": "2BBF014B-FE37-40DD-A448-FCE68799803C", 
	"format": "SugarCube",
	"format-version": "2.36.1",
	"start": "Start"
1 Like

I don’t know much about Tweego, but are you supposed to put a space between your colon and the name of your passage?

1 Like

The examples in the tweego documentation on all use a space after the double-colon.

It turns out that I skimmed the list of supported file extensions a teensy bit too fast and managed to make myself think that the correct extension for a twee 3 file was “tw3” when it’s actually “tw” :neutral_face:

When I renamed my file from tfg.tw3 to everything worked.

I’ll leave this thread up here in case anyone else ever makes my mistake :slight_smile:


Well, .tw and .twee are both acceptable, but yes, .tw3 is not a thing.

1 Like