Trouble in Sector 471

OK, who else is playing this? Cute and fun, and surprisingly manageable for an Arthur DiBianca game: I used the hints several times for the primary objective because I was too lazy to go back and find the in-game clues that I hadn’t written down, but then I got 6 of 8 optional ones within the two hours… and I figured out the rules for probably one of the last two, I just…ugh, I’ve never clicked with parity-flipping puzzles.

I like how tight it is: 8x8 is big enough for mechanics to overlap a bit, and for you to go “wait, where did I see that?” or “ohhh…that was actually significant!” but small enough that it feels cozy and it’s not too annoying to have to walk all the way across it, or check every square for clues.

Edit: aha, got the last two optional objectives. Yay!


It is just so cute. I’m still playing it, but I love what he’s done with the limited command set here. Another winner, I think.


I started playing it and loving it so far! It’s so cute, feels really polished and I love the limited command set! Looking forwards to see if I can solve it or not. :slight_smile:

Late to the party but: superb little game, I especially liked the minimap!


I am keeping playing this after having zapped the last bug. I want a 100% run.

  • How the do I open the door in Insulated Hall?
  • How do I not get bounced in Metacycling?
  • I hopped in (I think) all orange rooms, what next?

I hope ADB will publish a full guide/hints/commentary after the contest is over!


Doing this by memory so apologies if I’m misremembering the names of the rooms:

On point one, I think the door has a safety lock, so you just need to put in the right code in the safety override room – I’m not sure which one is correct but I suspect it’s the one that’s hidden in three parts around the facility.

On point two, notice how this is the message you get right before you get bounced? “A laser beam sweeps across the floor and encounters your locomotion units.” And do you notice anything consistently happening before you get bounced? Explicit solution next:

You just need to HUP whenever a red light blinks.

Never figured anything out for your last bullet point, I suspect that’s the bonus point I missed (I also didn’t solve the pipe puzzle since it seemed too much of a grind).


Thanks @DeusIrae, appreciated! Now the task I am missing are:

  • orange stripes

  • gym done, thanks again @DeusIrae

  • pipes

See if i can get an epiphany

1 Like

The gym is easy – here’s a hint if you want it:

It’s kind of the reverse of the Metacycling puzzle.


Ah man, it’s been a while: I played this one first. I think there are four orange stripe rooms but only three of them do something when you HUP, and the last one is where you go to see the result? Maybe? Edit: Yeah, I’m pretty sure you go to the Sorting Center at the right edge, 4th row: Calc-18 says “To restart it I need to get those [three] lights lit, but I don’t know how. I think it may involve remote controls of some kind.”

As for the pipes, the trick is that the cracked one doesn’t behave the same: I think sometimes it doesn’t cycle? I was trying to get everything fairly close and then I solved it by accident, so I don’t have a good answer here…

1 Like

Thansk @JoshGrams! Embarassingly enough… I think already solved the orange-stripe-rooms puzzle, I just did not notice (forgot to go back to Sorting Centre.

Will tackle pipes next.

I’m also having trouble with the pipes in sector 471 … I have spent ages on this seemingly simple puzzle. :frowning_face:

I did notice the cracked pink crystal, but it seems to behave exactly the same as a normal pink crystal. What am I missing?

I’m going to go out on a limb here but I swear that all that happens is that sometimes you have to type the same command twice to get it to work, but otherwise nothing else is different. I might be wrong, but nothing came up in my playthrough to convince me otherwise.

Yeah, I think if the next one is blank (or the previous one?) then you get to ROX once and it cycles one of the things but not the others, so it lets you line up the last thing without messing up the others? Sorry, I’m not being vague for hint purposes: I don’t remember the specifics… And as I said, I solved it by accident because I’m terrible at this specific kind of puzzle.

I also don’t think this one leads to anything special: IIRC it’s an optional puzzle that gives you that one last point?

Edit: Hmm, I do have a save right before the pipes so maybe I’ll go poke at it…

Yeah, I don’t know. In the room with the cracked pink crystal you can get

The crystal sparks weirdly.
You also hear a whirring sound from the east.

So it lets you offset the changes in that room by one. But I’m not sure what the conditions are? Sorry. I’m just bad at this sort of linked-cycling puzzle. Maybe one of these years someone will explain to me how to think about this class of things and I’ll get it, but for now they’re just “fiddle around until it works” for me.


The ‘crystal sparks weirdly’ event sounds incredibly useful for solving this puzzle. I hadn’t noticed this text. And looking back through my transcript, I only triggered it once, and that was the very first time I entered the pipe rooms. For my last 1000+ ROX commands, the cracked pink crystal behaves as a normal pink crystal.

I have tried varying things to get the crystal to ‘spark weirdly’, like putting different items in the room and even going for a ‘sparkle shower’ (in the Field Generator), but nothing seems to have an effect. :frowning_face:

Ugh. Never mind about my last message: that’s a red herring, and an annoyance, that maybe happens once randomly? When I started thinking about it as a parity puzzle and dependencies it all fell into place. So here’s a full process, I think?

basic mechanics

The crystal panels have three colors: blank/red/pink (and cycle through in that order).

When the panel is blank, ROX has no effect.

When the panel is red, ROX cycles the fluids through Amberix/Gilsap/Chroton.

When the panel is pink, ROX cycles the flow through none/trickle/swift.

If you ROX, and a change happens, then the panel in the next clockwise room cycles color (blank/red/pink).

The solved state is all rooms with Chroton flowing swiftly.

counting parity for order dependencies

Is there a word for when there are three states instead of two? Maybe it’s a trinity puzzle. :stuck_out_tongue:

OK. So draw out the state, and count how many ROX commands you need to cycle it to the solved state. You don’t care about the color changes, just the flow and fluid changes. So if you have Amberix flowing slowly, you need three ROX: Amberix to Gilsap to Chroton, and slowly to swiftly. Now you can look at the next room’s color and see which color it will be in when the current room is solved.

This gives you a bunch of order dependencies.

You also know that when one end of that chain is solved, the next room is a certain color. So you know that one property must be in the right state, and the other is still changeable.

full derivation of order

For me, when NW is solved, NE is blank. So NE must be solved first.

When NE is solved, SE is blank. So SE must be solved first.

When SE is solved, SW is red. So SW must end up in red/anything/swiftly when SE is solved. Remember that the color will cycle when you do the last step of SE, so it needs to be blank/anything/swiftly before? Except…that if you’ve seen the “sparks weirdly” effect, then SW will be pink, and you want pink/Chroton/anything instead.

When SW is solved, NW is pink. So NW must end up in pink/Chroton/anything.

So you have to solve SE, NE, then NW. And we know that SW must end up in red/?/swift when we solve SE.

So…we can partially solve SW, then solve the east side. Now we can ROX SW as many times as we want, it won’t lock us out of the solution. So we can trivially solve NW (it’ll change the color in NE but not the solution, so that’s fine). And then we ROX SW however many times we need until it’s solved.

tldr full solution

You can
Starting at the SW room and working counter-clockwise, set each room to Chroton flowing swiftly. You’ll have to mess up the SW room at some point, but don’t worry, it will work out that it stops there: you shouldn’t have to mess up the SE room again.

So…yeah. I’ve changed my mind. This is such a good puzzle. If you just worked your way around backward setting each room, (minimally messing up earlier solutions to make that happen) you’d eventually find it purely by accident. I’m pretty sure that’s how I got there the first time. But if you try to solve it by hunting through the maze of states it’s a hard puzzle, and even when you start looking at the parity it’s still an interesting challenge. Pure evil. I love it.

Edit:: grr…forgot to account for the effect of sparks weirdly. On the other hand, that makes the solution even simpler and now I’m really smacking myself for not seeing it…

1 Like

Thank you so much for writing this! :grinning:

I had managed to figure out he basic mechanics (after first trying to create a very complicated almost-working mental model of how the pipe system worked), but didn’t think of counting ‘parity’ (remainders in modular arithmetic?). That’s very clever!

And yes, I had managed to get the puzzle into a very messed up state. But it turned out that I was actually very close the solution (if counting the number of necessary moves). And now I’ve finally solved it and gotten that last lousy point! :grinning:

I agree that it’s an excellent puzzle. I hate it! :wink:

So now I’ve finished the game and gotten a 5000-cycle vacation. But there are still so many unanswerd questions. Such as:

  • There’s an empty space in the middle of the map. Is it possible to visit it?
  • Where did Med-23 go?
  • Is it possible to ‘run out of juice’? :low_battery: Can Wait-3 then help me?
  • Is there any use in getting rusty or sparkly in the Field Generator? :sparkles:
  • Why is Engi-12 still so willing to drain the zirbol tank for me? I tried jumping in after opening it, but couldn’t. Probably for the best.
  • Is there any point in improving my personal best > 50 in the gym?
  • Min-3 won’t allow me take a crystal. Too bad. I really wanted to fix the cracked crystal in the pipes area … :smile:
  • Why can I jump from the Processing Annex to the Processing Chamber when the magnetic nullifier is in the room? I can’t do it in the other direction? (Just a bug?)
  • It’s possible to send the rivets to the Chip Analysis. But it doesn’t change the room description in Chip Analysis room. Any reason?
  • I spent my 5000-cycle vacation waiting. Nothing happened. :cry: (Though I only half expected it to.)

Anyway, an excellent game!


Due to time restrictions I could not play all the IF Comp games within the voting deadline, so I only got to this now.

This is exactly the kind of game I have been waiting for ever since the remarkable “Inside the facility”. While some of Arthur DiBianca’s games in the following years didn’t click with me (especially “Sage Sanctrum Scramble” and “Skies Above”), others were nice too, but I always felt that they didn’t quite get to the level of “Inside the facitility”.

This one, on the other hand, does, and feels very much alike. Limited parser, a map, being some kind of robot, challenging but fair puzzles. Thank you for this game, Arthur!

I had a fun evening and needed to consult the hints only once, for the sculpture bot. And yes, the pipes area was difficult too, and I think finally I solved it by a mixture of deduction and just trying.

But now I’m still missing one optional task. Probably it’s related to the bug lab? Any hints on where I can find a piece of a bug to give to Ent-22?


Hrm. With where you are, I’m not sure I can hint the bug piece without just spoiling it. How about these?


One of the bugs doesn’t just turn into dust.


It’s the hard-shelled bug.


It was on the Auxiliary Power Conduit (Aux, 5th column/7th row). Look at this room carefully.


Where might the trash chute lead?


After you kill the hard-shelled bug its shell ends up on the carousel in the Trash Repository (Tra, 8th column/2nd row).


Hey Josh, thank you for the quick answer and even making the effort to not completely spoil the solution! I had indeed noticed that the shell went down the garbage chute, but I had not paid enough attention to the room names obviously, so I did not remember that there was a place were it could probably end up. After your clue for this, however, I found the correct place. Now I can finally sleep well after having the 100% completion in this game. :wink: