Translating the Source Failed

Hello all,

Recently I copied my Inform projects off onto a CD, reformatted my hard drive (Windows XP Professional), reinstalled Inform and copied my projects back into the new Projects folder.

Now I’m getting the “Translating the Source Failed” message no matter what I do. I commented everything out of my program except the title, and still got it. I created a brand spanking new program, and still got it. I moved everything around to different places, and still got it.

What the heck?

Just for the record, I just now grabbed everything Inform I could find, threw it in a folder, zipped it and threw away the original. I removed Inform again through “add/remove programs”. I installed it again.

Same result – I can’t even make a new project that will compile.

What does the I6 compiler error message say? You can see it if you switch back to the “Progress” tab when you get the error.

[code]“new” by Shae

The lab is a room.[/code]

Progress tab:

and in case you need it:

Just tried compiling with a more complicated program, and got the same message under progress: “Compiler finished with code A”

This is just guessing, but the error message suggests that Inform can’t find the Standard Library or some other part it needs. Is the Standard Rules.i7x file in its place in C:\Program Files\Inform 7\Inform7\Extensions\Graham Nelson?

Yes, that one is there.

But I agree, I think it’s a missing item, somehow, because it started happening after reinstallation and because it happens no matter how simple the game is.

Browsing around on Google I found a post on the Translating the Source Failed error in which someone said "I run and install all programs on my laptop with Administrative privileges so I think I can rule out ‘security setting issues’… "

I’m on a work computer (shh) that might be pushing out changes to the image periodically… does that point to a security setting issue, or otherwise clarify things?

If you installed wihout administrator rights, maybe it couldn’t install everything it needed. Other than that I’m out of ideas.

I looked, and if I’m looking in the right place, I do have administrator privileges.

I tried it all again a few times, destroying every Inform-related bit I could find, but no luck. Not much out there on Google either.

Oh well, thanks for trying Nitku. This may become something I can only do from home for a while, on the good old Linux machine.

I found someone complaining of a similar problem in a forum, and in their case, it was thought to be related to a firewall. Since I was at work when I started this thread, I tried again at home but got the same error. Then I uninstalled and reinstalled with the already downloaded installer and still got the error. Then I re-downloaded an installer, uninstalled and reinstalled, and got the same error.

Then I decided to go back a version, and download the installer for 5U92.

I got the Translating the Source Failed error again, this time with a different graphic. :frowning:

I suspect you’re getting this error because Inform is unable to write to your project folders. Windows has an annoying habit of marking files read-only when you copy them from a CD to the hard drive (since they were read-only on the CD).

Open your My Documents folder, right click on the Inform folder and open its properties, uncheck “Read-only”, click “Apply”, and make sure “Apply changes to this folder, subfolders and files” is selected.

Thanks for the suggestion Vaporware. I tried it, but it didn’t work. I even applied the change by hand to every subfolder just in case, and went into C: and did the same to the Infrom program folders there. Weirdly, after changing a folder to read-only, when I clicked on properties again, the square was filled in again (not checked), indicating that perhaps Windows undid my preference? Or perhaps not.

It’s weird that even brand new installations and projects don’t work, as well as those that got copied to and from a CD.

OK, this is just super freaking weird.

A guy at work spilled a glass of water in my laptop and damaged it so I was slated to get a new one. I figured this issue would go away with the new laptop.

I’m running Windows 7 now.

I downloaded Inform and installed it again. No trace of the old app or files were moved to the new computer from the old, nor were there for any other reason.

This time, every time I compile anything I get “The webpage could not be displayed” and in the status bar, “The game has not been compiled”.

For what it’s worth, the Internet connection is working fine.

I’m downloading I7_5Z71_Windows.exe for “PC running Windows 95 or later” from inform7.com/download/.

Is there something wrong with this file? Or is this an unrelated new Windows 7 problem?

Is it time to file a bug report? If so can someone point me in the right direction to do that?

Thanks

Edited to add: “Compiler finished with code 2”

I’m not aware of any problems with running Inform on Windows 7. I’m using Windows 7 Ultimate myself.

My suspicion is still that this is some kind of security setting that’s preventing Inform from writing its output. Can you check a couple things…

  1. On the “Errors” tab, select “Progress” and paste everything that appears there.

  2. After trying to compile the project, leave Inform running and open your Documents\Inform\Projects folder, open the folder for your project, then open the Build folder inside that, and list the files that appear inside.

DOH!

This time this is probably all my fault.

When the computer was put in my hands, I immediately started customizing it in the colors and file structures and such that I like.

I noticed there was no “My Documents”, but instead a folder named after my user name, that spoke of adding and removing “libraries” (whatever those are) and contained a dozen “My Music” and “My Whatever” folders that looked completely obtrusive and annoying to me.

I backed that junk up and then deleted it. Then I created my own “My Documents” folder just so I could get started with storing some work files without researching Windows 7 for two hours first.

SO… Inform used to put a folder in “My Documents” containing Projects and other folders. Obviously it’s not there now, and I can’t tell that it’s anywhere. I looked in Program Files (the program was there of course but the folder structure looked different) and even tried re-creating it here and there, but that didn’t help.

So I assume I probably need to do one of the following… ?

  1. Restore that built-in folder that I deleted (I’d really rather not, if it’s going to prevent me from deleting its built-in cruft)
  2. Set a default somewhere in Inform telling it where to store projects?
  3. Recreate the Projects folder and other folders somewhere?
  4. Reinstall Inform and choose a different location?

Thanks for your help Vaporware.

The best thing is probably to restore the deleted folders. If you really don’t want to do that, you could try just recreating the Documents folder: click your name on the Start menu, which should open your home directory (containing Contacts, Desktop, Favorites, Links, Searches, etc.), then create a folder called Documents in there.

Thanks Vaporware.

Recreating just Documents didn’t work. Restoring the whole user folder did.

Grrr!!! Why must Windows always litter numerous and useless undeletable folders all over everything? That’s a post for another forum, I guess.

No way to hide that user folder off my desktop, but still let it exist and hold those Inform files I assume?

If not I will live with it for now, because I’m tired of not writing Interactive Fiction!!

Thanks again.

In other news… Windows 7 is acting weird. Maybe it’s because I deleted that folder and brought it back.

Putting a documents “shortcut” on the desktop somehow seems to put the real documents there, as do some other folders. This makes it hard to understand when I am deleting and how to stop looking at something without deleting it.

I put a folder called “organize” on my desktop when I first got the computer, put some stuff in it, took the stuff out, and deleted the folder. Now that folder comes back every hour or two, even after reboots. I’m guessing that I must have put something from the library in it, and now Windows thinks that it’s a special folder that ought to behave erratically. I even renamed it “go away”, but it won’t.

When I add a favorite to IE, EIGHT (no more, no less) identical favorites folders are generated in my library. If I delete one, I delete them all. If I add another favorite after deleting, I immediately get another eight folders. They can’t be hidden. I can’t find anything on Google about this.

My copy-and-paste and select-all keyboard shortcuts don’t work in most programs. This I found on Google, but no solution that works for me.

I don’t really expect anyone to have advice… just venting.

Isn’t progress grand? :slight_smile:

I don’t know anything at all about Windows 7 (or Windows Vista), so I can’t offer any advice on the particular troubles you’re having beyond some general ideas:

–If these troubles are on a computer at your workplace, and if there’s an IT department at your workplace, tell them they gave you a lemon and then complain to your boss every day that you’re not nearly as productive as you could be if you had a properly working computer. There’s no need of course to mention that you’re having trouble installing video games; the troubles mentioned in your very last post could be easily framed in terms of Official Job-related Stuff, and (to me at least) indicate that something is clearly wrong with your OS installation.

–Inform 7 for Windows requires that Internet Explorer is installed on your computer; were you given a computer with Firefox etc installed instead of Internet Explorer?

–If you look at the “Help>Windows Inform Notes” section of Inform 7 for Windows, there’s a subsection about making a “home.txt” file. You just make a one line text-file naming a path to wherever you would like Inform 7 to store your user files, which can be anywhere you like (no My Documents required). After making this file, Inform will move its stuff to whatever folder you specified in “home.txt” the next time you start the program. It will also leave behind your original user files in the “My Documents” directory; after restarting Inform with the new “home.txt” pointing to somewhere else then (assuming you didn’t install Inform itself in “My Documents”) anything Inform-related in “My Documents” can be deleted as it will never be called upon again. :confused:

–Ditch that newfangled junk OS and go back to good old DOS 6.2 :laughing:

–Vaporware’s suggestion a while back about changing files restored from a cd backup from read-only status was a good one; if these newer operating systems you’re using still have a command line where you can run batch files, just make a one line batch file:

attrib -r *.* /s

If you create this file (e.g. “noreadonly.bat”) in the parent folder of where-ever you restored your backup to and run it, it will remove the read-only status from all the files in the entire directory in one simple step.