The Last Resort

The Last Resort by Jim Aikin

(Note: this review is based on the first version of The Last Resort. Two (I believe) subsequent versions have since been released so it’s likely that some of the bugs referred to herein have now been fixed.)

“The Last Resort” was one of several games recently announced on RGIF in the wake of the IFComp. It’s a fairly sizeable game, too, not in terms of locations (although there are quite a few of these) but in the amount of things to do and see. Add on the amount of times I restarted the game after realising I’d missed vital things and you have a good few hours of gameplay here.

The game begins with you – a teenage girl called Diane – being dragged to the town of Eternal Springs by your Aunt Caroline, a novelist, for reasons unknown. She’s now locked herself in the bathroom and is refusing to come out, leaving you alone in the cabin and wondering what to do next. Needless to say, this being a text adventure, what you do next is head out of the cabin and explore.

It soon becomes apparent that there are sinister goings on afoot. Your aunt hasn’t bought you here for a simple holiday but for something rather more lethal. If you don’t get away, and quickly, you might well find you won’t be leaving at all.

The only real bugs I discovered with the game seemed to be, ironically enough, right at the start which I would have expected to be the most thoroughly tested part of the game. One of the drawers in the first location contained Aunt Caroline’s clothes yet every attempt to take them met with the game thinking I was referring to Aunt Caroline herself and told me that it only understood me as far as wanting to take Aunt Caroline. Elsewhere, I filled a bucket with water and tried to throw it over an awkward dog, but attempts to throw the bucket just dropped it on the ground. Why was I trying to throw it? Well… it seemed like a good idea at the time. In a puzzle which involved me getting past a troublesome canine, throwing a bucket of water over it seemed like a viable solution. Unfortunately not. I also found the bucket quite frustrating in that I couldn’t fill it if there was something (like a pill) lying in the bottom. The game seemed to think the bucket couldn’t be filled if there were items inside it, although as the items only take up a small fraction of the bucket’s total mass I don’t see what the problem would be. Oh, and the pill cannot be eaten because, according to the game, it’s plainly inedible :slight_smile:

Other than that, there was a slight wording problem with the mask in Tyrone’s hut which, when I covered it with one item, I was informed was actually covered with some wax. (Apparently it’s possible to cover the mask with wax, but this is something I only discovered after first covering it with another item and seeing wax mentioned in the mask’s description.)

While not a bug as such, some of the default Inform responses to certain commands were a little unusual. Trying to take a drawer out the chest of drawers told me the drawer in question was too heavy which struck me as odd. Either the drawers here are unusually heavy or I’m playing someone who is remarkably weak, but who, at other times, can happily carry around a burlap sack full of items, a suitcase full of items and half a dozen other items in her arms. Not to mention being able to climb through a window while loaded with all this assembled baggage.

Gargoyle, in which I started playing the game, also ran into a problem with one of the suitcases in the closet, crashing on me with an error message when I tried to pick it up. A quick switch to the standard Glulx interpreter fixed this and the game ran smoothly afterwards.

A further annoyance, though not a bug in the strict sense, is the game’s use of an inventory carrying limit. Never a favourite of mine as it always strikes me as an attempt to introduce a realism aspect into a game but never quite manages to succeed. Here it’s as flawed as ever. My character seems perfectly capable of carrying X amount of items (including a burlap sack (itself filled with a dozen items), a suitcase (which likewise can be filled with many items) and several other items [quite how she’s capable of carrying so many items, unless she has more than the usual number of arms, is in itself baffling]), yet attempts to pick up anything else, even something remarkably small and light, is considered too much for her to handle. Surely small items could be secreted away in a pocket or just popped inside another item to allow me to carry them? There’s the added problem that it’s possible to carry items on top of other items (the shovel, in particular, can be used to carry items) at the same time as carrying a dozen other items. Hardly does wonders for the realism factor.

Fortunately there’s a burlap sack lying conveniently around in which items can be carried, thus removing the item restriction after a while. On the down side, the sack (and several other items) only show up after a certain point in the game so I spent a while backtracking and retracing my steps before finding them. A slight problem with the sack is that it’s perfectly possible to fill the kettle with water, put it in the sack, carry it around like that for a while, and then retrieve it from the sack… all without any of the water spilling out! Damn clever kettle.

After all that, trying to impose something like an item carrying limit is just never going to work out very well.

At times the games is a pain for making you specify exactly what you need to do; even though it understands you perfectly, it will frequently make you jump through hoops just to achieve something relatively simple. There was a bucket I decided to stand on but the game wouldn’t let me at first because it was the wrong way up, thus requiring me to turn the bucket over first. Why? It understood what I was trying to do, the item in question was there – was it really necessary to make me turn the bucket over before I could stand on it?

Items mentioned in room descriptions are covered pretty well as far as examining them is concerned, although quite a few slipped through the net, and several commands which I really thought would be covered – climbing the trees being one of them – didn’t work. In fact, the game is often quite particular about what it will and won’t accept. Sometimes, the DIG command suffices for digging, whereas at other times you need to specify where you want to dig. It’s also possible to DIG in certain items (a suitcase and a figurine being two I tried), yet the response given is the same as if you had dug in the ground.

Inconvenient and odd restrictions
A good deal of “The Last Resort” would be easier – probably too easy – if the player wasn’t held back by any number of strange restrictions that seem to be in place not to make the game more realistic or to add depth but to force the player into playing the game the way the author intended. Aside from the previously mentioned item carrying restriction, there are a good number that prevent the player carrying out perfectly logical actions and the reasons given for preventing you doing this are weak to say the least.

There’s a white dress in your and your aunt’s cabin that you’re prevented from taking out of the cabin because it might get muddy and your aunt will be cross. Strangely enough, even after you’ve discovered the truth of the situation and your aunt’s involvement in it – namely, that she’s planning to have you killed – the game still refuses to let you take the dress out of the cabin due to the possibility of it getting muddy and your aunt becoming cross over it. In light of what had happened, I would have thought you’d have other concerns than the possible muddying of a dress. I’d also question the common sense of anyone who hangs around like the player in this game does when she knows there are people planning to kill her. Wouldn’t she have simply ran at the first opportunity and not looked back?

I was also surprised, and a little frustrated, by the squeamishness of the player who, despite witnessing a murder, seeing a ghost, being attacked by a magical floating dagger and believing her own life is in danger, is too timid to pick up a dead animal or kill a spider. She’s also stopped from taking action against one of the people planning to kill her because “he’s a man of God”. Violence against other obstacles is prevented as well, generally with a comment that there’s probably a better way to do such and such without resorting to violence. I’m guessing the reason for this non-violence stance is to force the player to solve certain puzzles the way the author intended them to be solved, but it’s kind of annoying when you’re facing death if you don’t take some kind of action and get told that you can’t physically attack someone or break something open because the game would prefer you handled it another way. Elsewhere, the game won’t let me search someone’s cabin while he’s present because it would not be polite… even though he’s just confessed to being part of a conspiracy to murder me. Please, if you’re going to stop the player taking action, at least come up with a better reason for it than this.

Getting stuck
There are no hints available immediately, only via a password which can be obtained upon request from the author as an attempt to discourage people from seeking help the first time they get stuck. I can’t say I’m altogether fond of such an idea; given the choice between e-mailing the author (who might not be at the same e-mail address whenever it is you get around to playing the game, which could well be years after it was first released) and posting a request for help on RGIF or hunting around the internet for a walkthrough, I suspect most people would do one of the latter two options first. Still, on the positive side of things it did make me try harder to solve some puzzles that I would otherwise have resorted to the hints to get past if they had been available at the time.

A good deal of the puzzles seem to fall into the “solving them because they’re there, not because it makes any sense to solve them” category. (If that is a category. If not, I’ve just made it up.) Take, for instance, the spider in the closet. Now in normal circumstances, if I found a spider in a closet I’d either a) kill it or b) ignore it. Here I need to deal with it for no other reason than it’s in the game and dealing with it is crucial in order to make progress – dealing with the spider allows another puzzle elsewhere to be solved, this one in turn leading to the solving of another puzzle. The thing is that one of those puzzles – getting the stove to work – struck me as odd because in real life surely there’d be other means to heat things in the cabins. If this was a game set in the Dark Ages and the only source of heat for miles around was in a specific location, I could understand it. But here, in a modern setting, it just seems a little hard to believe that the only way of heating something is with the stove. Another unnecessary restriction imposed on the game to force people into solving the puzzle in a certain way?

The same applies for similar puzzles with a dead animal, a dog and countless items that seem to be lying around for no real reason other than they’re required to finish the game. There’s no real reason why the main character would give these things a second glance, particularly as she’s in very real danger of getting killed at any moment, yet figuring out what to do with them is essential to completing the game. Then again, maybe I should feel grateful for all these items lying conveniently around just waiting for me to come along and find a use for them. Without them, the game would be impossible to finish.

Other puzzles might seem to have a fairly straightforward solution, but, more often than not, the solution is actually a lot more complicated. One location has me trying to take one item with a magical dagger continually flying at my face every time I make a move. My initial plan was to put something on the dagger to prevent it attacking me, yet the game wouldn’t let me and instead told me there wouldn’t be anything gained by doing that. (I’d have disagreed as weighing the dagger down so it couldn’t move would have seemed like a sensible solution to the problem. It certainly made more sense than the solution used.) More than one way to solve puzzles is an idea I’m fond of as it means that if I can’t figure out the main way to do the puzzle, there might well be another way of doing it that I can try instead. As it happened, the solution was one I doubt I would have ever thought to try. The item I needed to solve the puzzle was one I already had in my hands, so requiring me to HOLD it up would have seemed unnecessary had I not been advised by the hints to try this.

“The Last Resort” comes with a nice PDF map which certainly helped me figure out the general layout of the game. A good thing, too, as the layout is sometimes confusing with southwest from one location leading me to another location and north being required to return me to the first one. On top of that are the cabins which have rooms that, on a normal map, would actually be inside other cabins. It took a while to familiarise myself with the general layout and the map helped me get my bearings.

At times, the game can be very unfair indeed. I didn’t find several key items to begin with as I’d neglected to enter some of the cabins and only became aware of these items’ existence when someone mentioned it on RGIF; unfortunately, by this time the occupant of the cabin had returned and I wasn’t able to enter, thus screwing the game up for me. Equally unfairly, no indication that the game has been rendered unfinishable is given so I played for quite a bit further before realising I wasn’t making any progress because there was no way to make progress.

As it happens, some parts of the game runs on a series of timed events. Certain locations are only accessible at certain times and if you miss your window of opportunity, you’ve blown it. Even more unfair, the game requires you to perform three separate tasks while a timed event is running, though it wasn’t until a lot later in the game that I realised anything needed doing during the course of the event. I’d also question whether anyone who ever played the game managed to figure this out on their first play through, or only realised the timer was relevant and all the things that needed doing before it was over, by first dying a few times. Solving a puzzle by dying several times doesn’t really count as solving it in my book. Getting hold of the items I’d missed required me to restart the game and play a sizeable portion of it again to reach the stage I’d been at before.

It’s also possible to put the game into an unfinishable position by scaring away the crow, though here at least the game does warn you immediately afterwards that you might have made a mistake. Going back to previous saved game positions helped on a few occasions, but quite often I’d discover too late that I’d missed something, or neglected to do something by a certain time. Before I tied up all these loose ends, I think I’d restarted the game half a dozen times or more.

Other examples of unfairness? Sometimes SEARCH and EXAMINE mean the same thing. Other times they produce different responses; something I only discovered later on in the game and which then required me heading back through every location in the game and start SEARCHing things that I’d previously only EXAMINEd. I also felt that the amount of items that needed to be looked behind or under was a little unfair. Unfortunately, the unfairness doesn’t stop there. When I opened the drawers on one of the bureaus (there was one in every cabin and most were identical), there was nothing to indicate there was anything inside and examining them revealed nothing more than a description of the drawer itself. Yet when I LOOKed IN the drawers, I found an item in there. Surely the game should have told me that there were items inside an open drawer when I first opened it or when I examined it without me needing to specify that I was looking in it as well. Makes me wonder how many other items I missed because I didn’t LOOK for them, only EXAMINEd and SEARCHed. Or are there other items only available via STUDYing certain things?

The dreaded guess the verb hampers some of the puzzles. The one involving gaining the aid of the crow was particularly bad and was something I’d never have considered if the hints hadn’t suggested it. (Yes, I weakened in the end and e-mailed the author to ask for the password for the hints.) The most annoying thing about this puzzle, and several others in the game actually, was that I had the item I needed to solve the puzzle in question but it never would have occurred to me to try the required command.

But despite all the negative aspects of the game, there’s a lot to like about it as well. A good deal of the puzzles, even the ones I’d label as ‘unfair’, can generally be figured out if you think about them. Restarting the entire game and keying in commands again when you realise you’ve missed something vital is a pain, but there’s a genuine sense of achievement when you finally get the better of a puzzle you’ve been stuck on for a while. The puzzles are generally arranged in a sensible fashion in that most of them can be completed in any order and if you can’t figure one out, you can always go away and do something else in the meantime. Games that hit me with one puzzle after another and don’t let me do anything else until each one is solved don’t tend to go down very well with me. Thankfully this is one problem “The Last Resort” doesn’t suffer from. This general relaxed attitude towards the puzzle solving also works well because there are times when, having discovered a new item or some previously hidden piece of information you didn’t have access to before, you hit upon the solution to a puzzle you couldn’t get the better of first time around.

Of course, there are problems with having this kind of freedom towards puzzle solving in that you can quite often end up reaching a puzzle at a stage in the game when it’s not possible to solve it. Naturally you aren’t aware of this and much time can be wasted trying to solve a puzzle when in fact your chances of solving it at that stage are zero. There are other times when you have the means to solve the puzzle (as with the crow or the dagger) but the precise wording is something you’re never likely to try.

But… but I liked it. I kept on struggling with “The Last Resort” long after I’d have given up with most other games and the fact that I went through it to the bitter end, even after being forced to restart several times due to missing key items and running out of time on other occasions, has to be a point in the game’s favour. So yes, a game I’d recommend, but only to people who aren’t put off by decidedly unfair puzzles and who have lots and lots of patience.

6 out of 10