TextCraft: Alpha Island - Fabrizio Polo

I tried sending mail to the author’s email address listed on the comp site, but it bounced, so I’m posting my bug report here… I hope he reads this forum. (Does anyone know how else to get ahold of Fabrizio Polo?)

When I run TextCraft on my Ubuntu laptop with 4k display, the window is small and the font is teeny tiny! Almost unreadable, and definitely not something I’d want to try playing for 2 hours. And I don’t see any controls for resizing or zooming. I dunno if this is fixable before the comp ends but I thought I’d let you know. Let me know if you need any more information.

I think his name on here is fizzyp

Thanks for the heads up. I’ll see what I can do.

I’m on old Ubuntu Linux (14.04), and I get this error when I try to launch this (either by “./AlphaIsland-v1-03.jar” or “java -jar AlphaIsland-v1-03.jar”):

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/fabriziopolo/timecraft/TextCraft : Unsupported major.minor version 52.0

From Google, I think this means that my JRE isn’t new enough (I have openjdk-7, and I think this means I need openjdk-8)? Oh well.

Yes Java 8 is required. Although you just need the JRE (runtime environment) not the JDK (development kit). Sorry for the difficulties. Next year I’m going to make my submission a web game running on my own server. That will really simplify things.

Email fixed! Thanks for persisting and sending me the bug report anyway.

A new version of “TextCraft: Alpha Island” has been uploaded containing an alternate, large font version for people with high res displays.

Tried again on an Ubuntu 16.04 installation.

This one had Java 9 and Java 8. TextCraft didn’t work on 9 but did on 8. Tried both 1.03 and 1.04.

I have the logfiles from 9 if anyone is interested, but it died with a SIGSEGV, which seems unlikely to be TextCraft’s fault.

To use Java 8, I temporarily switched the system Java; I didn’t find a way to just invoke Java 8 for a single application.

[code]# list available Java versions
sudo update-java-alternatives -l

temporarily switch to Java 8

sudo update-java-alternatives -s java-1.8.0-openjdk-amd64[/code]

Thanks for trying it! I targeted Java 8. I’m quite surprised it doesn’t work in Java 9. Possibly it’s a bug in their Swing implementation?
I’m itching for some feedback. Please let me know what you think (don’t spare the harsh critcism). Also, don’t forget to visit the companion wiki at fabriziopolo.com/textcraft/wiki.

No problems in terms of getting the game running on a Mac/OSX

I have reviewed the game here: blog.templaro.com/review-textcraft-alpha-island/

  • Jack

Thank you for the excellent feedback!