Stuck on Redux in Puny Jam

I’m stuck on this game. I’ve completed almost everything, but there’s one area I’m stuck on.

The area is accessible early on; it’s the CPU area.

I know what I need to do, I just don’t know how to do it. I even used all the hints and textdumped the strings and I still can’t figure it out.

I have to find an EXX instruction and put it in the slot. But where is it? I already have the programming manual. I tried SEARCH CODE and SEARCH SPHERES and TAKE SPHERES and LOOK AT SPHERES etc. Where could it be?


This is the hardest area of the whole game. At one point, I had solved it, then on a replay I couldn’t remember how I solved it. You’re on the right track. To find the EXX instruction, read the programming manual from the lounge room.


I have read it, but I can’t put it in the slot. It mentions the need to swap hidden and visible registers, but I’m not sure how to do that. I’ve also just tried typing EXX and SAY EXX.

1 Like

I’m going by my transcript from the beta version, so I can’t guarantee that this will work. I’ll play the final version shortly.

You first need to DECRYPT CODE with the cipher key in the RAM space. You can then READ CODE.

1 Like

Thank you, I was able to solve it. Your hints helped, and I looked more closely. I realized that in the sentence:

Your surroundings are structured RAM carved into silicon walls, with an arrangement of electrons resembling data. Some of it looks organised into code. that the RAM, DATA, and CODE are all separate objects that give separate responses when examined.

1 Like

Unfortunately, you only have ten moves in each area before you are automatically transported back to the lawn. This sort of discourages examination, but examination is essential to find some hidden things.

You can expect to spend a lot of time flipping backwards and forwards between the three different areas. I think the first two (possibly all three) areas are predictable and from then on, it seems to be random, but I need to experiment with this a bit more to confirm or deny that observation.

The good news is that once you’ve solved the puzzles in one area (as indicated by the score), then that enables a shortcut in the first room of that area to get out of that area. In this way, you can quickly transport from the starship bridge to the RAM space to the greenhouse and back to the starship bridge. Just mentioning it here, in case anyone finds this useful.

1 Like

I’m stuck at making coffee. I have the ground beans and the moka pot, but I can neither find the rest of the note nor do I find a way to cook coffee. Help!

There’s another room in the house. I missed it my first time too, so maybe that’s the problem. A lot of new hardware in there.

Besides kitchen and lounge?
I looked hard but did not find another room…

1 Like

Nope, I was referring to the kitchen.
I can’t remember where and if there is a second part of the note. I’m trying to replicate it now but the time limits render all too difficult.
Did you use the grinder in the kitchen?


For me the coffee was just make coffee once I had done pulp cherries and roast beans in the utility room and grind beans in the kitchen. I had trouble because I was trying to find something to do with the pot and the stove but no…

1 Like

Thanks, make coffee it was! :smile:

It was the same for me.

1 Like