Stuck on Down, the Serpent and the Sun

Tried this one a bit. Can’t really get anywhere at all.

[spoiler]I get swallowed by the serpent and the blade disappears. I’m guessing that’s intentional?

Then there’s a skull that I can talk to but none of my ASK attempts get anything,
Some tissue I could get through if I had a weapon,
and some glass where ditto.

Tried a bunch of weird stuff like cutting off a quill of the serpent or throwing the sword in the serpent and nothing seems to help.[/spoiler]

The conversation system is very limited, I’m afraid, due to my inexperience with coding. [spoiler]The only way to talk to the skeleton is “ASK skeleton ABOUT something.”

(And now that I look back at the source code, I see an obvious error I made distinguishing the skull from the skeleton, which is why the skull won’t reply but the skeleton will. Sorry about that!)[/spoiler]

An explicit solution to the conversation puzzle:

ASK skeleton ABOUT bridge

Regarding the blade:

The blade does clatter away when the serpent swallows you. There’s no way to keep it. This is intentional.

Well, I got further down, but I’m still stuck.

I’m going to guess I need a light source to get a tooth from the maw so I can start opening passages, but I can’t get anything out of Sol to help.

Search a cocoon for a rib. Light it with the sun.

That’s correct. Most things in this game are not takeable, but I tried to give descriptions to everything, so the things that are takeable will be apparent when you examine them.

Just in case anyone needs it, here’s a walkthrough for the game: … rough.html