Stuck in Rio Alto

I can’t progress beyond this point in the game:

What’s going on is I investigate Dr. Schwartz’s office and look at his desk. Then the whole screen gets blurry like this and none of the combinations I’ve tried move the story along.

The authors assured me that you can’t get stuck in this game. Am I missing something? Does anyone have any suggestions?

1 Like

Hi, it’s indeed not a bug as I told you. I’ll try to explain myself: Luis suffers a mental breakdown, he’s semi-unconscious so can’t go anywhere or use any item he may be carrying. So only player option is to review Luis’ thoughts, specifically those two that led him to this situation

I tried to hint it somehow in the text that triggers this event, I understand the logic I follow here may be questionable though.

Ambrosio,

That helped me get quite a bit further. In fact, I have entered the grove house, recovered the rope ladder and the revolver, entered the cave, grabbed the candle, compared it to the one in the house, asked Felisa about it (she was silent), showed it to Juana who said we should go and get a confession.

But I don’t know how to do that. I can’t get Juana to come with me, and, on my own, none of my thoughts work. Any tips?

I can’t get Juana to come with me, and, on my own, none of my thoughts work

That part was actually bugged, however the build I uploaded yesterday should correct it, present her the candle again. Hope the savegame still works.

1 Like

It worked! I just need a little hint on the last part.

I got her to come to the house, and got them to talk to each other, but now it says I need evidence. I thought of combining the sorcery book with the cupboard that has mushrooms, but I gave the sorcery book away. So I’m not sure how else to get evidence!

Edit: Well, I made progress. I got the doctor drunk, and now I have a sense of guilt. But the priest won’t let me confess it and it doesn’t affect the two women.

Edit: The priest is in the confessional, and I went to talk to him, but I can’t give him the guilty feeling. I did open the moneybox, though, trying to figure out what to do.

Edit:My exploration is at 56%.

Edit: Diego says to talk to Felisa about the guilt. But she doesn’t accept that topic!

I think you are missing Alberto’s disappearance, as the priest has some important clues to give you

I’m stuck in the same room, different time. After getting past the screenshotted section, the only option in the office is Continue, which locks me into what looks like an ending, with all options darkened instead of blurred. I can go to other locations, but I can’t do what I need in this one. Is this another situation where I actually can do something?

1 Like

That’s an ending indeed

I’ve gotten a few endings, but I haven’t gotten past about 50% exploration on any playthrough, so I’m clearly missing a lot of things. After doing everything mathbrush mentions as well as getting Alberto’s letter from the priest, as far as I can tell the only thing to do is to go with Juana to see Felisa. At that point, the only outcomes I’ve managed to find are:

  1. Show the letter to Juana, who kills Felisa and goes to jail

  2. Show the letter to Felisa while carrying the loaded gun; she attacks me, I shoot her and go to jail

  3. Show the letter to Felisa without the loaded gun; she stabs me and then poisons me so I can’t recover

Nothing other than that item seems to do anything significant in that scene. What am I missing/overlooking?

1 Like

How did you get the letter?

In the church, drag the empty basin of holy water onto the priest. He’ll give you a bottle to fill with water, which you can get from the well by reattaching the rope to the bucket. Once you give the bottle back to him, drag the confessional onto the priest or vice versa and he’ll go in there. Then ask him about Alberto’s disappearance again.

1 Like

There’s two important pieces you should research further: sorcery book and guilty feeling

Also note that Felisa’s character may become friendlier or hostile towards Luis, I suggest going the friendly route

Thanks!

I’ve posted a review of the game on my blog here.