Struggling with (enchant?page) macro

Hi! Can anyone help me with the enchant?page macro?

I’m trying to change the background color for an entire page of the game — as in not just behind text — but it only works for the section of the page that is initially visible. As soon as you scroll down, the background color cuts and turns to white.

This is what my code for the background color looks like:

(enchant:?page,(bg:(gradient: 179, 0,#000000,0.0716,#000000,1,#063503)))

I’m using Harlowe 3.2.3 on Twine 2. How do I fix this?


with your code, it works perfect with a new story, so I guess may be you did something in your css stylesheet

I’ve made no changes to the stylesheet. could it be something else?

Could you supply an example of the contents of that specific Passage, as well as any header and/or footer tagged Passages you may have.

[additional] If the (enchant: ?Page) macro isn’t being called within the above mentioned Passages, then where are you calling it from?

Are you using JavaScript to alter the contents of the Page?

Which Web-browser (brand / version / edition) are you viewing that output on, and what Operating System are you running that web-browser on?

I’m running the game on Google Chrome 94.0.4606.81 64 bits, Windows 10 Home. No JavaScript, no header or footer tagged passages. Macro is being called at the beginning of the passage itself — it’s the first line of code, before any displayed text. So the content looks something like this:

(enchant:?page,(bg:(gradient: 179, 0,#000000,0.0716,#000000,1,#063503)))

Example text

(text-colour:#e6e6e6)[Example text] (text-colour:#d4d4d4)[Example text] 

(link: "(text-colour:#b31919)[Example link?]")[(goto:"example")]

I’ve tried removing the text-colour bits and the link, to see if that’s the problem, and it doesn’t make any difference. I’ve even tried it with a whole page of just line breaks; if it’s long enough to allow scrolling, the background color cuts to white. Only way to get the background color working perfectly is to keep the text short enough that the scrollbar isn’t available.

It appears you may of found a bug in the new v3.2.3 release of Harlowe.

I create two test-cases, each using a different version of Harlowe 3.x. The v3.2.2 based test case works correctly, where as the v3.2.3 based one does not.

1 Like

Oof. Bad luck for me I guess. Thanks!