strange problem with action..

ok i got the name of a thing tp change but the wierd thin g is… if i do this:

After putting [something] on [something]:
say “something”;
now the printed name of [something] is “[something]”

that works find… but when i switch on to in it doesnt work?
this is what i put in:

After putting the special powder in the tea cup:
say “the water in the tea cup turned brown”;
now the printed name of the water is “mysterious liquid”.
… this n is my error i keep getting -

‘After putting the special powder in the tea cup’ , which seems to introduce a rule taking effect only if the action is ‘putting the special powder in the water’. But that did not make sense as a description of an action. I am unable to place this rule into any rulebook.

so on works but inside doesnt??? thats wierd…
putting something inside something else is an action just like putting something on something is?
just saying i dont know what wrong?
[the water is gonna be put inside the tea cup thats why theres water in there]

Make sure that you actually have items called “special powder”, “tea cup”, and “water”, spelled exactly that way, and that the tea cup is defined as a container.

I don’t have Inform in front of me, but if I recall correctly, the internal action name for “putting it in” is “inserting [something] into [something]” (could be “in” instead of “into”). To explain: Inform has a lot of synonyms that the player can use to refer to various actions, but you the author have to refer to actions by their one true name in your code. There are two ways of figuring out an action’s true name:

  1. when you’re playing your game, enter the command “actions” and then enter whatever action you want to know about (so in this case, you’d type “put powder in cup”); you’ll see stuff in parentheses about what action Inform thinks you want to invoke.
  2. or you can look them up in the Actions tab of the Index, where every synonym is listed (including the ones you’ve defined yourself, if you’ve run your code successfully since then) with a link to the true action it refers to.

thanks i got it to work. i used the action listing thing and it said inserting into the tea cup. so i tried that and it worked.

thanks sorry i guess i did have a confusion in there sorry i got confused i sorta changed something in the script… before i posted it omnn here i mean