Stian's IFComp 2019 Reviews

Finally, IFComp 2019 is here! And with apparently a record number of entries.

This is the first IFComp since I started playing IF for real, so I’m awfully excited. My plan is to play through every single game, in the order of my personalised shuffle, until I run out of time. I will write a review of every parser game I play in this thread, and possibly of non-parser games if they intrigue me.

I’ll also upload my playthrough transcript for all games that allow it.


Under the Sea: The Treasure of the Santa Tortosa
by Heike Borchers

A friendly and fun underwater game with a good spirit, which should be as suitable for children as it was for me. For the half-seasoned adventurer I am it took about 15-20 minutes to complete without hints. The puzzles were all very logical, though the syntax was at times a bit strict. “napoleon, push planks” didn’t work, while “ask napoleon to push planks” did.

I should say that the game wasn’t at all what I had expected after reading the blurb. Especially the family friendliness was unexpected. The mention of scaly friends might have been a hint though.

transcript.txt (34.6 KB)


Extreme Omnivore: Text Edition
An Exploration Game by Hazel Gold

A rather cute answer to the oppositely dark Eat Me, Extreme Omnivore is an exploratory game without puzzles. If you’ve read the blurb, it’s no spoiler to say that you simply go around an apartment trying to smell and eat whatever you can find. The first version published at IFComp, however, hasn’t really even arrived at the beta stage. Descriptions are usually left at their default, synonyms aren’t implemented, and I even encountered a Run-time problem error message when I tried eating the shampoo. With a bit of polish, I’m sure Extreme Omnivore can provide 15 minutes of fun entertainment for even the hungriest of adventurers.

transcript.txt (23.9 KB)

1 Like

Hard Puzzle 4: The Ballad of Bob and Cheryl
An Interactive Fiction by Ade McT

So far: Wow!

(I’ve only played for about 20 minutes, and need to call it a night. The review will be updated)

(update as follows:)

Two hours of playing has passed and I haven’t been able to finish Hard Puzzle 4, so I will leave it for now. Still: Wow!

I’m reasonable sure it should be possible to finish it in two hours, it’s just… well… hard. Perhaps it helps having played its three prequels. Perhaps not. In any case, I will definitely play them all once IFComp is over. As for the fourth, it’s pretty mindblowing. I love it. Very much. I can’t really say much more about it without spoiling anything, but if you like hard puzzles, you’ll love this too.

(incomplete) transcript.txt (178.7 KB)

1 Like

A Spirited Game by Steph Cherrywell

This is a solid, mostly well-polished game with lovely humour and great puzzles. Not mind-blowing, just very good. It took me just under two hours to finish, though a lot of that time I was stuck from consistently trying the wrong preposition. In the end I found it was rather perfectly balanced, integrating a lovely and fun story with a decent set of rather original puzzles. The flow and timing of Zozzled is particularly impressive, making it clear that this is the work of an experienced author. Of Steph’s earlier games, I have only played Brain Guzzlers from Beyond! which I found too easy, making it more of a story than a game. Zozzled, on the other hand, manages to combine story and game as well as any work of IF I have played. I’m sure it will be featured on many lists of recommended IF in the years to come.

transcript.txt (193.5 KB)

Here are some typos and bugs and suggestions to the author (contains spoilers)
  • There is a typo in the note on the model. It says “subhman”, rather than “subhuman”.
  • The pool could use some restrictions. I was able to put a lot of stuff in the pool, including the dog, without it being affected, not even after having been frozen.
  • The place I got stuck was trying to put the stocking on rather than in the cart. It would be nice if “on” works too.
  • The ending doesn’t end the game by itself. Rather, I’m stuck in choice mode where no choices work except “quit” (at least from what I tried).

Meeting Robb Sherwin
An Interactive Fiction by Jizaboz

Slices-of-life tend not to be my thing in IF, mostly because they don’t easily lend themselves to interesting puzzles. This particular work of IF was no exception and literally spelled out most of the actions the player should take to advance the story. As such, a parser game may not be the best suited way of conveying the author’s anecdote. It’s also quite under-implemented, with little room for exploration. The impression I get is that of someone’s first attempt at creating a parser IF and simply implementing an episode of their life for the sake of it. This is of course an applaudable thing to do, but unfortunately doesn’t always make for a good game. Those who love a slice-of-life might enjoy the story though.

transcript.txt (23.7 KB)

Thanks for your review! Those bugs should be fixed now.

1 Like

by Victor Gijsbers

Wow, that escalated quickly. And then some!

Turandot was actually a choice-IF I could enjoy, and not just because it was really funny. It is very different from a CYOA; here, the choices are as one part of a dialogue; no waiting, no clicking around, just a steady progress, always forward, and always hilarious. Great stuff!


Island in the Storm
by JSMaika

Island in the Storm feels like a classic game in a brand new interpreter. Classic, not only in the type of story and puzzles, but also in the sense that a lot of the verbs and shortcuts we take for granted are absent. There is no such verb as “move”, and pronouns are generally not understood. As the engine behind it is still in early development, such things are not entirely unexpected and may change in the future. I also met a few bugs during my play, including one which I believe has prevented me from completing the game (I’m not able to empty kaur from the cup).

That said, both the game and the interpreter were pleasant to experience.

The interpreter has quite a modern feel to it, with an enjoyable layout and style featuring differently coloured frames around the text. For being in early development, the look of it certainly gives a sense of maturity. Some aspects of the engine feels still a bit rough around the edges though, especially the default responses (such as “The passed out villagers doesn’t sell a drink in the villagers’ cups.”)

The game felt rather old-school in many ways: You can die, and there is no “undo”. It’s not strictly necessary to map it, but it does help with finding your way back. There are dark caves and number puzzles and beaches and keys.

Island in the Storm was not at all as hard as the old games I have tried, however, which was much appreciated. None of the puzzles are absurd or outlandish, but I did have to think and search around for a bit. If it weren’t for the bug, I think I would have been able to get through it in around two hours. I would definitely recommend this game after a bit of polish and bugfixing.

Map of the island (may contain spoilers)

by Robb Sherwin

This is essentially a puzzleless IF and reads as a cross between Jack Kerouac and Quentin Tarantino if they were making a Sci-Fi B-movie together, very late at night. Or something like that. The main thing Enceladus has going for it is its humour, crass and absurd and with lots of attitude. As a work of IF, Enceladus wasn’t really my thing, but I would like to acknowledge that it’s quite well written, and I’m sure many will love it.

transcript.txt (66 KB)


Skies Above
A game by Arthur DiBianca

I was very excited to see a new game by Arthur DiBianca in the ballot, and now I’ve played it obsessively for five hours before deciding that enough is enough. Among Arthur’s previous games, The Wand is one of my absolute favourite works of IF, although I felt that last year’s The Temple of Shorgil was a bit too mechanical for my tastes.

One thing I have come to expect from his games is an excellent implementation, and Skies Above is truly a masterpiece in that regard. However, playing it gets very tedious very quickly. The blurb describes the actions as “minigames”, but I’d much rather liken it to those actions in those mobile games that are so horribly meaningless and horribly addictive. Click the cow ten times to milk it. Click the trees to harvest their fruit. Click the garage to upgrade your vehicle. And suddenly yet an afternoon has passed.

I have no idea how I’m going to judge this game. On one hand, I have played and ended up with an aversion to such mobile games, and will probably never want to play Skies Above again. On the other hand, it’s implemented as a perfect parser game! It’s a crazy thing to do, and such an impressive feat! And just as addictive… so be careful.


The Four Eccentrics
An Interactive Fiction by Mild Cat Bean

Surrealism and dreamscapes is something that interactive fiction, a medium where anything that can be expressed in words can be experienced, is particularly suited for. In The Four Eccentrics, you literally dive right into a very peculiar dream. Already the opening landscape, a park filled with globes containing other dreams, sparks the imagination in ways that visual media cannot. From there, the game opens up to a fabulous world of wonders and strangeness.

In a dreamscape such as this, there’s always a danger that navigation becomes an issue of some difficulty; if diamonds are food and words are currency, how do you even begin to guess the verb? The Four Eccentrics handles this very well, and although you can do several unorthodox things in its dream, most of them come rather natural.

In a way, the basics of the story, your mission in the game, is an archetypical one, which makes it easier to find your way forward and finally reach the conclusion. I liked this contrast. Two other surrealistic games I have enjoyed are Shade and Sub Rosa. The Four Eccentrics is very different from either of these, though somewhat closer to the latter. In particular, more things are clear, much thanks to the world being populated by several NPCs to assist you on your way.

To be honest, there is room for plenty of polish for The Four Eccentrics to become a truly enjoyable experience; I’ve seen descriptions coming before they should and others that linger on until the end, objects that are both there and not (but not in a dreamy way), and at least one case of serious disambiguation problems. Still, it was a very enjoyable game, and it certainly has the potential of becoming a classic.

transcript.txt (276.2 KB)

Bugs and notes for the author (contains spoilers)

Even after removing the weevil, it is part of the stain’s description:

>x stain
A large weevil of some sort seems to have lodged itself deep into her brain. How appalling!

>take weevil
You can't see any such thing.

The smock may get mentioned before the player discovers it:

The wavering hands on your smock's clock face snap into place, indicating it is just after two o'clock.

At the same time a little button, shaped like a sunface, pops out with a click, just below the hands.

Dusty Afternoon
A drab and dusty plaza. Anonymous buildings sag together like sleeping beasts. Lobed patches of sunlight drape over the stone like blankets. The windows are all shuttered, the doors sealed, the awnings furled, and the trees at each corner sag their leaves as if in torpor. A drowsy street heads east to the market.

A single sequin blazes up from the ground to catch your eye, perhaps an indication that this place is sometimes more lively.

  Knowledge (labyrinth secret)

  a bronze book (a book of fairy tales, locked)
  an oxblood book (a volume of horror stories)
  a gamboge book (an architectural catalog)
  a zaffre book (an alchemical encyclopedia)
  an ecru book (a technical manual)

  a sequin
  a medical kit (open)
    a cotton bandage
    a scalpel
    a vial

After giving away the left arm, it can be taken/worn, but doesn’t end up in the inventory:

>x left arm
You see nothing special about the left arm.
>take it
(somewhat clumsily)
There is no reply.
>wear it
(somewhat clumsily)
(first taking the left arm)
(somewhat clumsily)

  Knowledge (musical practice)
  Knowledge (labyrinth secret)
  a Gown Chair
  a Bicycle Suit with Wheels and Shelves
  a West Vest
  a Clock Smock (being worn)
  a bowler hat (being worn)
  your head (being worn)
  a right arm (being worn)
  a right leg (being worn)
  a left leg (being worn)

If the player brings the Expert to the swamp while the other woman is there, the parser thinks the player means the Expert when referring to “woman”:

Mangrove Swamp
The heavy canopy closes in above you as you leave the city behind. You steer between interlocking stands of trees propped up on roots like countless fingers.
Sitting on the edge of a large clump of trees where several roots make a natural hammock, a woman is fidgeting with a broken axe handle.
>x woman
(the Ancient Expert)
Her withered body lies limp in your arms. She has gone completely still.

The parser doesn’t allow putting bandage on the clapper, but the game will do exactly that if trying to play the bell:

>put bandage on clapper
What? Don't be absurd! That's obviously not a serviceable limb.

>put bandage on bell
What? Don't be absurd! That's obviously not a serviceable limb.

>play bell
Leaning in carefully to avoid triggering the bell, you swaddle the clapper in cotton gauze, until the bell is completely muffled.

Two strange responses:

>ask vendor for poetry
You can't use multiple objects with that verb.

>cut ghoul
You already have that.

A case of unimplemented objects/scenery:

>x woman
On her pillow lies a corona of withered dry leaves, like a halo of mortality.
>x corona
You can't see any such thing.
>x leaves
You can't see any such thing.
>x pillow
You can't see any such thing.

The Untold Story
An Interactive Fiction by Michael Pavano

The Untold Story is somewhat peculiar. With a touch of nature, some wizardry, a bit of classic symbolism and a protagonist dealing with loss, it builds on several familiar tropes, some of which they don’t feel like they belong together at all, not in the way they are mixed here. On top of that, the protagonist is extremely religious (which doesn’t seem to have any bearing on the story as a whole) and several actions are assessed morally out of the blue:

Spoiler here
>bash falcon with shield
(You bash the shield right into the skull of the falcon. The falcon drops the chess piece.)
The bird falls to the ground and dies. You look at your brother's bow struggling with what you've just done. "You did the right thing," You hear a voice say. "It was too violent. It had to be put down." You nod wiping away the tears.
Congratulations! You found a chess piece. 
[Your score has just gone up by five points.]

The main problem, however, is that the game is severely underimplemented and quite bug-ridden. It is functional enough to finish, but I had to resort to parser-aware methods (such as dropping an item in one place in order to pick up another item in another place) to progress, and repeatedly got stuck trying to perform an action that was hinted at being possible but the parser wouldn’t allow.

As a light puzzle driven IF, The Untold Story has it’s good parts too. The setting was rather nice, and many of the descriptions were good. In general I would regard it as a very easy game, as the solutions to most puzzles were rather obviously hinted at. If the game receives a significant update that fixes the implementation issues, I would recommend that the hinting be toned down a bit as well. I’m sure it can be turned into a decent game, but it’s just not there yet.

transcript.txt (191.4 KB)

Bugs and notes for the author (contains spoilers)

After the dwarf drops the chess piece, I should be able to take it with just “take piece”:

>take piece
You can't see any such thing.

>take chess piece

I hadn’t found the bow yet at this point and don’t think I should be informed of its existence like this:

>x door
It's a very large and very heavy door. On the door is a bullseye.
>x bullseye
It's a magic bullseye. It's attached to the door. Perhaps if you shoot the bullseye something with happen.
>shoot bullseye
You have to shoot something with the bow.

The response when I try putting the found pieces on the set doesn’t make sense:

>put rook on set
(Rook on the chess set)
No, only the chess pieces should go on there. It's too precious.
>put pawn on set
(the pawn on the chess set)
No, only the chess pieces should go on there. It's too precious.

There’s a disambiguation problem with the books. I don’t know that the intriguing book can be referred to with “tome” before I have examined it:

>x desk
The desk has a purple tablecloth wrapped over its entire surface. On the desk is an intriguing book.
>x book
(the Untold Story)
The book has very special meaning for you. The title, no longer visible due to the dust covering it's once beautiful cover image is simply, "The Untold Story." A story that will forever remained untold. Your brother desired nothing more than to write a book of his own. Nearly a year ago, he finally began to craft his story...... He never had a chance to finish it.
>x intriguing
You can't see any such thing.
>x intriguing book
You can't see any such thing.

The coin is part of the description after having been put in the wall, but cannot be referred to any more:

>x wall
The coin remains in the wall, but the wall is now closed shut. There will most likely be no getting the Dwarf out of there for awhile.
>x coin
You can't see any such thing.

Many actions that are wrong for various reasons give the response “You can’t see any such thing”, even when that makes no sense:

>x potion
This looks to be a rare and magical potion. The potion is bright red and has a potent smell. It seems to have important qualities that may come in handy on your journey. The only problem is you don't know what it's used for. There must be a way to find out.
>x caterpillar
The caterpillar waits. It looks and stares at you. You're not sure what to make of the creature, but you feel it's fury. You remember playing up in the trees with your brother when you were younger.

>pour potion on caterpillar
You can't see any such thing.

It’s possible to take the indentation:

>take all
small circular indentation: Taken.

Another disambiguation problem is with the bottles. The non-magical bottle should probably have an adjective as well:

>break bottle
Which do you mean, the magical bottle or the bottle?
>the bottle
Which do you mean, the magical bottle or the bottle?

The door to the tower is described as blocking the entrance even after it has been opened:

>open door
You open the large iron door.
From the Cliff you can make out mountains and a river surrounding your forest. It's so beautiful. You would love to travel there if only you had the courage. In the cliff stands the Wizard's Tower. The entrance to the tower is blocked by a door with a peculiar object on it.

The bullseye is described also on the inside with the door closed:


Entrance room
There are some large stairs here. They must lead to the top of the tower.

You can see a large iron door here.

>x door
It's a very large and very heavy door. On the door is a bullseye.

>close door
You close the large iron door.

>x door
It's a very large and very heavy door. On the door is a bullseye.

And lastly, the dwarf can be found in Under the Forest even after he supposedly has locked himself inside the wall.

1 Like

Treasure Hunt in the Amazon
by Kenneth Pedersen and Niels Søndergaard

Treasure Hunt in the Amazon is not a great game by today’s standards. It shows that it was originally crafted in 1985, and I suppose it was a relatively decent game back then. The remake is certainly decently implemented and lets you disable all the elements of time and randomness that made the original difficult to finish on a first playthrough. Without such restrictions, however, the game became surprisingly easy; the map is not big, the verbs don’t have to be guessed, the descriptions are sparse, and an automap makes it easy to navigate. In the end it took about 15 minutes to play through. It was nice to play, but rather as a curiosity – a way to experience a classic from the eighties through the comfort of the present.

An interactive memory by Chris Selmys

I did not play this game to its conclusion nor for a full two hours, but seeing as it as of yet has no other reviews and that the requirements for playing it are rather strict, I thought I should give it a paragraph or two nonetheless.

ALICE BLUE may only run in a Linux terminal, but its general design is more akin to such Twine games where some words in the text are highlighted and can be clicked, which in turn changes bits and pieces of the text. In this case, the game, or the story, seems more abstract than most. You navigate memories and are supposed to be able to enter several rooms throughout it. I’m afraid I very rarely am able to enjoy such IF, but was very impressed with the fact that ALICE BLUE was written as a bash script – a very limited programming language – and really well implemented. For a game in a terminal, it looks very good, and it has nice music too! Chris Selmys: You are crazy and clever!

Something Weird by Marshal Tenner Winter

Clusterflux is truly an ambitious project, and a much larger game than initial appearances would suggest. It’s actually impressively huge, especially considering it’s a one-author game. Described as a “weird mystery”, it’s also right up my alley, and I enjoyed it immensely. It did, however, take me six hours to get through it and I had to consult the walkthrough twice. I think it would be hard for most to finish in under two hours, though the first two hours were just as enjoyable as the rest. Well, perhaps apart from the half-hour I spent banging my head against a specific puzzle.

In general terms, I would like to describe Clusterflux as a modern self-conscious style puzzle IF, where an everyday protagonist enters absurdity as if it were the most natural thing in the world – not too dissimilar to Bill Lindsay’s excellent Bullhockey games.

While the plot is more than solid enough, and its absurdity intriguing, the puzzles are what makes this a great game. They are always clever, but generally not too clever, and solving them provides proper satisfaction. I was planning to stop after two hours, but this is the kind of game I can’t put down until I have finished it.

With a game as big and ambitious as Clusterflux, there will likely be several small bugs persevering even rigorous beta-testing and I did meet a few of these. Still, it is impressive how polished it is, with thorough descriptions for almost everything. The large gallery of autonomous NPCs made certain scenes a bit confusing, but useful conversations are limited by a topic list which made it manageable.

A tremendous amount of work has gone into this game and I’m immensely grateful for it. I will definitely try Marshal’s earlier games once I have recuperated from this IFComp…

transcript.txt (528.1 KB)

Bugs and notes for the author (contains spoilers)
  • I was stuck for a very long time trying to go east from Top of Stairway and/or figuring out what’s with the music. I had gotten the hint to push the amp, but it never occurred to me to push it south and east.
  • Later, I was stuck with the basement door and wondering what to do with the podium. The description of the door mentions a battering ram, but rather hints that even that wouldn’t help.
  • When in West of House I probably mean the large bush and not Gef when referring to “bush”.
  • “an a rip in time and space” can be picked up.
  • When referring to “house” I probably don’t mean the scarf.
  • When in the cell (and also outside it) I probably don’t mean the photograph when referring to “man”
  • Smells are referred to in the descriptions but not implemented for Spacious Living Room, Shed, and Unclean Kitchen.
  • In the end message, I’m told I encountered 18 out of 16 people.

Remedial Witchcraft
A brewing disaster by dgtziea

Remedial Witchcraft is a really lovely game with spells and wands and potions and a cat. As a puzzler, it is an easy one, yes, but the puzzles are great too, well conceived and perfectly implemented; they’re generally not obvious from the start, though always solvable through experimentation and a bit of pondering. The protagonist is the most charming character I’ve encountered so far in this year’s IFComp and I really hope I will meet her again in a sequel!

transcript.txt (51.4 KB)

1 Like

An egress by Viktor Sobol

Out is a puzzleless parser game that can be completed in less than two minutes, though it is worth stopping to explore the sights on your journey. The implication of the title and the blurb is what it seems to be, but although labeled as a slice-of-life it is actually much more. For such a short IF it is very deep and thoughtful and it surprised me in a good way.


The Secret of Vegibal Island
by Ralf Tauscher

I gave up on The Secret of Vegibal Island after 45 minutes. While the premise, the style and the parodic elements are great, there are serious bugs and language issues that make it hard to continue. Also, the walkthrough ends after the first part (of more than one) of the game. Most annoyingly, the language here seems to be the result of machine translation, which sometimes makes it hard even to understand the basic descriptions. I really hope this game gets a serious update with a proper translation, because I would love to play it in a finished form.

transcript.txt (116.9 KB)