State of Inform and Terps for Mac?

Old-timer here who was in the scene before and is coming back after a hiatus.

I’m on a Mac … and not much seems to work.

I figured out the interpreters I need ( but I tried playing some old (Infocom) and newer games. Of the terps listed on that page, Zoom shows nothing on the screen when a game starts, just the status line. Spatterlight does something very similar. I found Lectrote and it works for some stuff but gives me errors about “unsupported z-machine version 3” on many Infocom games and “unsupported z-machine version 5” on some others.

I tried playing around with Inform 7 a bit. The app as a whole works fine but when I actually try to execute any source code, no matter how small, I get nothing in the story window.

I ended up having to run WinFrotz (via Wine) to get games to play and I had to do the same with the Windows version of Inform. Not my first choice, but it’s workable.

So I guess the question is: does anything actually work on Mac directly? Alternate question: am I missing some prerequisite that needs to be installed for all of this to work?

Versions: Inform 7 (1.65.1), Zoom (1.1.5), Lectrote (1.1.7), Spatterlight (0.5.0).

You are correct that this is a particularly sucky moment for IF tools on the Mac. (As of MacOS 10.12.)

I have a working build of Gargoyle in this thread:

And people have successfully rebuilt the Mac I7 IDE, although I haven’t looked at that.

Lectrote uses Parchment, which should support all Z-machine version 5 games… as far as I know. (I just stuck it in there, I didn’t test it widely.) Which games aren’t working?

Ah, so this is a Sierra issue? Checked the Gargoyle you provided and it works just fine. Thanks for that.

I should note that for a new person coming in none of this is very obvious. A note about Sierra on the Interpreters page might be good? At least until everything is resolved. I did finally dig up the references to rebuilding Inform 7 from another thread I found here. That does work. Again, though, someone new popping in has to do some grunt work. (I remember the old days of IFArchive and so I don’t mind hopping around to find info or just asking but for the easily frustrated it might be a barrier.)

As far as Lectrote, I’ll do a check of what games weren’t working. Starcross definitely wasn’t and that gave a “version 3” error. Border Zone was another that didn’t work for me and that seemed to be a “version 5” issue. I’ll do a bit more investigation into that in case it helps.

I’ve added a new “MacOS 10.12” row to the interpreters chart on ifwiki. Would someone more knowledgeable than I am please confirm that the information in that row is correct?