Spring Thing

The Spring Thing 2013 games are now available for download. There are
three games this year:

Encyclopedia of Elementals (Quest)
A Roiling Original (Glulx)
Witch’s Girl (HTML / Twine)

You can find out everything you need to know at:

You’ll find the links to download the games on that page.

Anyone who plays the games and is willing to follow the voting rules
on the site may serve as a judge for the competition by voting on the

The deadline for voting is 11:59 PM EDT, Sunday, April 28, 2013. Winners
will be announced soon afterwards.

The details on how to submit your vote are at:

Feel free to contact me if there are any problems.


To all the players, have fun! To all the entrants, good luck!



(The links to the IF Archive apparently aren’t active yet, but the springthing versions are good.)

One of each system is pretty darn good.

Also, hey! A comp where there AREN’T more Inform games than the rest!

For “Witch’s Girl”, is there any way of saving your progress or does it need to be completed in a single go? When I bookmarked the page, it was blank when I went back to it.

Is there a way to play the Quest entry on a non-Windows computer? (Don’t say WINE.)

Having a little experience of Twine, I believe there is a feature that should allow variables to be stored in a cookie but it doesn’t actually work in the latest stable version of Twine (the software used to make Witch’s Girl). So as the game’s preamble warns, you need to leave the browser open or you’ll lose your progress. Hopefully when they fix the issue in Twine it’ll fix the game too, or maybe the author will need to re-release it.

If it can be uploaded to textadventures.co.uk then it can be played in a web browser.

I think there was some issue with this being against the rules last year though, for some reason.

The author would need to re-build/re-release it. All the magic is in about 30K of Javascript at the top of the HTML file.

Unfortunately, Twine development is basically stopped, at least the official branch (from what I’m seeing in the Google groups). There are a couple of people working on forks of the code right now - one of them does have an alpha which fixes fixes this issue.

Anyone made it all the way through Encyclopedia of Elementals? I seem to have hit a nasty bug pretty far into it. I’m at the fort, and the gate to my homeland is now open and guarded. It’s impossible to kill the guards, though,because combat always seems to break at this exact point. The game prompts for attacks and defense, but doesn’t actually register any results. Neither side hits the other, and the game just cycles ad infinitum. And there’s no way to withdraw from combat, as far as I can tell. Anyone else encounter this, or somehow made it past?

Hmmm, knowing Quest… have you tried the USE verb, like using a weapon? USEing it WITH a guard? I haven’t played it, but have you tried using the P&C commands? Sometimes, in some spots, in some games, they are easier to use than typing.

It’s not a verb issue in this case. I’ve had no trouble fighting everything else in the game. It’s just this particular combat where nothing happens, and it’s true whether I type or point and click.

Ok, just checking. Like I said, haven’t played it yet, was going from past frustrations on past Quest games. I’m actually glad to see it’s not an issue.

USE x WITH y is indeed the ticket at many points in the game, but alas, not here. Thanks anyway.

If anyone’s interested, I was able to get past it by (major spoiler)

casting Gust on the guards, which I could’ve sworn I’d already tried, and been told they weren’t a valid target. Maybe I’m just imagining it.

If you don’t have this available – and you very well may not, since you’re rewarded for using it earlier in this exact same scene – the game may be unwinnable at this point.

This, I suppose, is very basic:

How do I use the glow powder? I guess I am to USE it ON something, but ‘me’ is disallowed, my slippers have disappeared, the spellbook can’t be taken along, and almost everything else in the game is scenery/fixed in place. ‘Sprinkle powder’ (used in the description) is not recognised, ‘pour powder’ gives an error, ‘use powder on powder’ is disallowed, the pouch is not known, …Reading the white-on-white description tell me I feel walls, but USE powder ON wall (or walls) doesn’t work…Normally I’d let it percolate for some time, but because of the deadline I don’t want to spend too much time on it and then have less to evaluate the remainder of the game.

At the start you can simply USE GLOW, although at other points in the game you may need to USE GLOW WITH something.

Aha! In earlier rooms that didn’t work, in a way that tricked me into a thorough conviction that it would never work.
(Especially as the help text doesn’t mention this possibility either.)


I need a hint for The Encyclopedia of Elementals. My character’s aspect is light, so I have the glow powder.


I’m in the well, but it’s dark. When I use the glow powder, I get this response:
“The area is lit for just a second before the glow powder is neutralized in the water on the floor. You’ll need to get in a position to distribute the powder around the room without all of it getting in the water.”


  • paper
  • charcoal
  • glow powder
  • Encyclopedia of Elementals
  • magnet
  • gold

I’ve already tried using everything I have with everything else (and independently), but there is no luck. I don’t know of any other takeable objects on the map.

If I recall correctly:

It’s not what you have, but where you are.

USE GLOW WITH WELL while you’re still on the surface.

That’s clever. Thank you.