Sporadic crashes using Inform 7 on Mac OS X (Yosemite)?


I’m using Inform 7 (build 6L02) on Mac OS X Yosemite. I have noticed that recently (starting from about last week) Inform will suddenly freeze, and I’ll be unable to see what edits I’ve made. I can only get it running after I quit and reopen. Is this happening for anyone else? What troubleshooting could I do?

Thank you in advance!

Using Linux here (Mint 17, based on Ubuntu 14.04) and Inform7 crashes and quits frequently when I hit Ctrl-R to compile and run. Hopefully, it saves properly before and a few shortcuts bring me back in the action, but it is a mood killer :stuck_out_tongue: I use 6L38.

I thought this said sporadic rashes, and I was very confused.

When the app freezes, can you still open menus?

I… I don’t know. I’ll have to wait until it freezes again…

@craiglocke well that wouldn’t be too good either C:

You said you had to quit the app. Did you type cmd-Q or did you use the “Force Quit” option from the dock?

Cmd-Q. I realise I should have checked if it showed up as ‘Not Responding’ in the task manager. I didn’t.

If cmd-Q worked, then the app (and the menus) are responding normally. It must have been a problem with the text editing pane getting into a funny state.

I don’t recall a bug like this being reported. There was one recent Mac IDE bug where the Undo (text-editing) command stopped working, but regular typing wasn’t affected.

(Linux IDE bugs are unrelated – completely different software.)

I did report a Mac bug recently where using the documentation search features in particular ways could put the main panel into a non-responsive state. You could no longer type there, so the basic feeling was the app had frozen, but you could still QUIT the app with command-Q - the whole program hadn’t gone down.


I’ve experienced that - when the documentation search picker gets lost behind something.

The compiler sometimes hangs for no apparent reason. I hit PLAY>TEST ME and it errors out, but then I can hit compile again and it usually works.

I’d give MY KINGDOM for link arrows to to the source from error messages again.

I think I ran into this freeze just now while editing text in the IDE. It happened a couple of times, but (of course) now I can’t reproduce it.