[Solved] Raconteur / undum-commonjs

Hi EveryBody,
I write you from France, so I will do my best to write in a good english.
It’s my first post on this board, so I hope I don’t make mistake to post my problem in this section !
Because it’s my first post : I am Bertrand, 32 years old, I live in Lille (North of France). In France, CYOA isn’t very know, and I think it’s a big shame! So my goal is trying to make the IF closer to the readers.

I used to write Twine, so I am novice with undum and I would like to use Raconteur.
I followed step by step the Segue’s tutorial (very good, very explicit : thank you a lot). Nevertheless, Raconteur doesn’t work on my mac.

That’s my error :

MacBook-Pro-de-Bertrand:raconteur bertrand$ gulp serve [22:17:47] Using gulpfile ~/Desktop/raconteur/Gulpfile.js [22:17:47] Starting 'html'... [22:17:47] Starting 'img'... [22:17:47] Starting 'less'... [22:17:47] Finished 'less' after 2.02 ms [22:17:47] Starting 'buildUndum'... [22:17:47] Finished 'html' after 124 ms [22:17:47] Finished 'img' after 116 ms events.js:141 throw er; // Unhandled 'error' event ^ Error: Cannot find module 'undum-commonjs' from '/Users/bertrand/Desktop/raconteur' at /Users/bertrand/Desktop/raconteur/node_modules/resolve/lib/async.js:46:17 at process (/Users/bertrand/Desktop/raconteur/node_modules/resolve/lib/async.js:173:43) at ondir (/Users/bertrand/Desktop/raconteur/node_modules/resolve/lib/async.js:188:17) at load (/Users/bertrand/Desktop/raconteur/node_modules/resolve/lib/async.js:69:43) at onex (/Users/bertrand/Desktop/raconteur/node_modules/resolve/lib/async.js:92:31) at /Users/bertrand/Desktop/raconteur/node_modules/resolve/lib/async.js:22:47 at FSReqWrap.oncomplete (fs.js:82:15)

Due to “undum-commonjs”, I can’t use Raconteur…

I don’t know where I can find undum-commonjs. Please, if you could help me et explain me what i have to do, it will be very nice.



When you do “npm install”, what output do you get? The package.json file that comes in the scaffold should specify the undum-commonjs module (currently served from github and not npm).

npm is fickle and, frankly, kind of bad so it may fail to install a bunch of modules, and things are just breaking on the first uninstalled one that gets required.

It’s not npm’s fault (which I find very stable!) You’re requesting a git@ url, which I think will only work if you have a Github profile, and possibly only if your profile has access to the raconteur repo. You should change it to a https: url.

Any reason why you didn’t just publish undum to npm?

Thanks for your quick answers.

When I did “npm install”, I did it on my unzipped folder Raconteur-scaffold-master.

Following your advice, I create an account on Github and I go to the adresse : github.com/sequitur/undum#commonjs (specified in package.son),
it’s the undum-master repository. Is it here, that I can take undum-commonjs ? And how can I take it to instal it on Raconteur folder ?

Thanks a lot!

You don’t need a github profile for npm installs from github to work (and you definitely don’t need push access to the repo); it just makes npm use git clone instead of downloading from the npm repositories as normal, and you should be able to git clone that repository. It may be that it’s having problems with just installing undum-commonjs (in which case you should also have problems installing raconteur) or it may be that it’s breaking in some other way and undum-commonjs is just the first thing that isn’t installed. I find that, particularly under Windows, npm has trouble installing packages pretty often; I’ve had reports of it breaking when installing dependencies for Raconteur because an optional dependency can’t be installed and it doesn’t know how to proceed after that.

Again, if you do “npm install”, do you get any errors? Do you have git installed?


Problem Solved, it was due to the syntax with the file : package.json in the folder “raconteur-scallfold-master”.

I replace the line :

"undum": "git://github.com/sequitur/undum.git#commonjs",


"undum-commonjs": "git+https://github.com/sequitur/undum.git#commonjs"

and the install finished in good conditions.

Thanks a lot for your answers!

See ya !

Well the Github help page says:

And I know I’ve had trouble with non https urls in the past, so I was just suggesting it as it couldn’t be any worse but might solve the issues.

But a new thing I learned is that you can use a ‘GitHub url’ as the package version. That would surely be the most reliable way.

Yes, I’ll patch the scaffold to reflect that when I have the time. I believe this way of specifying github urls in package.json wasn’t available yet when Raconteur was released.