As far as I know, the standard way to write a rule that applies to any actor—player or not—is to use “an actor”.
Instead of an actor taking a container…
This is nicely documented in WI 12.14:
[With this syntax] the rule applies to anyone who tries taking a container, player or not.
However, the implementation of action patterns disagrees. Section 8 specifically delegates any syntax involving “an actor” to a phrase helpfully named “Anyone except the player”.
The behavior doesn’t seem to have changed in version 10; indeed, the Standard Rules still use the “an actor” syntax to have rules apply to everyone. So I have to wonder—are the phrase names and comments in the implementation just outdated, or misleading? Or am I just horribly misreading this?
It would seem so, both on the basis of the observed behaviour, and that the name of the documented enumerated outcome
ACTOR_EXP_UNIVERSAL would seem to be shorthand for ‘Explicitly stated universal actor’ - so the phrase should be named “Anyone including the player”
In my (very important) opinion, it should stay the way it was, since changing it would fail to deliver the intended program behaviour after compiling some of my code.