Screen reader issues with certain comp games

ifcomp2018

#1

Hi, I was hoping that one of the highly-knowledgeable people on here might be able to help me please. I’ve been playing through as many of the games in this year’s competition as I can and would like to complete a few more before the judging deadline. However, I am having a few issues with some of the games as they don’t seem to be compatible with my screen-reader. I use Jaws as a screen-reader and Internet Explorer as a browser (I know that sounds very old-school but I still find it gives me the best results for playing web-based games). I can generally access most Twine games but there are a few games which I am struggling with because of the way the links are handled. In some of the Twine games the clickable text is easily identified, it’s either presented as separate options at the bottom of the page or stands out as an individual indented line within a body of text, making it clear where you need to click. Unfortunately, there are a few games where the word you have to click is not identified in any meaningful way, I’m sure it is highlighted in some way if you can see the screen but I can’t see a way of getting the screen-reader to pick it out. Sometimes clicking randomly on words has got me through but this can be annoying and time-consuming when trying to make your way through a long game with extended bodies of text. Does anyone have any tips on how to get Jaws to pick out the relevant links within the text? There are a few games which just don’t seem to work with my screen reader at all, am I right in thinking that Texture is inaccessible or is there a way I can play those games? There are a couple of games which start off ok but which I have been unable to complete do to unknown issues. I am particularly struggling with ‘Animalia’ which seems to utterly stall once I reach the house. I have no idea what I need to click to continue, I’ve tried every available word but nothing seems to happen, am I missing something obvious? Any help would be very gratefully received. I’ve very much enjoyed the games I’ve played so far and hope to play a few more!


#2

Can you use the tab key to move from one hyperlink to another? - Jack


#3

Thanks for replying. I’ve tried using the tab key but it doesn’t seem to want to take me to links embedded in the text, only links on separate lines.


#4

Hi Sarah, I wrote Animalia – I’m very sorry you’ve been struggling to proceed, and I’m sorry that the design of the game isn’t more accommodating to those using screen readers. I’m working on a solution, but in the meantime, can you tell me what you mean when you say the game stalls when you reach the house? Do you mean when you actually get inside the house, or reach the front door?


#5

Hi imw, thanks for your reply. I’ve re-started the game a few times to see if there was a way around the issue. The first time the game stalled when I attempted to jump over the wall or walk through the gate with the wrong selection of animals. The second time it stalled when I rang the doorbell and waited for someone to answer. the dialogue of the parents inside the house appeared but I couldn’t proceed. The other times the game stalled near the beginning of conversations with the parents. Hope that helps but if I’ve not made it clear then please let me know and I can try and be more specific.


#6

Hm… in my experience testing just now in Internet Explorer, the tab button will take you to links embedded within the text (as well as status, save, and load), but it seems as though the game gets hung up occasionally when you click a link. The subsequent text, which contain the links to continue, will appear and then vanish – might be an issue with the transition animation in Internet Explorer? You can get it back by clicking anywhere in the main game window, but of course that doesn’t help you if you’re using a screen reader.

This is a poor solution for the moment, but I would recommend trying another browser while I look into this further, if you can. Sorry about this! Thanks for getting back to me.