Running Wabewalker

I installed Java to play Wabewalker, but when I try to run the .jar file, I get “Error: A JNI error has occured, please check your installation and try again.”

The Java program says I have the most recent version of Java installed. Does anybody know how to resolve this?

1 Like

Which version of Java do you have installed? And is the version you installed recently also the version that’s first in the system PATH?

I’m asking because, if I remember correctly, Oracle at some time discontinued the old updater, I think with/after Java 8 (also called 1.8). It would report that there was no update available, which was true for the 1.8 line, but not true in the general sense.
And also, if you installed that version at some previous time, it might be the one that is first in the system path, and thus called in precedence to a later version.

The current version is Java 17, available from the Oracle website, or from here: JDK 17 GA Release

And the game does need a really recent version. I thought I’d be fine with Java 15, but no:

java.lang.UnsupportedClassVersionError: Wabewalker has been compiled by a more recent version of the Java Runtime (class file version 60.0), this version of the Java Runtime only recognizes class file versions up to 59.0

“Class file version 60.0” corresponds to Java 16, so either 16 or 17 will be fine.

4 Likes

I ended up playing this game on two computers. The first never had Java, so I installed Java 17 and it ran perfectly.

The second already had Java 8, which it said was up to date, but it wouldn’t play the game. I downloaded and installed Java 17, and still nothing happened to make the game work. So I moved the game file to the Java 17 folder and ran the command prompt from inside that folder, and that worked.

2 Likes

Heh, I got Java 8 from java.com. Why is that website still up?

Anyway, now uninstalled it and installed the up-to-date version. Will play Wabewalker when I get off work.

1 Like

thanks for the awesome information.

2 Likes

Played this game with Java 17. Collected all symbols and mantras. Performed meditation in one shrine. When I tried to visualize symbol for 2nd shrine I got response that I didn’t memorized that symbol, although “memory” command list all symbols and mantras as memorized.

Now I wonder is it some technical issue or I miss something in game? Anyone experienced something similar?

1 Like

My own observations:

I got it to run on Windows. I wound up downloading the wrong SDK a few times.

Java Downloads | Oracle is where I went. The anchor for #jdk17-windows makes sure you get the Windows download.

Stackoverflow.com reports and questions seem to indicate that you really want to uninstall (I had JDK 8 installed) and change the environment paths, especially on Windows 10. For those not technically inclined, that means you can push the windows button then type UNINSTALL. or you can push it and then type ENV. You probably want to have the common directory on top, as the screenshots show. Also, the right paths will probably be in the system variables, but they may be in your own user variables.

collapsed so graphics don't hog the thread

412x468

Edo, did you figure out what went wrong? No one else has experienced that. I’ll write below what the three symbols are and how they are spelled:

ENDLESS KNOT (ENDLESS or KNOT also work individually), LOTUS FLOWER (LOTUS or FLOWER also work individually), and GOLDEN FISH (GOLDEN and FISH also work individually).

No I didn’t figure it out. I was able to visualize just one symbol. I did find all three of them, and “memory” command recognized that, but when I tried to visualize 2nd or 3rd symbol in their respective shrines I got response that I didn’t memorize those symbols.

I reached bad ending because my PC was killed and “there was no ningyo alive who can receive your spirit”, so I got some closure for the game. :slight_smile:

I found the bug, and fixed it. Thank you for pointing it out Edo, and my apologies you encountered that. I credited your name in the “Playtesting and Feedback” section of the credits.

2 Likes

Glad you could fix that! And thank you for the credit :slight_smile: :+1: